Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как получить предыдущее значение периодического реквизита

v7: Как получить предыдущее значение периодического реквизита
Я
   1сЮлия
 
25.12.12 - 12:08
У меня имеется периодический реквизит СменаФамилии мне нужно чтобы в переменную ПредыдФамилия выводилась предыдущая фамилия например была Сидорова стала Иванова в переменную ПредыдФамилия вывело значение Сидорова,а допустим после Ивановой стала Петровой и переменной ПредыдФамилия присвоилось значение Иванова я использую
ИсторияЗнач=СоздатьОбъект("Периодический");
ИсторияЗнач.ИспользоватьОбъект("СменаФамилии",ТекущийЭлемент());
ИсторияЗнач.ОбратныйПорядок(1);
ИсторияЗнач.ВыбратьЗначения(НачГода(РабочаяДата()),КонГода(РабочаяДата()))
   ПОКА ИсторияЗнач.ПолучитьЗначение()=1 Цикл
СменаФамилии=ИсторияЗнач.Значение;
как мне спозиционироваться на втором элементе выборки
   КонецЦикла
 
 
   Mikeware
 
1 - 25.12.12 - 12:10
программиста позвать...
   Ёпрст
 
2 - 25.12.12 - 12:10
(0)

//ПОКА ИсторияЗнач.ПолучитьЗначение()=1 Цикл
 

ИсторияЗнач.ПолучитьЗначение();
ИсторияЗнач.ПолучитьЗначение();

наслаждайся
   cw014
 
3 - 25.12.12 - 12:13
(0)
Если ИсторияЗнач.ПолучитьЗначение() = 1 тогда
СменаФамилии = ИсторияЗнач.Значение;
КонецЕсли;
Если ИсторияЗнач.ПолучитьЗначение() = 1 тогда
ПредыдФамилия = ИсторияЗнач.Значение;
КонецЕсли;
   zak555
 
4 - 25.12.12 - 12:13
юрияЦветочек ?
   zak555
 
5 - 25.12.12 - 12:18
РС сведений
   1Сергей
 
6 - 25.12.12 - 12:22
(5) чо???
   1сЮлия
 
7 - 25.12.12 - 12:23
Всё получилось.Спасибо огромное!!!
   zak555
 
8 - 25.12.12 - 12:24
   1Сергей
 
9 - 25.12.12 - 12:37
(8) ок, теперь расшифруй "РС сведений"
   zak555
 
10 - 25.12.12 - 12:38
(9) "В новой версии V8 предлагается вместо периодических реквизитов использовать регистры сведений...."
 
 Рекламное место пустует
   cw014
 
11 - 25.12.12 - 12:40
(10) Регистр сведений - сокращенно РС...
в (5) Ты написал РС сведений - это у тебя Регистр сведений сведений???
   cw014
 
12 - 25.12.12 - 12:41
(10) Как в Интернах:
- Я что должен пить коньяк "Коньяк"???
   1Сергей
 
13 - 25.12.12 - 12:41
(10) ну, это типа СиДи-дисков. Вроде, всем понятно. а начинаешь расшифровывать - масло масляное... :)
   zak555
 
14 - 25.12.12 - 12:42
=)
   zak555
 
15 - 25.12.12 - 12:42
не проснулся ещё

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует