Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Отчет на основании проводок

Я
   Filosof
 
25.12.12 - 12:08
Отчет на основании проводок формируется некорректно. только после перепроведения документов формируется нормально.
 
 
   zak555
 
1 - 25.12.12 - 12:08
херовый отчёт и/или логика проведения дока
   cw014
 
2 - 25.12.12 - 12:09
Видимо сами проводки сформированы не корректно, только после перепроведения они становятся корректными
   Filosof
 
3 - 25.12.12 - 12:17
(2)как проводки могут после перепроведения стать нормальными а до перепроведения быть некорректными?
   cw014
 
4 - 25.12.12 - 12:18
(3) Кривой механизм формирования проводок. Потом поправили, а документы не перепровели
   cw014
 
5 - 25.12.12 - 12:18
(3) Один из вариантов
   cw014
 
6 - 25.12.12 - 12:18
(3) Условия по которому формировались проводки до определенного момента были одни, потом что-то поменялось (вид номенклатуры у номенклатуры, галка в настройках, еще что нибудь) и проводки стали неактуальными
   cw014
 
7 - 25.12.12 - 12:18
(3) Второй вариант
   Filosof
 
8 - 25.12.12 - 12:35
(4) (6) Ни первый ни второй вариант не подходят. механизм проведения документов не изменялся.
   zak555
 
9 - 25.12.12 - 12:37
(8) ты код покажи
   Filosof
 
10 - 26.12.12 - 10:46
Код будет позже
 
 Рекламное место пустует
   Filosof
 
11 - 26.12.12 - 10:52
Опер=СоздатьОбъект("Операция");
        
Если Крой=1 тогда    
    Док=СоздатьОбъект("Документ.ВРаскройНовый");
    Док.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);

    
    Пока Док.ПолучитьДокумент()=1 цикл
     Если Док.Проведен()=1 тогда
         Док.ВыбратьСтроки();
         Если  Док.ПолучитьСтроку()=1 тогда
         Материал=Док.ТМЦ;    
         КонецЕсли;    
        
         Если Полуфабрикат.Выбран()=1 тогда
        
    Опер.НайтиОперацию(Док.ТекущийДокумент());
    Опер.ВыбратьПроводки();
    Пока Опер.ПолучитьПроводку()=1 цикл

    Если (Опер.Дебет.Счет=СчетПоКоду(203)) И (Полуфабрикат=Опер.Дебет.Субконто(2)) тогда
        Таб1.НоваяСтрока();
        Таб1.Изделие=Опер.Дебет.Субконто(2);
        Таб1.Материал=Материал;
        Таб1.ИзделиеКво=Опер.Количество; 
        Таб1.ИзделиеСумма=Опер.Сумма;
    КонецЕсли;
   КонецЦикла;
   Filosof
 
12 - 26.12.12 - 12:23
Никто ничего не скажет?
   Classic
 
13 - 26.12.12 - 12:27
Какой ужас
   Classic
 
14 - 26.12.12 - 12:27
А по теме. Если после перепроведения показывает правильно, значит перепроведение дало другие проводки. Так что смотри почему у тебя после перепроведения меняются проводки
   Ёпрст
 
15 - 26.12.12 - 12:28
не не так..

Полный ПЭ!
   Filosof
 
16 - 26.12.12 - 12:42
(14)Дело в том что непонятно после первого или второго перепроведения а может и третьего. То есть  при неизменных модуле отчета и процедуре проведения документа почему-то отчет выдает разные результаты.Хотя проводки остаются неизменными.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует