Вход | Регистрация


1С:Предприятие ::

Метки: 

Вопрос по ТЗ.НайтиСтроки()

Я
   kisskiss
 
25.12.12 - 10:56
1. запросом к таблице значений100% (2)
2. перебором в цикле0% (0)
3. несколько раз НайтиСтроки0% (0)
Всего мнений: 2

Как с помощью конструкции НайтиСтроки в таблице значений найти все строки, у которых в колонке "ФизЛицо" будет или Петров, или Иванов, или Сидоров?
 
 
   Утконос
 
1 - 25.12.12 - 10:57
Соответствие тебе в помощь
   ZanderZ
 
2 - 25.12.12 - 10:58
никак, только отдельно 3-и раза искать или запросом
   Нуф-Нуф
 
3 - 25.12.12 - 10:58
запрос
   regniws
 
4 - 25.12.12 - 10:59
(1) ндээ...

(0) тз в вт запроса.
   pessok
 
5 - 25.12.12 - 10:59
(0) в твоем случае (3)
   ДенисЧ
 
6 - 25.12.12 - 10:59
запрос лучше всего
   GANR
 
7 - 25.12.12 - 10:59
Отбор = Новый Структура;
Отбор.Вставить("ФизЛицо", Петров);
СтрокиПетров = ТЗ.НайтиСтроки(Отбор);
Отбор.Вставить("ФизЛицо", Иванов);
СтрокиИванов = ТЗ.НайтиСтроки(Отбор);
Отбор.Вставить("ФизЛицо", Сидоров);
СтрокиСидоров = ТЗ.НайтиСтроки(Отбор);
   Ursus maritimus
 
8 - 25.12.12 - 10:59
Запрос уже предлагали?
   kisskiss
 
9 - 25.12.12 - 10:59
(2) а можно поподробнее, желательно кодик написать ... для наглядности...
   GANR
 
10 - 25.12.12 - 11:00
(0) НайтиСтроки по прнципу ИЛИ не отбирает
 
 Рекламное место пустует
   Serginio1
 
11 - 25.12.12 - 11:00
   YHVVH
 
12 - 25.12.12 - 11:02
(1) чаго?
   Cube
 
13 - 25.12.12 - 11:03
   ptiz
 
14 - 25.12.12 - 11:03
(0) Построитель тебе в помощь.
   kisskiss
 
15 - 25.12.12 - 11:08
Ога, понятно
В итоге получено несколько групп советов:
1) (8) запросом к таблице значений
2) (11) перебором в цикле
3) (7) несколько раз НайтиСтроки 
Думаю подойдет :) Спасибо!
   Reset
 
16 - 25.12.12 - 11:10
Отобранные=ТЗ.СкопироватьКолонки();
Для каждого ПроверяемаяСтрока из ТЗ цикл
  Если ПроверяемаяСтрока.ФизЛицо=Иванов
    или ПроверяемаяСтрока.ФизЛицо=Сидоров
    или ПроверяемаяСтрока.ФизЛицо=Петров тогда
ЗаполнитьЗначенияСвойств(Отобранные.Добавить(),ПроверяемаяСтрока);
  КонецЕсли;
КонецЦикла;
   Нуф-Нуф
 
17 - 25.12.12 - 11:11
юзай запрос. будь мужиком, блеать!
   МихаилМ
 
18 - 25.12.12 - 11:13
скд
   Нуф-Нуф
 
19 - 25.12.12 - 11:14
кстати. на фотке тема сисек не раскрыта
   wowik
 
20 - 25.12.12 - 11:16
(19) +1
   kisskiss
 
21 - 25.12.12 - 11:21
   Cube
 
22 - 25.12.12 - 11:23
(21) О, так вставляй её в профиль!) Помощь на мисте будет ещё оперативнее)
   wowik
 
23 - 25.12.12 - 11:30
еще email желательно оставить и город проживания. ну так, на всякий...
   cw014
 
24 - 25.12.12 - 11:31
ИМХО

1. запросом к таблице значений
   Serginio1
 
25 - 25.12.12 - 11:50
Новаятз=СкопироватьПоУсловию(Тз,"Стр.НужнаяКолонка<0");
11


  Evrepid
 

8 - 07.12.12 - 19:07 


Почему только запросом?
Перебор все еще имеет большие силы для этого... :)
10


  Serginio1
 

9 - 07.12.12 - 19:30 


Функция НайтиПоУсловию(Тз,Условие,Список="")
 Массив новый массив;
 Для каждого Стр из Тз Цикл
   Если Вычислить(Условие) Тогда
     массив.Добавить(стр)
   КонецЕсли
 КонецЦикла;
возврат Тз.Скопировать(массив)
КонецФункции

Рез=НайтиПоУсловию(тз,"стр.ФизЛицо=""Иванов""
    или стр.ФизЛицо=""Сидоров""
    или стр.ФизЛицо=""Петров""");
 
или
 Список=ОбщегоНазначение.РазложитьСтрокуВМассивПодстрок("Иванов,Сидоров,Петров");

Рез=НайтиПоУсловию(тз,"Список.Найти(стр.ФизЛицо)<>Неопределено");
   Serginio1
 
26 - 25.12.12 - 11:51
Для последнего
Рез=НайтиПоУсловию(тз,"Список.Найти(стр.ФизЛицо)<>Неопределено",Список);
   Serginio1
 
27 - 25.12.12 - 11:52
Нужно добавить выбор использование функции с перебором с передачей в нее условий с данными
   Serginio1
 
28 - 25.12.12 - 12:25
Можно еще извратиться. Создать в модуле (обработки,документа итд) ЭтаФорма Функцию

И передать
Фрм=ВнешниеОбработки.Создать(ПутьКОбработке);
НайтиПоУсловию(Тз,"Список.ФункцияВМодуле(стр)",фрм);
   GANR
 
29 - 25.12.12 - 12:25
но это противоречит изначальному условию
>с помощью конструкции НайтиСтроки

1. запросом к таблице значений
   Serginio1
 
30 - 25.12.12 - 12:26
(29) И тубудешь в запросе устанавливать флаг нужной записи?
   GANR
 
31 - 25.12.12 - 12:31
(30) А вообще нужно уточнить задачу.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует