Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УПП. РТУ. как формируются проводки по товарам?

УПП. РТУ. как формируются проводки по товарам?
Я
   lostkiker
 
24.12.12 - 17:25
В отладке не видны проводки по товарам, сделал подписку на событие (обработка проведения) там проводок тоже нет, но док формирует эти проводки. В чем дело?
 
 
   ДенисЧ
 
1 - 24.12.12 - 17:27
В подписках.
   lostkiker
 
2 - 24.12.12 - 17:28
там тоже не нашел
   DEVIce
 
3 - 24.12.12 - 17:29
(0) Я с этой хренью долго бодался. Что интересно, если проводить документ из формы документа, то в подписке то есть записанные проводки, то нет их ровно поочередно (есть-нет-есть-нет), а если проводить из формы списка, через действия например, то всегда есть, или если сначала распровести документ, а потом провести, то тоже всегда есть. Это глюк платформы. Хотя господа разработчики говорят, что в подписке нельзя предполагать что все транзакции завершены и можно пользоваться результатами проведения модуля документа или более ранними подписками.
   DEVIce
 
4 - 24.12.12 - 17:31
(2) И еще, не менее интересно. В некоторых случаях проведение при отладке как раз всегда показывает что есть, а без отладки через раз. Это всяко какая-то несогласованность транзакций сервера предприятия и скуля. Та же хрень и в файловой версии, которая по сути тоже клиент-серверная.
   lostkiker
 
5 - 24.12.12 - 17:32
а где док формирует проводки, я код так и не нашел?
   DEVIce
 
6 - 24.12.12 - 17:33
(5) Это делается после распределения по партиям, точно не помню, возможно в том же модуле что и распределяет партии.
   DEVIce
 
7 - 24.12.12 - 17:34
Т.е. молодцы в 1С что придумали подписки, но они работают неоднозначно, что в некоторых случаях делает невозможным их применение.
   lostkiker
 
8 - 24.12.12 - 17:37
(4) у меня в отладке ни разу не показало что проводки есть ни в подписке ни в модуле.
   DEVIce
 
9 - 24.12.12 - 17:39
(8) О чем и речь, никто ничего не гарантирует.
   Serg_1960
 
10 - 24.12.12 - 17:43
УПП. РТУ. РАУЗ?
 
 Рекламное место пустует
   lostkiker
 
11 - 24.12.12 - 17:47
(10) нет не рауз
   lostkiker
 
12 - 24.12.12 - 17:49
В конце модуля обработка проведения таблица товары запихивается в переменную "Дополнительные свойства" и в комментах пишется, чтобы она была доступна из подписок. Только что это за переменная я не понимаю. Может проводки все таки где то в подписке формируются? потому что в модулях кода не нахожу
   Serg_1960
 
13 - 24.12.12 - 17:50
ОбработкаПроведения - ДвиженияПоРегистрам() - например, ДвиженияПоРегистрамУпр() - и далее запись в регистры идет через такие конструкции (последняя строка - то что тебе надо):
...
ТаблицыДанныхДокумента = ОбщегоНазначения.ЗагрузитьТаблицыДокументаВСтруктуру(...);
ОбщегоНазначения.УстановитьЗначениеВТаблицыДокумента(...);
ОбщегоНазначения.ЗаписатьТаблицыДокументаВРегистр(...);
   lostkiker
 
14 - 24.12.12 - 17:56
(13) в ДвиженияПоРегистрамУпр нет движений по хозрасчетному, по хозрасчетному движения формируются в ДвиженияПоРегистрамУпр(), но там только по услугам, по товарам нет.
   lostkiker
 
15 - 24.12.12 - 17:57
(14) ДвиженияПоРегистрамУпр() -> ДвиженияПоРегистрамРегл()
   DrShad
 
16 - 24.12.12 - 17:57
ВыполнитьСписаниеПартий* что-то такое ищи там все
   DrShad
 
17 - 24.12.12 - 17:58
и вообще с какой целью ты их ищешь?
   lostkiker
 
18 - 24.12.12 - 18:03
(17) мне нужно заполнить доп. субконто на счете. Сделал подписку, а там проводки не видны
   lostkiker
 
19 - 24.12.12 - 18:07
(17) в подписке смотрю через Источник.Движения
   lostkiker
 
20 - 24.12.12 - 18:10
Попробую подписку сделать на регистр бухгалтерии перед записью
   Serg_1960
 
21 - 24.12.12 - 18:13
(14) Ты бы ещё позднее уточнил что и где ты ищещь :(
        Если НЕ глЗначениеПеременной("ПараметрыПартионногоУчета").СписыватьПартииПриПроведенииДокументовБух Тогда
            
            Для каждого СтрокаТовара Из ТаблицаПоТоварам Цикл
                Если СтрокаТовара.ПринадлежностьНоменклатуры <> Перечисления.ПринадлежностьНоменклатуры.Принятый Тогда
                    НоваяСтрокаВыручки = ТаблицаВыручкиДляБУ.Добавить();
                    ЗаполнитьЗначенияСвойств(НоваяСтрокаВыручки, СтрокаТовара);
                    НоваяСтрокаВыручки.СписаниеПартий = Истина;
                КонецЕсли;    
            КонецЦикла;
            
        КонецЕсли;
   lostkiker
 
22 - 24.12.12 - 18:18
(21) спасибо!! кусок кода нашел, завтра разберусь


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует