Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Доступ к подчиненному справочнику из запроса

v7: Доступ к подчиненному справочнику из запроса
Я
   bananan
 
24.12.12 - 17:13
Есть запрос такой:
Период с ДатаС по ДатаПо;
                    |ОбрабатыватьДокументы Проведенные;
                    |Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
                    |Код = Документ.РасходнаяНакладная.ТМЦ.Код, Документ.РасходнаяНакладнаяН.ТМЦ.Код;
                    |ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
                    |Функция Колво = Сумма(Количество);
                    |Группировка Документ;
                    |Группировка ТМЦ;
                    |Условие (ТМЦ в выбТМЦ);";
Я пробывал так:
    |ПодчСпр=Справочник.ДополнительныеСведения.ТекущийЭлемент;
                     |Условие(ПодчСпр.Владелец=ТМЦ);";
Выдает:
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС.ERT(93)}: ПодчСпр=Справочник. <<?>> ДополнительныеСведения.ТекущийЭлемент;
Запрос[10] : Неверно заданный путь 'ДополнительныеСведения'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС.ERT(93)}: Условие(ПодчСпр.Владелец=ТМЦ <<?>> );
Запрос[11] : Ошибка в услови
Т.е. как мне правильно обратиться к подчиненному справочнику?
 
 
   Ёпрст
 
1 - 24.12.12 - 17:14
зачем ?
   Sh1ko
 
2 - 24.12.12 - 17:14
Не совсем понятно каким боков подчиненный справочник к запросу по документам.
   bananan
 
3 - 24.12.12 - 17:15
Шеф сказал что нужно делть так. Хотя оно у меня и без обрщения из запроса работает нормально. но, я здесь пока 3-й день и спорить с шефом как-то не выходит...
   Sh1ko
 
4 - 24.12.12 - 17:16
(3) Тебе шеф именно строку запроса продиктовал?
   КонецЦикла
 
5 - 24.12.12 - 17:16
(0) Освой, наконец, конструктор запросов
Он не позволит писать дебильные запросы
   bananan
 
6 - 24.12.12 - 17:16
(2) В документе (табличная часть) есть номенклатура (справочник ТМЦ), ей и подчинен справочник ЕдИзм
   ДенисЧ
 
7 - 24.12.12 - 17:17
|ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ,Справочник.ДополнительныеСведения.Владелец;

 
...
   palpetrovich
 
8 - 24.12.12 - 17:17
это просто праздник какой-то (цы) :)
   bananan
 
9 - 24.12.12 - 17:17
(5) Освоить как? - методом тыка?
   Ёпрст
 
10 - 24.12.12 - 17:17
(6) Шо опять ?

Предыдущие темы пишет твой клон, или твой шеф ?
 
 Рекламное место пустует
   bananan
 
11 - 24.12.12 - 17:18
(10) Клон
   Sh1ko
 
12 - 24.12.12 - 17:18
(6) Ок, а при чем тут Справочник.ДополнительныеСведения?
   Mikeware
 
13 - 24.12.12 - 17:18
(5) ему - позволит :-)
   bananan
 
14 - 24.12.12 - 17:18
Да просто-напросто покажите как это сделать
   Sh1ko
 
15 - 24.12.12 - 17:18
(14) Да просто-напросто сформулируй задачу, которую тебе поставил шеф
   bananan
 
16 - 24.12.12 - 17:19
(12) Увидел такое обращение к подчиненному справочнику в какой-то ветке на даном форуме
   Sh1ko
 
17 - 24.12.12 - 17:19
(16) Зашибись ты придумал.
   bananan
 
18 - 24.12.12 - 17:20
(15) в документах количество указывается в разныз еденицах измерения, мне нужно показать сколько в ящиках продано даного ТМЦ, сколько в ящиках продано по даному документу и сколько в ящиках по всех документах за даный период
   Ёпрст
 
19 - 24.12.12 - 17:21
(18) читай (52) пост в предудыщей серии, клону привет!
   bananan
 
20 - 24.12.12 - 17:29
(19) Сейчас  еще раз прочитал НЕ ПОНИМАЮ каким образом ті вічисляещб коєффициент
|Коэффициент = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН.Сумма;
бвлеберда какая-то а не коеффициент
   bananan
 
21 - 24.12.12 - 17:30
(19) У Тебя коэффициент РАВЕН сумме документа, это как и на каком языке?
   Ёпрст
 
22 - 24.12.12 - 17:32
(20) читай ниже
   Ёпрст
 
23 - 24.12.12 - 17:33
(101) пост
   bananan
 
24 - 24.12.12 - 17:33
(19) и ко всему прочему код, который ты дал выдает:
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС013.ERT(98)}: Функция Колво = Сумма(Количество*Коэффициент <<?>> );
Запрос[6] : Ошибка в выражении 'Коэффициент'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС013.ERT(98)}: Функция КоличествоЯщиков = Сумма(ПересчетВЯщики(ТМЦ,Количество*Коэффициент <<?>> ));
Запрос[7] : Ошибка в выражении 'Коэффициент'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС013.ERT(98)}: Условие (ТМЦ в выбТМЦ <<?>> );
Запрос[10] : Ошибка в условии
   Ёпрст
 
25 - 24.12.12 - 17:35
(24) дай мд в архиве посмотреть.
   bananan
 
26 - 24.12.12 - 17:36
(23) а |Коэффициент = Документ.РасходнаяНакладная.Коэффициент, Документ.РасходнаяНакладнаяН.Коэффициент;

выдаст совсем не тот коэффициент. который надо, а надо коефициент для едюизмерения ящик к данной еденице измерения (которая указана в расходной накладной)
   bananan
 
27 - 24.12.12 - 17:37
(25) Сори что туплю, а как это сделать?
   Ёпрст
 
28 - 24.12.12 - 17:37
(27) открыть каталог с базой в проводнике, найти в нём файл 1cv7.md, закинуть в архив, далее на файлопомойку, ссылку сюда
   palpetrovich
 
29 - 24.12.12 - 17:38
(26) даст именно тот что в РасходнаяНакладная или РасходнаяНакладнаяН
   bananan
 
30 - 24.12.12 - 17:38
(28) адрес како-нибудь файломойки
   Ёпрст
 
31 - 24.12.12 - 17:38
(26) какой догадливый. Угадай, для чего этот коэффициент вообще введен в табличную часть документа ?
   Ёпрст
 
32 - 24.12.12 - 17:38
ifolder.ru
   Sh1ko
 
33 - 24.12.12 - 17:40
Походу кончится тем, что Епрст приедет в Ровно, и сделает все сам.
 
 
   bananan
 
34 - 24.12.12 - 17:42
   palpetrovich
 
35 - 24.12.12 - 17:44
(33) приезжать-то зачем? ...бывают  моменты когда совпадают свободное время и приступ благотворительности  ;)
   palpetrovich
 
36 - 24.12.12 - 17:45
(34) браво, "закинуть в архив" - как-то незаметно было написано :)))
   bananan
 
37 - 24.12.12 - 17:47
(36) пардон сча кину в архиве
   Sh1ko
 
38 - 24.12.12 - 17:48
как архивировать в курсе?
   Mikeware
 
39 - 24.12.12 - 17:49
(35) приезжать - это когда в один момент совпадет свободное время и приступ ярости...
   bananan
 
40 - 24.12.12 - 17:50
   palpetrovich
 
41 - 24.12.12 - 17:51
(39) :)
   bananan
 
42 - 24.12.12 - 17:52
(28) http://rusfolder.com/34266012
так пойдет?
   Ёпрст
 
43 - 24.12.12 - 17:53
Перем Спр;
 //======================================================================
 
Функция ПересчетВЯщики(ТМЦ,Количество)
    Спр.ИспользоватьВладельца(ТМЦ);
  // Спр.ВыбратьЭлементыПоРеквизиту("Ед",Перечисление.Единицы.ящик,1,0);
 
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если (Спр.ПометкаУдаления()=0)И(Спр.Ед = Перечисление.Единицы.ящик) Тогда
            Возврат Количество/?(Спр.Коэффициент=0,1,Спр.Коэффициент);
        КонецЕсли;
    КонецЦикла;
    Возврат Количество;
КонецФункции// 
 
Процедура Сформировать()
    Спр = СоздатьОбъект("Справочник.ЕдИзм");
    ТекстЗапроса = "
    |Период с НачДата По КонДата;
    |Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
    |Коэффициент = Документ.РасходнаяНакладная.Коэффициент, Документ.РасходнаяНакладнаяН.Коэффициент;
    |ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
    |Функция Колво = Сумма(Количество*Коэффициент);
    |Функция КоличествоЯщиков = Сумма(Количество-Количество+ПересчетВЯщики(ТМЦ,Количество*Коэффициент));
    |Группировка Документ;
    |Группировка ТМЦ;
    |Условие (ТМЦ в выбТМЦ);";
   Ёпрст
 
44 - 24.12.12 - 17:53
на, наслаждайся
   palpetrovich
 
45 - 24.12.12 - 17:57
(44) наслаждение боюсь будет неполным ибо где "Таб.ВывестиСекцию("ТМЦ")" и т.д. :)
   bananan
 
46 - 24.12.12 - 17:57
(43) В результате выдал мне
АТ-0039294        
товар кг        Количество
товар шт        Количество
товар ящ        Количество
Всего по документу        0
АТ-0039295        
товар шт        Количество
Всего по документу        0
АТ-0039296        
товар ящ        Количество
Всего по документу        0
ну и т.д.
   bananan
 
47 - 24.12.12 - 17:58
в окне сообщений выдал :
   bananan
 
48 - 24.12.12 - 17:58
Количество<<?>>
Переменная не определена (Количество)
Количество<<?>>
ну и т.д.
   bananan
 
49 - 24.12.12 - 18:01
Извениете с этим разобрался, а как теперь в этом же запросе считать к-во ящиков по документах и по всех документах - таким же образом написать функцию?
 
 Рекламное место пустует
   Sh1ko
 
50 - 24.12.12 - 18:02
(49) Группировка.
   Sh1ko
 
51 - 24.12.12 - 18:03
Открой желто-красную книжку и прочитай зачем в запросе группировки и функции
   palpetrovich
 
52 - 24.12.12 - 18:13
   bananan
 
53 - 24.12.12 - 18:20
(52) И что это за фигня, которая даже не работает:
   bananan
 
54 - 24.12.12 - 18:21
+(53) в ней несчитается сумма ящиков по документу ну и вообще по всех документах
   palpetrovich
 
55 - 25.12.12 - 14:01
(53) хамство детектед, все прекрасно работает http://rusfolder.com/foto/view_foto/0_fhlo6940rm/
и если уж так лень поправить пару строчек -  http://rusfolder.com/34279035
   Ёпрст
 
56 - 25.12.12 - 14:05
(55) это уже пройденный этап, уже на 1cpp автор подсел.

Подвинтесь, мастадонты!
   palpetrovich
 
57 - 25.12.12 - 14:09
(56) пипец, я уже боюсь :)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует