Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: ОLE соединение

v7: ОLE соединение
Я
   DeMi4
 
24.12.12 - 16:29
Подскажите почему такая вещь может не отрабатывать.
бПодразделение = ОЛЕ.Справочники.ПодразделенияОрганизаций.НайтиПоКоду( СокрЛП( тзДвижениеДС.КодПодразделения ) );
        Если бПодразделение.Пустая() = -1 Тогда
            Сообщить("БУХ: Не найдено подразделение!!!","!");
        КонецЕсли;
        бСтатьяДвиженияДенежныхСредств = ОЛЕ.Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду( СокрЛП( тзДвижениеДС.КодСтатьиДДС) );
        Если бСтатьяДвиженияДенежныхСредств.Пустая() = -1 Тогда
            Сообщить("БУХ: Не найдена статья движения денежных средств склад!!!","!");
        КонецЕсли;
        бДатаДок = глФорматДаты(тзДвижениеДС.ДатаДвижения,,1) + "120000";
        
        бПКО = "";
        бВыборка = ОЛЕ.Документы.ПриходныйКассовыйОрдер.Выбрать(бДатаДок,бДатаДок);
        Пока бВыборка.Следующий() = -1 Цикл
            Если Найти(бВыборка.Комментарий, бКомментарий) > 0 Тогда
                Сообщить(бВыборка.ПодразделениеОрганизации);
                Сообщить(бПодразделение);
                Если бВыборка.ПодразделениеОрганизации = бПодразделение Тогда
                    Сообщить(бВыборка.СтатьяДвиженияДенежныхСредств);
                    Сообщить(бСтатьяДвиженияДенежныхСредств);
                    Если бВыборка.СтатьяДвиженияДенежныхСредств = бСтатьяДвиженияДенежныхСредств Тогда
                        бПКО = бВыборка.ПолучитьОбъект();
                        Прервать;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
 
 
   Deon
 
1 - 24.12.12 - 16:30
в каком месте-то не работает?
   DeMi4
 
2 - 24.12.12 - 16:30
не могу получить бПКО
Дольше проверки комментария не идет в условия
   DeMi4
 
3 - 24.12.12 - 16:30
Перебор выборки
   Patrio_O_Muerte
 
4 - 24.12.12 - 16:31
Убери явное определение переменной бПКО
   Deon
 
5 - 24.12.12 - 16:32
(3) А Сообщить чего выдают?
   Patrio_O_Muerte
 
6 - 24.12.12 - 16:33
бПКО = бВыборка.ПолучитьОбъект();
Сюда доходит хоть ? Или даже в условие не заходит?
   DeMi4
 
7 - 24.12.12 - 16:33
OLE
   DeMi4
 
8 - 24.12.12 - 16:34
Заходить только в условие
Если Найти(бВыборка.Комментарий, бКомментарий) > 0 Тогда
   Deon
 
9 - 24.12.12 - 16:35
(7) Слушай, а разве можно сравнивать 2 оле объекта? Разве надо сравнивать не их реквизиты не ссылочного типа?
   Patrio_O_Muerte
 
10 - 24.12.12 - 16:35
Если бВыборка.ПодразделениеОрганизации = бПодразделение Тогда
То есть сюда заходит? 
Если бВыборка.СтатьяДвиженияДенежныхСредств = бСтатьяДвиженияДенежныхСредств Тогда
А сюда нет?
 
 Рекламное место пустует
   Patrio_O_Muerte
 
11 - 24.12.12 - 16:36
Да и в ОЛЕ я б коды сравнивал...
   Patrio_O_Muerte
 
12 - 24.12.12 - 16:36
Если конечно уникальность поддерживается
   DeMi4
 
13 - 24.12.12 - 16:36
Если Найти(бВыборка.Комментарий, бКомментарий) > 0 Тогда
сюда заходит
                Если бВыборка.ПодразделениеОрганизации = бПодразделение Тогда
Сюда нет 
                    Если бВыборка.СтатьяДвиженияДенежныхСредств = бСтатьяДвиженияДенежныхСредств Тогда
Сюда нет                        
бПКО = бВыборка.ПолучитьОбъект();
                        Прервать;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
   Deon
 
14 - 24.12.12 - 16:37
(13) Сравнивай коды, ну или уиды, если нет уникальности
   Галахад
 
15 - 24.12.12 - 16:41
Просветите, что за код:

бВыборка.Следующий() = -1
   DeMi4
 
16 - 24.12.12 - 16:53
При OLE соединении -1 - Истина
   DeMi4
 
17 - 24.12.12 - 16:56
С 7.7 соединение по OLE с 8.2
   Галахад
 
18 - 24.12.12 - 16:56
(16) Ого, интересно.
   DeMi4
 
19 - 24.12.12 - 17:00
(16)то есть Ложь

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует