Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Выбор из списка

Выбор из списка
Я
   derk153
 
24.12.12 - 13:44
Здравствуйте!
Есть поле ввода(тип: строка), куда вводятся данные из списка выбора. В списке выбора есть "Значение" и "Представление". Мне нужно, чтоб при  выборе элемента списка в поле ввода подставлялось "Представление", но подставляется "Значение".
Я так понимаю, по-умолчанию должно подставляться "представление",
если я не прав, то как найти событие записи элемента списка в поле ввода?
ЗЫ. Пробовал назначать в "ОбработкеВыбора", все равно после меняется значение.

Спасибо.
 
 
   Cube
 
1 - 24.12.12 - 13:47
(0) Юзай поле выбора
   RomaH
 
2 - 24.12.12 - 13:50
мы обошли так:
задача - выбор веб камеры из списка
спсиок в виде идентификатора + представление


    Список = МИС_СменаРаскладкиКлавиатурыКлиент.ПолучитьСписокКамер();
    Текст = Новый ТекстовыйДокумент;
    Текст.УстановитьТекст(Список);
    Для Строка = 1 по Текст.КоличествоСтрок() Цикл
        Элементы.Камера.СписокВыбора.Добавить(Текст.ПолучитьСтроку(Строка + 1), Текст.ПолучитьСтроку(Строка));
        Строка = Строка + 1;
    КонецЦикла;
    
    ПодключитьОбработчикОжидания("УстановитьКамеруПоУмолчанию",0.1,Истина);
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьКамеруПоУмолчанию()
    Камера = Элементы.Камера.СписокВыбора[0].Значение;
    КамераПриИзменении(Элементы.Камера);
КонецПроцедуры

&НаКлиенте
Процедура КамераПриИзменении(Элемент)
    МИС_СменаРаскладкиКлавиатурыКлиент.ОтключитьКамеру();
    МИС_СменаРаскладкиКлавиатурыКлиент.ПодключитьКамеру(Камера);
    
    Камера = Элемент.СписокВыбора.НайтиПоЗначению(Камера).Представление;
КонецПроцедуры


т.е. выбраное значение пишется в другое место, а значению для спсика - присваивается представление
   derk153
 
3 - 24.12.12 - 13:52
(1) пробовал, тоже самое
   Cube
 
4 - 24.12.12 - 13:56
   derk153
 
5 - 24.12.12 - 15:20
...пробую пробую, все никак.
https://docs.google.com/open?id=0B9nG75PJHfsyb3hMdzA3ejlHQVk
   Cube
 
6 - 25.12.12 - 05:09
(5) А вопрос задать правильно религия не позволяет? Из топика не понятно, что ты ведешь речь про элемент управления ячейки табличного поля...

* Глубокий вдох *
* Выдох *

Так, начнем сначала. Для такой задачи тебе придется сделать две колонки в табличном поле: скрытую (в ней будет хранится значение) и видимую (в ней будет хранится представление). На видимую колонку вешаешь обработчик выбора и меняешь значение в скрытой колонке при изменении значения в видимой колонке.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует