Вход | Регистрация

  1  2   
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Непростой запрос..

v7: Непростой запрос..
Я
   bananan
 
24.12.12 - 11:59
Сейчас у меня такой запрос:
"Период с ДатаС по ДатаПо;
                    |ОбрабатыватьДокументы Проведенные;
                    |Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
                    |Код = Документ.РасходнаяНакладная.ТМЦ.Код, Документ.РасходнаяНакладнаяН.ТМЦ.Код;
                    |ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
                    |Функция Колво = Сумма(Количество);
                    |Группировка Документ;
                    |Группировка ТМЦ;
                    |Условие (ТМЦ в выбТМЦ);";
Запрос нормально работает, выдает то, что надо.
Но тут есть еще несколько не решеных в запросе моментов:
1. Нужно выдавать сумму ящиков по каждому документу;
2. Нужно выдавать общее количество ящиков по всем документам;
3. В запросе нужно обращаться к подчиненному справочнику ЕдИзм (этот справочник подчинен справочнику ТМЦ) и из него брать коэффициент для конкретной еденици измерения...
Я в запросах не силен (хотя и понимая что здесь ничего архисложного нет).
Подскажите,пожалуйста как это сделать.
 
 
   ЧеловекДуши
 
1 - 24.12.12 - 12:03
Прямой запрос спасет тебя :)
   ЧеловекДуши
 
2 - 24.12.12 - 12:03
+ или Цикл в цикле + "Итого по строке" и вперед
   Андрей_Андреич
 
3 - 24.12.12 - 12:03
(1) Он его погубит :)
   bananan
 
4 - 24.12.12 - 12:04
(1)(2) Это как? Пример пожалуйста дайте
   Zhuravlik
 
5 - 24.12.12 - 12:07
(0) А разве единица не указывается в тч дока?
   bananan
 
6 - 24.12.12 - 12:11
(5) за еденицу измерения естественно идет ед изм из документа. но мне нужно узнать сколько это в ящиках. а у многих ТМЦ разные коеффициенты ...
   Ёпрст
 
7 - 24.12.12 - 12:14
(0)

пишем что выдает это:

мд =  Метаданные.Справочник("ТМЦ");
Для к =1 По мд.Реквизит() Цикл
  сообщить(мд.Реквизит(к).Идентификатор +" тип: "+мд.Реквизит(к).Тип+" вид: "+мд.Реквизит(к).Тип);
КонецЦикла;
   palpetrovich
 
8 - 24.12.12 - 12:17
(0) а зачем там |Код = Документ.РасходнаяНакладная.ТМЦ.Код, Документ.РасходнаяНакладнаяН.ТМЦ.Код; ?
   bananan
 
9 - 24.12.12 - 12:18
(8) это осталось от прошлой версии...
   palpetrovich
 
10 - 24.12.12 - 12:21
(9) добавть вс\место него "Ед = ... " и группировку по ней
потом при обработке результата будешь из нее брать коэффициент и делать с ним все что хочешь ;)
 
 Рекламное место пустует
   bananan
 
11 - 24.12.12 - 12:22
(7)
Выдает дофига ненужной в данном случае информации:
мд =  Метаданные.Справочник("ТМЦ");
Для к =1 По мд.Реквизит() Цикл
  сообщить(мд.Реквизит(к).Идентификатор +" тип: "+мд.Реквизит(к).Тип+" вид: "+мд.Реквизит(к).Тип);
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: Строка
Коф=0
ПолнНаименование тип: Строка вид: Строка
ШтрихКод тип: Строка вид: Строка
Актуален тип: Перечисление вид: Перечисление
Вид тип: Перечисление вид: Перечисление
Валюта_Прод тип: Справочник вид: Справочник
Цена1 тип: Число вид: Число
Цена2 тип: Число вид: Число
Цена3 тип: Число вид: Число
Валюта_Прих тип: Справочник вид: Справочник
Цена_Прих тип: Число вид: Число
СтавкаНДС тип: Справочник вид: Справочник
БазЕдиница тип: Перечисление вид: Перечисление
СтарыйПолныйКод тип: Строка вид: Строка
Транспорт тип: Перечисление вид: Перечисление
ВидЗатрат тип: Справочник вид: Справочник
СчетЗатрат тип: Счет вид: Счет
ЦенаРозн тип: Число вид: Число
Счет тип: Счет вид: Счет
Литраж тип: Перечисление вид: Перечисление
ВидТовару тип: Перечисление вид: Перечисление
Назва11 тип: Строка вид: Строка
Група тип: Строка вид: Строка
ЦенаК1 тип: Число вид: Число
ЦенаК2 тип: Число вид: Число
Спутник тип: Справочник вид: Справочник
Цена4 тип: Число вид: Число
Цена5 тип: Число вид: Число
Цена6 тип: Число вид: Число
Цена7 тип: Число вид: Число
Цена8 тип: Число вид: Число
Код1 тип: Число вид: Число
Product_id тип: Число вид: Число
КороткаНазва тип: Строка вид: Строка
Product_id_G тип: Число вид: Число
Учесть тип: Число вид: Число
МинДоход тип: Число вид: Число
Учесть1 тип: Число вид: Число
Цена9 тип: Число вид: Число
Цена10 тип: Число вид: Число
СрокГодности тип: Дата вид: Дата
НомерСертиф тип: Строка вид: Строка
ДатаСертиф тип: Дата вид: Дата
Цена11 тип: Число вид: Число
Цена12 тип: Число вид: Число
Цена13 тип: Число вид: Число
Цена14 тип: Число вид: Число
Цена15 тип: Число вид: Число
Цена16 тип: Число вид: Число
фКатегория1 тип: Число вид: Число
ПроцКатегория1 тип: Число вид: Число
Код_NPS тип: Число вид: Число
УткЗЕД тип: Строка вид: Строка
ЗаказБумаг тип: Число вид: Число
Артикул тип: Строка вид: Строка
КодУКТВЭД тип: Справочник вид: Справочник
УчетнаяЦена тип: Число вид: Число
УровеньПередела тип: Число вид: Число
НормыЗатрат тип: Документ вид: Документ
ШтрихКодЯщика тип: Строка вид: Строка
МетроКод тип: Число вид: Число
ПоставщикКод тип: Строка вид: Строка
ПоставщикНаименование тип: Справочник вид: Справочник
ПоставщикТовар тип: Строка вид: Строка
грам тип: Число вид: Число
видГр тип: Число вид: Число
Срок тип: Число вид: Число
Ширина тип: Число вид: Число
Высота тип: Число вид: Число
Довжина тип: Число вид: Число
КвоДляНН тип: Строка вид: СтрокаКонецЦикла;
   palpetrovich
 
12 - 24.12.12 - 12:23
забавный справочник :))
   palpetrovich
 
13 - 24.12.12 - 12:25
кста, сразу не заметил, а что это за баден-баден?
|Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
   bananan
 
14 - 24.12.12 - 12:28
(13) Коливество данного товара в накладной
   Mikeware
 
15 - 24.12.12 - 12:32
жесть жестяная....
"у них там гнездо!"©
   Стрелок
 
16 - 24.12.12 - 12:35
о мой бог... коэффициент пересчёта есть в документе
   palpetrovich
 
17 - 24.12.12 - 12:35
(14) я не про то, зачем по два раза? :)
   palpetrovich
 
18 - 24.12.12 - 12:35
+17 а, это  я протупил, там .РасходнаяНакладнаяН какая-то, сорьки
   Ёпрст
 
19 - 24.12.12 - 12:36
(11) нафига ты мой код в цикл засунул ?

ЗЫ: теперь выполни ЭТО (но только ОДИН раз)

мд =  Метаданные.Справочник("Единицы");
Для к =1 По мд.Реквизит() Цикл
  сообщить(мд.Реквизит(к).Идентификатор +" тип: "+мд.Реквизит(к).Тип+" вид: "+мд.Реквизит(к).Тип);
КонецЦикла;
   abfm
 
20 - 24.12.12 - 12:36
Цена16 это класс. Да ещё и с типом.
   1Сергей
 
21 - 24.12.12 - 12:37
11 раз повторил
   Ёпрст
 
22 - 24.12.12 - 12:39
Точнее "ЕдИзм"  воткни в (19).
   Privalov
 
23 - 24.12.12 - 12:39
Мля
   bananan
 
24 - 24.12.12 - 12:40
(19) Выдает
Для к =1 По мд.Реквизит() Цикл
{\\SERVER12\VPKTEST$\EXTFORMS\РАС01.ERT(62)}: Поле агрегатного объекта не обнаружено (Реквизит)
   Ёпрст
 
25 - 24.12.12 - 12:41
(24) см (22)
   Mikeware
 
26 - 24.12.12 - 12:41
(19)(21) Это чтобы вы лучше поняли! :-)
"ну тупы-ы-ые...
   bananan
 
27 - 24.12.12 - 12:41
(22) Это как?
   bananan
 
28 - 24.12.12 - 12:42
(25) для к=1 По мд.ЕдИзм так?
   Ёпрст
 
29 - 24.12.12 - 12:43
(28) п...ц

Процедура Сформировать()

   мд =  Метаданные.Справочник("ЕдИзм");
   Для к =1 По мд.Реквизит() Цикл
     сообщить(мд.Реквизит(к).Идентификатор +" тип:    "+мд.Реквизит(к).Тип+" вид: "+мд.Реквизит(к).Тип);
   КонецЦикла;
КонецПроцедуры
   Mikeware
 
30 - 24.12.12 - 12:44
(29) забавный зверек, не правда ли? :-)
   bananan
 
31 - 24.12.12 - 12:44
(29) Сейчас попробую так
   Ёпрст
 
32 - 24.12.12 - 12:44
Реквизит БазЕдиница , какой вид перечисления имеет ?
   bananan
 
33 - 24.12.12 - 12:45
Выдал:
Ед тип:    Перечисление вид: Перечисление
Коэффициент тип:    Число вид: Число
 
 
   Ёпрст
 
34 - 24.12.12 - 12:46
(33) супер
Ед , какой вид перечисления имеет ?
   1Сергей
 
35 - 24.12.12 - 12:48
" вид: "+мд.Реквизит(к).ВИД);
   bananan
 
36 - 24.12.12 - 12:48
(34) Еденицы там переычислены, например: кг, шт, ящ, и т.д.
   Ёпрст
 
37 - 24.12.12 - 12:50
(36)
1. в свойствах этого реквизита стоит галка Сортировка ?

2. в документах РасходнаяНакладная,РасходнаяНакладнаяН есть реквизиты табличной части ЕдИзм и Коэффициент ?
   palpetrovich
 
38 - 24.12.12 - 12:52
пробу так ...если я ничего не напутал :)
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ТМЦ    = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
    |Ед        = Документ.РасходнаяНакладная.Ед, Документ.РасходнаяНакладнаяН.Ед;
    |Кво    = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
    |Функция СуммаКво = Сумма(Кво);
    |Группировка ТМЦ без групп;
    |Группировка Ед;
    |Условие(ТМЦ в выбТМЦ);";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
    ЕдИзм = СоздатьОбъект("Справочник.ЕдиницыИзмерения");
    Пока Запрос.Группировка(1) = 1 Цикл
        Пока Запрос.Группировка(2) = 1 Цикл      
            ЕдИзм.ИспользоватьВладельца(Запрос.ТМЦ); 
            Если ЕдИзм.НайтиПоНаименованию("Ящик",1,0)=1 Тогда
                КоэффициентЯщик = ЕдИзм.Коэффициент;
                КвоЯщик = Запрос.Кво * Запрос.Ед.Коэффициент / КоэффициентЯщик;  
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
   bananan
 
39 - 24.12.12 - 12:53
(37) 2. есть, но не факт что там тот коэффициент что нам нужен
(1) сча посмотрю ... - этого какого именно этого ЕдИзм?
   bananan
 
40 - 24.12.12 - 12:54
(38) что-то подобное у меня уже есть и оно работате. здесь вопрос в том как бы коэффициент узнавать в запросе..
   Ёпрст
 
41 - 24.12.12 - 12:56
(39) >>> но не факт что там тот коэффициент что нам нужен

^))))))))))))))))))))))))))))))))))))))))))))))))))))))))))

полный ПЭ.

Ясен пень что не тот, он от той единицы измерения, что указана в самом документе.
   abfm
 
42 - 24.12.12 - 12:59
Стаж 5 лет. Уникум просто.
   palpetrovich
 
43 - 24.12.12 - 12:59
(40) тогда так
 //=========================================================
 
Функция КоэффициентЯщик(ТМЦ)         
    ЕдИзм = СоздатьОбъект("Справочник.ЕдиницыИзмерения");
    ЕдИзм.ИспользоватьВладельца(Запрос.ТМЦ); 
    Если ЕдИзм.НайтиПоНаименованию("Ящик",1,0)=1 Тогда
        Возврат = ЕдИзм.Коэффициент;
    КонецЕсли;
    Возврат 1;
КонецФункции        
      
    ТекстЗапроса = "
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ТМЦ    = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
    |Коэффициент = Документ.РасходнаяНакладная.Ед.Коэффициент, Документ.РасходнаяНакладнаяН.Ед.Коэффициент;
    |Кво    = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
    |Функция СуммаКво = Сумма(Кво*Коэффициент/КоэффициентЯщик(ТМЦ));
    |Группировка ТМЦ без групп;
    |Условие(ТМЦ в выбТМЦ);";
   bananan
 
44 - 24.12.12 - 12:59
ну и нафишг мне тот коэййициент, мне нужен коэффициент для еденици ящик!
   КонецЦикла
 
45 - 24.12.12 - 13:00
Что-то непонятно
В документе любая единица, а нужно узнать коэфф ящика?
   abfm
 
46 - 24.12.12 - 13:00
Коэффициент в справочнике и документе может быть разным.
   КонецЦикла
 
47 - 24.12.12 - 13:01
Тут перебором наверное только
Если бы был приемлем прямой запрос - можно соединиться по ОКЕИ и владельцу
   bananan
 
48 - 24.12.12 - 13:01
(43) Сейчас проверю. Но ладно с тем коэффициентом, а КАК мне просуммировать к-во ящиков в документе и к-во ящиков во всех документах. Это можно сделать в тексте запроса?
   bananan
 
49 - 24.12.12 - 13:02
(45) Да
 
 Рекламное место пустует
   bananan
 
50 - 24.12.12 - 13:03
(43) Работает. Но с этим я ж говорю у меня коэффициет тоже вычисляется но это происходит не в запросе
   КонецЦикла
 
51 - 24.12.12 - 13:04
(49) А, вот выше с помощью функции
Будет, конечно, тормозить, но зато в одном запрос
Во всех документах ящики отдельно. Результат запроса же будет - сложишь.
   Ёпрст
 
52 - 24.12.12 - 13:05
Перем Спр;
 //======================================================================
 
Функция ПересчетВЯщики(ТМЦ,Количество)
    Спр.ИспользоватьВладельца(ТМЦ);
    Спр.ВыбратьЭлементыПоРеквизиту("Ед",Перечисление.ЕдИзм.Ящ,1,0)//воткнешь сюда нужный вид перечисления и его значение ящик
 
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если Спр.ПометкаУдаления()=0 Тогда
            Возврат Количество/Спр.Коэффициент;
        КонецЕсли;
    КонецЦикла;
    Возврат Количество;
КонецФункции// 
 


Процедура Сформировать()
    Спр = СоздатьОбъект("Справочник.ЕдИзм");
    ТекстЗапроса = "
    |Период с НачДата По КонДата;
    |Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
    |Сумма = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН.Сумма;
    |Коэффициент = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН.Сумма;
    |ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
    |Функция Колво = Сумма(Количество*Коэффициент);
    |Функция КоличествоЯщиков = Сумма(Сумма-Сумма+ПересчетВЯщики(ТМЦ,Количество*Коэффициент));
    |Группировка Документ;
    |Группировка ТМЦ;
    |Условие (ТМЦ в выбТМЦ);";
.......
   Ёпрст
 
53 - 24.12.12 - 13:07
(50) как он у тебя может работать, если у тебя в конфе нет справочника Справочник.ЕдиницыИзмерения" а есть
Справочник.ЕдИзм

опять врешь ?
   bananan
 
54 - 24.12.12 - 13:08
(52) У меня сейчас (оно работает и вроде не тормозит) так:
ЕдИ = Создатьобъект("Справочник.ЕдИзм");
    ТМЦ = Создатьобъект("Справочник.ТМЦ");
    Найд=ТМЦ.НайтиПоКоду(Запр.Код);
    ЕдИ.ИспользоватьВладельца(ТМЦ.ТекущийЭлемент());
    Найд2=ЕдИ.НайтиПоНаименованию("ящ.", 1);
    Коф=(ЕдИ.Коэффициент);
    Если Коф=0 тогда
        Количество=Запр.колво/Коф;    
    иначе
        Таб.ВывестиСекцию("ноль");
        Возврат;
    КонецЕсли;
    Таб.ВывестиСекцию(Секц);
   bananan
 
55 - 24.12.12 - 13:08
(53) Справочник такой : ЕдИзм
   Ёпрст
 
56 - 24.12.12 - 13:09
(54) за такой код надо, как минимум, увольнять без объяснения причины.
   palpetrovich
 
57 - 24.12.12 - 13:09
(52) Сумма(Сумма-Сумма+ПересчетВЯщики(ТМЦ,Количество*Коэффициент)) - доставляет ;)
   bananan
 
58 - 24.12.12 - 13:10
(53) я ввобще редко вру, а здесь мне какой рещон врать?
   abfm
 
59 - 24.12.12 - 13:10
Ящики тоже разные бывают одна и таже водка 12 и 20 например.
   Ёпрст
 
60 - 24.12.12 - 13:10
можно даже с записью = "несоответствие с занимаемой должностью
"
   Ёпрст
 
61 - 24.12.12 - 13:10
(57) учись студент!

в твоём коде не будет дробной части..
   Ёпрст
 
62 - 24.12.12 - 13:11
и весь пересчет в "ящики" у тебя будет с "огруглянием"

в отличие от (52).
   Ёпрст
 
63 - 24.12.12 - 13:12
+ за поиск по наименованию.. поубыв...л бы
   Ёпрст
 
64 - 24.12.12 - 13:13
а за поиск по коду при наличии ссылки.. это к дохтуру ужо
:)
   palpetrovich
 
65 - 24.12.12 - 13:13
(61) не, мне вот это "Сумма-Сумма" не понять! :)
   Ёпрст
 
66 - 24.12.12 - 13:14
(65)ёёё..

см (61-62)
   palpetrovich
 
67 - 24.12.12 - 13:14
(64) кстати да,  " за поиск по наименованию" - я-бы и сам... :)
   Ёпрст
 
68 - 24.12.12 - 13:15
если че, функция сумма в тексте запроса берет точность для вычисления из переменной текста запроса (который является её аргументом).
В твоём коде нет переменной, точность = 0.
В моём - точность будет такая, как у переменной Сумма.
в данном случае, точность будет 2 знака в дробной части.
   abfm
 
69 - 24.12.12 - 13:17
а почему не так.
Сумма(ПересчетВЯщики(ТМЦ,Количество*Коэффициент));
   bananan
 
70 - 24.12.12 - 13:17
(68) Сейчас покажу резульататы работы моего кода
   Ёпрст
 
71 - 24.12.12 - 13:17
(69) читай (61,62,68)
   bananan
 
72 - 24.12.12 - 13:18
(68) Пожалйста, резыльтаты работы моего кода:
АТ-0037197        
Вівсяні пластівці (ЛІТА) 500г 20ШТ        0.5
Горох шліфований (ЛІТА) 1кг*20шт.        2
Гречана крупа ЛІТА 1кг 20шт        3
Перлова (ЛІТА) 1кг*20шт.        2
Пшенична 750г (ЛІТА) 20шт        2
Пшенична арнаутка яра  750г (ЛІТА) 20шт        2
Пшоно  Літа 1кг*20шт.        2
Рис круглий 1кг 20шт        4
   bananan
 
73 - 24.12.12 - 13:19
(61) Как по поводу дробной часьти?
   palpetrovich
 
74 - 24.12.12 - 13:19
(68) кстати да, я-же уже видел такой хитроый зврат с точностью, прошу прощения за (65)  
и еще, не подскажешь почему в таких функциях как в (43) неполучается сразу использовать передаваемы аргумент (ТекДок), почему  приходится искать предварительно:
Функция Себестоимость(ТекДок, ТМЦ)         
    Если Док.НайтиДокумент(ТекДок)=0 Тогда
...
   Ёпрст
 
75 - 24.12.12 - 13:20
(72) это результат работы чего ?
   bananan
 
76 - 24.12.12 - 13:20
Ладно с коээфиципетном как мне просумировать к-во ящиков по документу и по всех документах - если не в запросе - знаю. В запросе хоть один из этих пунктов сделать можно?
   Ёпрст
 
77 - 24.12.12 - 13:20
(74) не надо ничего искать там, всё видится в этих функциях.
   bananan
 
78 - 24.12.12 - 13:20
(75) моего кода. который тебе очень не понравился
   Ёпрст
 
79 - 24.12.12 - 13:21
(76) ты вообще читаешь, что тебе пишут ?
   Ёпрст
 
80 - 24.12.12 - 13:21
(78) свой код лучше никому не показывай, а то уволят по статье к едрени фени.
   palpetrovich
 
81 - 24.12.12 - 13:21
(77) у меня не видится, наверное я не умею их готовить :(
   Ёпрст
 
82 - 24.12.12 - 13:22
(81) ты целиком покажи, чего не видится.
   Ёпрст
 
83 - 24.12.12 - 13:23
+82 надеюсь, запрос не в скуле ?
:)
   Ёпрст
 
84 - 24.12.12 - 13:25
вот это шедевр

 Если Коф=0 тогда
        Количество=Запр.колво/Коф;
   Ёпрст
 
85 - 24.12.12 - 13:25
:))))))))
   palpetrovich
 
86 - 24.12.12 - 13:27
+81 блин, спецом проверил, работает ...но ведь неработало-ж
правда, так работает 
Функция Себестоимость(ТекДок, ТМЦ) 
Док = ТекДок;
Опер = Док.Операция; 
...
а так нет 
Функция Себестоимость(ТекДок, ТМЦ) 
Опер = ТекДок.Операция; 
...
   bananan
 
87 - 24.12.12 - 13:27
(85) не то показал:
    Если Коф<>0 тогда
        Количество=Запр.колво/Коф;    
    иначе
        Таб.ВывестиСекцию("ноль");
        Возврат;
    КонецЕсли;
    Таб.ВывестиСекцию(Секц);
   Ёпрст
 
88 - 24.12.12 - 13:28
(87) а ничего, что это полная х..ня ?

Не находишь ?
   Ёпрст
 
89 - 24.12.12 - 13:30
у тебя в документе продали в ящиках, в количестве 1 штука, коэффициент в документе 20..

Твой отчет покажет 1/20 ящика, а не 1.

Дальше продолжать ?
   bananan
 
90 - 24.12.12 - 13:38
(88) может и так но так работает, когда же проверяю равен ли Коф нулю тоже работате но происходит деление на ноль
Так как насчет подсуммирования ящиков в документе и во всех документах?
   Ёпрст
 
91 - 24.12.12 - 13:39
(90)
чем тебя (52) не устраивает ?
   bananan
 
92 - 24.12.12 - 13:43
(91) по-поводу того кода что ты дал:
Перем Спр;
 //======================================================================
 
 
Функция ПересчетВЯщики(ТМЦ,Количество)
    Спр.ИспользоватьВладельца(ТМЦ);
    Спр.ВыбратьЭлементыПоРеквизиту("Ед",Перечисление.ЕдИзм.Ящ,1,0)//воткнешь сюда нужный вид перечисления и его значение ящик
 
 
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если Спр.ПометкаУдаления()=0 Тогда
            Возврат Количество/Спр.Коэффициент;
        КонецЕсли;
    КонецЦикла;
    Возврат Количество;
КонецФункции// 
 
 


Процедура Сформировать()
    Спр = СоздатьОбъект("Справочник.ЕдИзм");
    ТекстЗапроса = "
    |Период с НачДата По КонДата;
    |Количество = Документ.РасходнаяНакладная.Кво, Документ.РасходнаяНакладнаяН.Кво;
    |Сумма = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН.Сумма;
    |Коэффициент = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН.Сумма;
    |ТМЦ = Документ.РасходнаяНакладная.ТМЦ, Документ.РасходнаяНакладнаяН.ТМЦ;
    |Функция Колво = Сумма(Количество*Коэффициент);
    |Функция КоличествоЯщиков = Сумма(Сумма-Сумма+ПересчетВЯщики(ТМЦ,Количество*Коэффициент));
    |Группировка Документ;
    |Группировка ТМЦ;
    |Условие (ТМЦ в выбТМЦ);";
.......
Так вод что он мне выдал:
НачДата<<?>>
Переменная не определена (НачДата)
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Период с  <<?>> НачДата По КонДата;
Запрос[2] : Ошибка в выражении 'НачДата'
КонДата<<?>>
Переменная не определена (КонДата)
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Период с НачДата По  <<?>> КонДата;
Запрос[2] : Ошибка в выражении 'КонДата'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Сумма = Документ.РасходнаяНакладная. <<?>> Сумма, Документ.РасходнаяНакладнаяН.Сумма;
Запрос[4] : Неверно заданный путь 'Сумма'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Сумма = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН. <<?>> Сумма;
Запрос[4] : Неверно заданный путь 'Сумма'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Коэффициент = Документ.РасходнаяНакладная. <<?>> Сумма, Документ.РасходнаяНакладнаяН.Сумма;
Запрос[5] : Неверно заданный путь 'Сумма'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Коэффициент = Документ.РасходнаяНакладная.Сумма, Документ.РасходнаяНакладнаяН. <<?>> Сумма;
Запрос[5] : Неверно заданный путь 'Сумма'
КОЭФФИЦИЕНТ<<?>>
Переменная не определена (КОЭФФИЦИЕНТ)
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Функция Колво = Сумма(Количество*Коэффициент <<?>> );
Запрос[7] : Ошибка в выражении 'Коэффициент'
КОЭФФИЦИЕНТ<<?>>
Переменная не определена (КОЭФФИЦИЕНТ)
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Функция КоличествоЯщиков = Сумма(Сумма-Сумма+ПересчетВЯщики(ТМЦ,Количество*Коэффициент <<?>> ));
Запрос[8] : Ошибка в выражении 'Коэффициент'
Если Запр.Выполнить(ТекстЗапроса)=0 Тогда
{\\SERVER12\VPKTEST$\EXTFORMS\РАС011.ERT(102)}: Условие (ТМЦ в выбТМЦ <<?>> );
Запрос[11] : Ошибка в условии
ну начДата это понятно а вот все остальное?
   bananan
 
93 - 24.12.12 - 13:45
+(92) так как там по поводу профпригодности?
   Ёпрст
 
94 - 24.12.12 - 13:47
(92,93) это не лечится, уволняйся.
   Ёпрст
 
95 - 24.12.12 - 13:48
если ты не в состоянии определить НачДата и КонДата в тексте запроса 
- вон из профессии! ©Чье то
   bananan
 
96 - 24.12.12 - 13:50
(94) Код то твой....
   palpetrovich
 
97 - 24.12.12 - 13:51
(93) мдя...
   Ёпрст
 
98 - 24.12.12 - 13:52
(96) Для особо одаренных, нажимаем Меню-Вставить-Элемент диалога - выбор периода , наслаждаемся.
   Mikeware
 
99 - 24.12.12 - 13:53
(95) получил, фашист, гранату? :-)
Тебя в (96) в криворукости обвинили...
   bananan
 
100 - 24.12.12 - 13:53
(98) Рябята. я сюда не ссориться пришел, а за помощью или консультацией.
Кроме периода там дальше посмотри сколько ошибок выдает.
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует