Вход | Регистрация

1С:Предприятие ::

Метки: 

терминирующие сообщения

Я
   LivingStar
 
24.12.12 - 10:56
Вывожу пользователю сообщение, как сделать что бы ему не давалось продолжить свои действия пока он не исправит проблемную ситуацию? В данном случае пока не введут корректные данные для списания.


    Если ИтогоПоСтроке > ИтКол Тогда
        Превышено             = ИтКол - ИтогоПоСтроке;
        Сообщение             = Новый СообщениеПользователю();
        Сообщение.ПутьКДанным = "Номенклатура";
        Сообщение.Текст       = "В строке " + (ТекСтр + 1)  + " веденное количество превышает остаток на " + Превышено*(-1);
        Сообщение.Сообщить();
    КонецЕсли;
 
 
   Axel2009
 
1 - 24.12.12 - 10:57
модальное окно открой
   YHVVH
 
2 - 24.12.12 - 10:58
(0) исправь сам за него
   Starhan
 
3 - 24.12.12 - 10:58
(0)трудная у тебя работа.

плюс фокус в нужное поле и не давать закрыть окно.
   Reset
 
4 - 24.12.12 - 10:59
Пока Не ВведеныКорректныеДанные цик
 print нука введи корректные данные
 input Данные
 Если ДанныеКорректны(Данные) тогда
    ВведеныКорректныеДанные=Истина;
 КонецЕсли;
КонецЦикла;
   Гефест
 
5 - 24.12.12 - 11:00
(4) только счетчик нужен, чтобы раза с 500-ого признать себя побежденным
   Wobland
 
6 - 24.12.12 - 11:04
прервать или возврат ещё не предлагали?
   Жан Пердежон
 
7 - 24.12.12 - 11:07
(0) зачем?
   Reset
 
8 - 24.12.12 - 11:11
(5)
ЗапасТерпения=500;
Пока Не ВведеныКорректныеДанные цикл
  print нука введи корректные данные 
  input Данные
  Если ДанныеКорректны(Данные) тогда
      ВведеныКорректныеДанные=Истина;
  Иначе
     ЗапасТерпения=ЗапасТерпения-1;
     Если ЗапасТерпения=0 тогда
       print хрен с тобой, пусть будут эти данные
       Прервать;
     КонецЕсли;
  КонецЕсли;
КонецЦикла;
   LivingStar
 
9 - 24.12.12 - 11:23
(6) Возврат ничего не даcт !!!!
Ситуация такая: заполняю таблицу и при окончания ввода строки могу вывести только сообщение, при этом позволено вводить остальные строки. Думал есть метод не позволяющий продолжить ввод пока не исправится значение, и не будет выводиться сообщение об ошибке.
   vde69
 
10 - 24.12.12 - 11:26
обработчик "ПриИзмененииСтроки"

Отказ = Истина;
 
 Рекламное место пустует
   Wobland
 
11 - 24.12.12 - 11:26
(9) не делай так, дай юзеру закончить ввод, даже если он неправилен. иначе будешь гореть в геенне огненной, проклинаемый проклятиями юзерскими
   LivingStar
 
12 - 24.12.12 - 11:54
(10) мне надо в ПриОкончанииРедактирования()
   Ivan Bezdomnyi
 
13 - 24.12.12 - 12:02
(11) У табличного поля "ПередОкончаниемРедактирования" Отказ = Истина
   LivingStar
 
14 - 24.12.12 - 12:09
(13) спасибо, попробую!!!
   Wobland
 
15 - 24.12.12 - 12:09
а что, после (10) обязательно надо было (13) дождаться?
   LivingStar
 
16 - 24.12.12 - 14:21
(15) отказ= истина ничего не дал, дальнейший ввод при возникновении ошибки возможен !


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует