Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

форма выбора

форма выбора
Я
   Саша80
 
24.12.12 - 09:37
Ситуация какая-у меня при входе в систему сразу открывается форма списка документа. До сегшоднеяшнего дня это устраивало, сейчас возникла такая необходимость-как сделать так чтобы при открытии системы предлагалась возможность выбора вида документов?
 
 
   Галахад
 
1 - 24.12.12 - 09:37
Это в конфигуратор заглянуть придется.
   Саша80
 
2 - 24.12.12 - 09:38
я так понимаю форма нужна какая то.
   Goggy
 
3 - 24.12.12 - 09:41
Совершенно верно
   Саша80
 
4 - 24.12.12 - 09:55
вот...только вот какая...
   pessok
 
5 - 24.12.12 - 09:59
Список = Новый СписокЗначений;
Список.Добавить("Тип1", "Уно типо");
Список.Добавить("Тип2", "Дуо типо");

Результат = Список.ВыбратьЗначение();

Если Результат.Значение = "тип1" Тогда
 
ФормаСписка = Документы.тип1.ПолучитьФормуСписка();

Иначе

ФормаСписка = Документы.Тип2.ПолучитьФормуСписка();

КонецЕсли

ФормаСписка.РежимРабочегоСтола = Истина№
ФормаСписка.Открыть;
   Саша80
 
6 - 24.12.12 - 10:03
Список = Новый СписокЗначений;
Список.Добавить("Договора", "Договора");
Список.Добавить("Служебные записки", "Договора");

Результат = Список.ВыбратьЗначение();

Если Результат.Значение = "Договора" Тогда
 
ФормаСписка = Документы.Договор.ПолучитьФормуСписка();

Иначе

ФормаСписка = Документы.СлужебнаяЗаписка.ПолучитьФормуСписка();

КонецЕсли;

ФормаСписка.РежимРабочегоСтола = Истина;
ФормаСписка.Открыть();

не канает..или что то не так сделал?
   Саша80
 
7 - 24.12.12 - 10:10
ау
   rincewind
 
8 - 24.12.12 - 10:12
(6) с отладчиком советовался? ФормаСписка получает правильное значение?
   pessok
 
9 - 24.12.12 - 10:13
Список = Новый СписокЗначений;
Список.Добавить("Договора", "Договора");
Список.Добавить("Служебные записки", "Договора");

уверен:
   pessok
 
10 - 24.12.12 - 10:13
?
 
 Рекламное место пустует
   Саша80
 
11 - 24.12.12 - 10:15
Список = Новый СписокЗначений;
Список.Добавить("Договора", "Договора");
Список.Добавить("Служебные записки", "Служебные записки");

Результат = Список.ВыгрузитьЗначения();

Если Результат= "Договора" Тогда
 
ФормаСписка = Документы.Договор.ПолучитьФормуСписка();

Иначе

ФормаСписка = Документы.СлужебнаяЗаписка.ПолучитьФормуСписка();

КонецЕсли;

ФормаСписка.РежимРабочегоСтола = Истина;
ФормаСписка.Открыть();    

открываюся только служебки и форма выбора не предлагается
   rincewind
 
12 - 24.12.12 - 10:18
(11) Возможно, причина тут:

Результат = Список.ВыгрузитьЗначения();

вместо ВыбратьЗначение()
   Саша80
 
13 - 24.12.12 - 10:21
(12)а у меня как написано?
   vmv
 
14 - 24.12.12 - 10:21
(0) что мешает сделать общую форму с простенькой таблицей выбора из списка значений - она может еще в 100500 местах понадобиться, я давно прикрутил, ибо стандарт работы со списками значений в управляемом, увы беден
   vmv
 
15 - 24.12.12 - 10:22
(13) у тебя похмелье - это очевидно
   vmv
 
16 - 24.12.12 - 10:23
у Документы.Договор просто нет УФ-формы списка по умолчанию, сгенери шоли
   Саша80
 
17 - 24.12.12 - 10:24
(16) есть у всех все есть, все проверил
   Саша80
 
18 - 24.12.12 - 10:38
апчик
   singlych
 
19 - 24.12.12 - 10:48
Результат = Список.ВыбратьЭлемент()
   Саша80
 
20 - 24.12.12 - 12:08
(19)все равно только служебки выходят
   Саша80
 
21 - 24.12.12 - 12:19
все..разобрался..Если Резуьтат.Значение


Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует