Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УПР форм и заполнение табличной части внешней обработки

УПР форм и заполнение табличной части внешней обработки
Я
   picom
 
24.12.12 - 08:53
Во внешней обработке есть ТЧ
ТЧ заполняется в модуле по кнопке на форме
...
&НаКлиенте
Процедура ВыполнитьВыгрузку(Команда)
    СтартС () ;
КонецПроцедуры
...Затем срабатывает
&НаСервере
Процедура СтартС()
    РеквизитФормыВЗначение("Объект").Старт();
КонецПроцедуры
...А Вот текст модуля
Процедура Старт() Экспорт
        НовСтр = Табло.Добавить();
        НовСтр.Текст = "Новые текст";
...
А строка на форме не появляется
все перепробовал
и обновить и обновить отображение данных и т.п.
подскажите, как правильно?
 
 
   picom
 
1 - 24.12.12 - 10:39
шаманским методом призываю к активности в ветке с правильными ответами
   RomaH
 
2 - 24.12.12 - 10:40
а обратно - значение вреквизит формы?
   picom
 
3 - 24.12.12 - 10:44
(2) а это как?
   picom
 
4 - 24.12.12 - 11:34
ап п
   picom
 
5 - 24.12.12 - 12:19
апп
   RomaH
 
6 - 24.12.12 - 13:06
РеквизитФормыВЗначение
а догадайся
   picom
 
7 - 24.12.12 - 13:43
(6) Старец Фара, у меня не получается
скажи что написать надо
   picom
 
8 - 24.12.12 - 13:44
(+7) Фура
   RomaH
 
9 - 24.12.12 - 13:45
че-то я не уверен
у тебя в модуле объекта именно тот объект с которым работаешь?
   picom
 
10 - 24.12.12 - 13:52
(9) Внешняя обработка, весь код в (0)
 
 Рекламное место пустует
   RomaH
 
11 - 24.12.12 - 13:52
(10) и че - сам проверяй
   picom
 
12 - 24.12.12 - 13:57
Очень жду помощи от разбирающихся
(11) Хватит загадок не пишите тут больше
   RomaH
 
13 - 24.12.12 - 14:07
сам попросил, потом не обижайся

&НаКлиенте
Процедура Команда1(Команда)
    
    ВыполнитьНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ВыполнитьНаСервере()
    
    ОбъектОбработки = РеквизитФормыВЗначение("Объект");
    
    ОбъектОбработки.ЗаполнитьТЧ();
    
    ЗначениеВРеквизитФормы(ОбъектОбработки,"Объект");
    
КонецПроцедуры
   Noroving
 
14 - 24.12.12 - 14:10
Вы что издиваетесь все?))
   Noroving
 
15 - 24.12.12 - 14:11
&НаКлиенте
Процедура Команда1(Команда)
    
    ВыполнитьНаСервере();
    
КонецПроцедуры

&НаСервере
Процедура ВыполнитьНаСервере()
    
    нСтр = Объект.Табло.Добавить();
    нСтр.Текст = "Ламеры блин!";
    
КонецПроцедуры
   RomaH
 
16 - 24.12.12 - 14:24
(15) а теперь выполни заполнение ТЧ снаружи обработки,
   Noroving
 
17 - 24.12.12 - 14:43
(16) А при чем здесь с наружи. Он заполняет из формы обработки... и что ты имееш в виду "...с наружи"?
   RomaH
 
18 - 24.12.12 - 15:08
(17) снаружи - это значит где-то получить объект обработки и воспользоваться её методами, например в фоновом задании
   Noroving
 
19 - 24.12.12 - 15:11
(18) Для этого есть модуль менеджера, слышал про такое?
Я понимаю если бы это был метод "Заполнить()"...и то...
   picom
 
20 - 24.12.12 - 15:44
(19) весь код обработки должен быть в модуле под паролем
Модуля менеджера там нет
   picom
 
21 - 24.12.12 - 15:54
(13) Огго, заработало
спасибо, с меня бутылка пива.
..
Еще бы подсказали, почему в обработке не активно поле выбора дополнительной формы?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует