Вход | Регистрация

1С:Предприятие ::

Метки: 

не могу заполнить форму документа

Я
   koketka
 
24.12.12 - 00:53
смысл этой процедуры если нет в поле счет фактуры создаем новую и записываем в поле формы, создает новую счет фактуру но не записывает на форму авансового отчета хоть тресни? почему непонимаю
Процедура ПередЗаписи(Отказ)
    Для Каждого СтрокаПрочее из Прочее Цикл
        Если  Строкапрочее.СтавкаНДС <> Перечисления.СтавкиНДС.ПустаяСсылка() и
            СтрокаПрочее.СуммаНДС <> 0 и
            СтрокаПрочее.ДатаВходящегоДокумента <> '00010101000000' и
            СтрокаПрочее.НомерВходящегоДокумента <> 0 и
            СтрокаПрочее.СчетФактура = Документы.СчетФактураПолученный.ПустаяСсылка() Тогда
            Док = Документы.СчетФактураПолученный.СоздатьДокумент();
            Док.ВидСчетФактуры = Перечисления.ВидСчетаФактурыПолученного.НаПоступление;
            Док.Дата = Дата;
            Док.ДокументОснованиеСписок = Ссылка;
            Док.СуммаДокумента = СтрокаПрочее.Сумма;
            Док.СуммаНДСДокумента = Строкапрочее.СуммаНДС;
            Док.КодВидаОперации = "01";
            Док.ДатаВходящегоДокумента =  СтрокаПрочее.ДатаВходящегоДокумента;
            Док.НомерВходящегоДокумента = СтрокаПрочее.НомерВходящегоДокумента;
            Док.КодСпособаПолучения = 1;
            Док.КонтрагентСписок = СтрокаПрочее.Поставщик;
            Стр = Док.ДокументыОснования.Добавить();
            Стр.ДокументОснование =  Ссылка;
          // Док.с
 
            Док.Записать();
            СтрокаПрочее.СчетФактура = Док.Ссылка;
                     КонецЕсли;
    КонецЦикла;    
КонецПроцедуры
 
 
   Noroving
 
1 - 24.12.12 - 00:58
А условие выполняется?
   koketka
 
2 - 24.12.12 - 01:01
да вот до сюдо доходит
СтрокаПрочее.СчетФактура = Док.Ссылка;
Док.Ссылка - несет информацию о документе
но в строчку   СтрокаПрочее.СчетФактура  не вставляется
   Noroving
 
3 - 24.12.12 - 01:02
А тип соответствует?
   koketka
 
4 - 24.12.12 - 01:03
да ДокументСсылка.СчетФактураПолученный
   koketka
 
5 - 24.12.12 - 01:04
Процедура выполняется в модули формы
   Noroving
 
6 - 24.12.12 - 01:13
Тут только отладчик в помощь, единственное в чем не уверен, это в строке    
Стр.ДокументОснование =  Ссылка;
   koketka
 
7 - 24.12.12 - 01:13
я попробывала Документы.СчетФактураПолученные.найтипономер(Док.Номер) - не находит, странно хотя после обработки докумнта документ счет фактура есть
   koketka
 
8 - 24.12.12 - 01:15
Стр.ДокументОснование =  Ссылка;
эту строчку правильно заполняет судя по готовому документу
   koketka
 
9 - 24.12.12 - 01:16
а не может быть такого типа перед записью форма блокируется
   Noroving
 
10 - 24.12.12 - 01:18
Ты уверена что в новом документе перед записью у тебя Ссылка не будет пустой??
 
 Рекламное место пустует
   koketka
 
11 - 24.12.12 - 01:21
уверена вот там указан конкретный документ
   koketka
 
12 - 24.12.12 - 01:24
10 да вариант возможен
   Noroving
 
13 - 24.12.12 - 01:31
незнаю... тут просто нужно внемательно пройтись отладчиком по каждой строке... особенно здесь  
Док.Записать();
СтрокаПрочее.СчетФактура = Док.Ссылка;
КонецЕсли;
   sanja26
 
14 - 24.12.12 - 01:32
(13) фотку не спрашивал?
   alexei366
 
15 - 24.12.12 - 01:33
Объект Док не записан, ссылка пустая поэтому
   sanja26
 
16 - 24.12.12 - 01:34
ПередЗаписи(Отказ)
ты вручную сюда код набиваешь?
   alexei366
 
17 - 24.12.12 - 01:34
Ой чот не то написал
   sanja26
 
18 - 24.12.12 - 01:35
Док.Записать();
сообщить(Док.Ссылка);
            СтрокаПрочее.СчетФактура = Док.Ссылка;
   alexei366
 
19 - 24.12.12 - 01:37
Такс а у тя эта процедура при записи нового объекта срабатывает?
   sanja26
 
20 - 24.12.12 - 01:37
СтрокаПрочее.НомерВходящегоДокумента <> 0

а НомерВходящегоДокумента число чтоли?


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует