Вход | Регистрация

1С:Предприятие ::

Метки: бухгалтерский учет

бухитоги... полная непонятка

Я
   Crystalizer
 
06.07.04 - 11:18
есть такой запрос. и он вроде бы работал. по крайней мере на другом компе. данные по этому счету РТ есть (смотрел по ОСВ) и вроде бы в тоже самое время.... в общем никаких результатов запрос не даёт...
Сообщить("суб1..."); не срабатывает ни разу...

        би = создатьобъект("БухгалтерскиеИтоги");
        би.ИспользоватьРазделительУчета(Фирма);
        
        би.использоватьсубконто (видысубконто.ТМЦ,            список_ТМЦ,        2);
        би.использоватьсубконто (видысубконто.Заказы,                      ,         1);
        би.использоватьсубконто (видысубконто.контрагенты,    контрагент,         2);
        би.выполнитьзапрос ("01.01.04", "30.07.04", СчетПоКоду("РТ"), , ,2, ,"К");
        
        ОчиститьОкноСообщений();
        ВыбратьСтроки();
        Пока ПолучитьСтроку()=1 Цикл
            Если ПроверкаСтроки()=0 Тогда
                глНеПроводить(Контекст);
                Возврат;
            КонецЕсли;
            сообщить("проход строки...");
            би.ВыбратьСубконто ( 1 );
            Пока би.получитьсубконто ( 1 ) = 1 цикл
                Сообщить("суб1...");
                би.ВыбратьСубконто(2);
                Пока би.получитьСубконто(2) = 1 Цикл
                    Сообщить("суб2...");
                    сообщить( " заказ = " + би.субконто(2) );
                    би.ВыбратьСубконто(3);
                    Пока би.получитьСубконто(3) = 1 Цикл
                        Сообщить( " фирма = " + би.субконто(3) );
                        Сообщить(" идёт непосредственно проверка...",);
                        Если (контрагент=би.субконто(3)) и (тмц=би.субконто(1)) и (заказ=би.субконто(2)) Тогда// всё ок

                            колзар = би.СКД("К");// количество зарезервированного товара

                            Если кво <= колзар Тогда
                                сообщить ( "спишем " + кво );
                            КонецЕсли;
                        КонецЕсли;
                    КонецЦикла;
                КонецЦикла;
            конецЦикла;
        КонецЦикла;
 
  Рекламное место пустует
   Crystalizer
 
1 - 06.07.04 - 11:27
из-за чего вообще может 
       би.ВыбратьСубконто ( 1 )
не выбирать?


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует