Вход | Регистрация


1С:Предприятие ::

Метки: справочники

При выборе значения из справочника заходить сразу в опред. группу

Я
   SiMazx
 
25.06.04 - 15:01
Документ. Шапка. Реквизит. Типа. Справочник.
При открытии нужно сразу проваливаться в нужную группу.
Туплю.
Напомните. Как.
Спасибо.
 
  Рекламное место пустует
   Tyпoй Mля
1 - 25.06.04 - 15:04
использовать родителя при начале выбора значения?
   SiMazx
 
2 - 25.06.04 - 15:16
Все равно туплю... Так?
В модуле формы документа:
Процедура ПриНачалеВыбораЗначения(Парам)
    Если Парам = "Водитель"  Тогда
            Груз = СоздатьОбъект("Справочник.Персонал");
            Груз.НайтиПоНаименованию("Водители");
            ????? ИспользоватьРодителя(Груз.ТекущийЭлемент());  
    КонецЕсли;
КонецПроцедуры
   SiMazx
 
3 - 25.06.04 - 15:25
В качестве апа расскажу подробнее...
Есть справочник "Персонал" с папками "Грузчики" и "Водители".
При открытии из одного документа форма списка справочника должна открываться в папке "Грузчики", из другого документа - в папке "Водители".
В одном документе делал через подбор, там передача параметра в форму подбора и Фрм.ИспользоватьРодителя(МойРодитель) проблему решают...
Во втором документе мне подбором нафих не нуно...Там банальный реквизит типа Справочник.Персонал...
   SiMazx
 
4 - 25.06.04 - 15:28
Снарк... Ну хоть ты не издевайся... Лана остальные не знают... Подскажи и я тихо-мирно свалю... Не буду позорицца... Туплю и все тут...
   It is me
 
5 - 25.06.04 - 15:29
Попробуй передавать родителя в форму списка и там ИспользоватьРодителя в процедуре ПриОткрытии...
   lexa
 
8 - 25.06.04 - 15:34
Процедура ПриНачалеВыбораЗначения(Парам) 
   Если Парам = "Водитель"  Тогда 
           Груз = СоздатьОбъект("Справочник.Персонал"); 
           Груз.НайтиПоНаименованию("Водители"); 
           Водитель.ИспользоватьРодителя(Груз.ТекущийЭлемент());   
   КонецЕсли; 
КонецПроцедуры 
Груз.ИспользоватьРодителя(Груз.ТекущийЭлемент());
   SiMazx
 
9 - 25.06.04 - 15:34
Мне вопчем-то не облизательно в форму передавать родителя... Родителя я при открытии справочника могу найти.. Мне надо передать в форму списка справочника весточку о том, что это вызов из документа такого-то типа...
   lexa
 
10 - 25.06.04 - 15:34
Процедура ПриНачалеВыбораЗначения(Парам) 
  Если Парам = "Водитель"  Тогда 
          Груз = СоздатьОбъект("Справочник.Персонал"); 
          Груз.НайтиПоНаименованию("Водители"); 
          Водитель.ИспользоватьРодителя(Груз.ТекущийЭлемент());   
  КонецЕсли; 
КонецПроцедуры
 
  Рекламное место пустует
   Tyпoй Mля
11 - 25.06.04 - 15:35
Короче... Страшилы Мудрые...

Процедура ПриНачалеВыбораЗначения(Парам) 
Если Парам = "Водитель"  Тогда 
  Груз = СоздатьОбъект("Справочник.Персонал"); 
  Груз.НайтиПоНаименованию("Водители"); 
  ИДТВОЕГОРЕВИЗИТА.ИспользоватьРодителя(Груз);   
КонецЕсли; 
КонецПроцедуры



Список тем форума
Рекламное место пустует   Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует