Вход | Регистрация

1С:Предприятие ::

Метки: справочники

интерактивный множественный выбор (эл.справ.) с группами...

Я
   Crystalizer
 
02.06.04 - 11:58
Необходимо по нажатию кнопки вызывать форму выбора элементов справочника с группами. Выбор должен быть множественный. Т.е. чтобы форма не закрывалась после выбора элемента.

есть 2 подхода - ни один не делает всё.

1)
процедура выбрать()
    спр=создатьобъект("справочник.контрагенты");
    спр.ВыборГруппы(1);    
    спр.выбрать("выберите клиентов исключаемых из рассмотрения",);
    если спис.Принадлежит(спр.текущийэлемент())=0 тогда
        спис.добавитьзначение(спр.текущийЭлемент());
    конецесли;
конецпроцедуры 

недостаток: выбирает по одному

2)
Процедура обработкаподбора(выбор)
    тмц_спис.ДобавитьЗначение(выбор);
КонецПроцедуры

Процедура Добавить_ТМЦ_Список()
    ОткрытьПодбор("Справочник.ТМЦ", "Выбор ТМЦ для отчета", Контекст, 1);
КонецПроцедуры

недостаток: не выбирает группы

--------

Как сделать чтобы выполнялись все условия?
и подобор групп и множественный выбор...
 
  Рекламное место пустует
   GrayT
 
1 - 02.06.04 - 12:08
А что, указать ВыборГруппы при открытии "Выбор ТМЦ для отчета" нельзя?
   Crystalizer
 
2 - 02.06.04 - 12:11
это приписывается к справочнику
в том случае справочник не используется
   lexa
 
3 - 02.06.04 - 12:13
смотри модуль формы для подбора справочника ТМЦ - там наверняка есть что то типа 
    Если ТекЭлем.ЭтоГруппа() = 1 Тогда
        Предупреждение("Группы подбирать нельзя!",60);
        Возврат 0;
    КонецЕсли;
   SnarkHunter
 
4 - 02.06.04 - 12:13
Процедура Добавить_ТМЦ_Список() 
   ОткрытьПодбор("Справочник.ТМЦ", "Выбор ТМЦ для отчета", Контекст, 1); 
   Конекст.ВыборГруппы(1); <== Так не пробовал?
КонецПроцедуры
   SnarkHunter
 
5 - 02.06.04 - 12:14
(+4)Описка: "Конекст" читать "Контекст"
   Crystalizer
 
6 - 02.06.04 - 12:18
SnarkHunter: не катит
lexa: хм... он просто "входит" а не "выбирает"
   GrayT
 
7 - 02.06.04 - 12:20
Вы чего???
В обработке:
//_____________________________________________________________________________

Процедура ПОКнопке()
    ОткрытьПодбор("Справочник.Контрагенты", "ФормаСписка",,1);
КонецПроцедуры//ПОКнопке                                  


//_____________________________________________________________________________

Процедура ОбработкаПодбора(Зн)
    Сообщить(?(Зн.ЭтоГруппа()=1, "Группа", "Элемент"));
КонецПроцедуры//ОбработкаПодбора


В Форме Контрагентов
Процедура ПриОткрытии()
    ВыборГруппы(1);
КонецПроцедуры//ПриОткрытии
   Crystalizer
 
8 - 02.06.04 - 12:25
ГрэйТ:

В Форме Контрагентов 
Процедура ПриОткрытии() 
   ВыборГруппы(1); 
КонецПроцедуры//ПриОткрытии


это в форме самого справочника?
мне нужно исправить только отчет.
он должен работать на выбор группы только в этом отчете.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует