Вход | Регистрация

1С:Предприятие ::

Метки: 

Что можно брать на сертификацию с собой?

Я
   Таня
 
01.06.04 - 15:36
где то читала впечатления сдавших экзамен, говорят можно даже распечатки своих модулей брать. Или это неправда?
 
 
   Композитор
 
1 - 01.06.04 - 15:38
(0) Правда. Если распечатки заверены у нотариуса.
   DimG
 
2 - 01.06.04 - 15:42
Почти все можно, кроме дисков и флешек. Книги не бери, есть там.
   GrayT
 
3 - 01.06.04 - 15:48
Голову не забудь :)
   Таня
 
4 - 01.06.04 - 15:52
Да уш-ш :) постараюсь
   Рупор абсурда
 
5 - 01.06.04 - 15:56
(2) Диски и флэшки можно
   gr13
 
6 - 01.06.04 - 15:58
(5) а что же тогда нельзя?
   DimG
 
7 - 01.06.04 - 15:58
(5) да, можно, только пользоваться нельзя.
   GrayT
 
8 - 01.06.04 - 15:58
Брать можно все
   Таня
 
9 - 01.06.04 - 16:00
Еще вопрос, все-таки, если построить отчет рациональнее по документам, чем по бухитогам?
Например в первом задании первый отчет я сделала так:
Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Шапка");

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Проведенные;
    |Док = Документ.ЗакрытиеДоговораЗайма.ТекущийДокумент;
    |Группировка Док;
    |Условие (Док.ДатаДок < Док.ДоговорЗайма.ДатаОкончания);
    |";
    
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
КонецЕсли;    
     
Пока Запрос.Группировка(1) =1 Цикл
    СрокЗаймаВДнях = Запрос.Док.ДоговорЗайма.ДатаОкончания-Запрос.Док.ДоговорЗайма.ДатаНачала;
    ФактическийСрок = Запрос.Док.ДатаДок - Запрос.Док.ДоговорЗайма.ДатаНачала;
    НачисленПроцент = Запрос.Док.Процент;
    Если Запрос.Док.ДоговорЗайма.Валюта.Выбран() = 1 Тогда
        Валюта = Запрос.Док.ДоговорЗайма.Валюта;
    Иначе
        Валюта = "-----";
КонецЕсли;

Таб.ВывестиСекцию("Строка_1");
КонецЦикла;

И что? могут сказать что неправильно?
   Таня
 
10 - 01.06.04 - 16:02
нет, можно только книги по языку и Митичкина
это щас сказали компетентные люди
 
  Рекламное место пустует
   DimG
 
11 - 01.06.04 - 16:03
(9) да не парься ты, может и смотреть не будут, а если захотят прикопаться - прикопаются. Но вообще-то экзаменаторы нормальные люди...
   GrayT
 
12 - 01.06.04 - 16:12
В принципе, в задании нет четкого указания, что данный надо брать из бух итогов. И в первом очете (правда я бегло посмотрел) там имеет смысл брать только начисленные проценты - так они в документе на оповерхности лежат. Так что согласен с DimG.
А что, там так сильно Митичкина любят?
Кажеться только стандартную доку и все. (ручку, бумажку, и голову не отбирают)
   NL
13 - 01.06.04 - 17:32
2(12) За это, "в задании нет четкого указания, что данный надо брать из бух итогов." просто - не сдал и "приходите в следующий раз". Это из опыта бывших коллег по франчу. Оно и правда, а если я ручками ввёл операцию, а не доком?
   Таня
 
14 - 01.06.04 - 17:47
тогда пусть мне достанется не 1 задание, потому что я совершенно не понимаю, как из бухгалтерских итогов получить то что мне нужно. Это я так, ни к кому не обращаясь.
   Таня
 
15 - 01.06.04 - 17:48
С бух итогами я уже делала, например 6, 5 задание. Это если кто-то скажет "учи бух итоги"
   Таня
 
16 - 01.06.04 - 17:49
а если я буду вместо документов обращаться к проводкам?
   NL
17 - 01.06.04 - 18:18
Все проводки порождены документами. В том числе и "Операции, введёные вручную" - это тоже документ. Прежде, чем получить проводку, тебе нужно получить документ... Далее текст кода никто не смотрит просто.
   Таня
 
18 - 01.06.04 - 18:32
а если так?
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период с НачДата по КонДата;
    |ОбрабатыватьДокументы Все;
    |Док = Документ.ДоговорЗайма.ТекущийДокумент;
    |Группировка Док; 
    |";
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;    
    
    Опер = СоздатьОбъект("Операция");
    Если  Опер.ВыбратьОперацииСПроводками(НачДата,КонДата, "91.2,66.4;91.2,66.44") > 0 Тогда
        Пока Опер.ПолучитьПроводку() = 1 Цикл
            Договор = Опер.Кредит.Субконто(3);
            Пока Запрос.Группировка(1) =1 Цикл
            Если  Договор = Запрос.Док Тогда
                Если Запрос.Док.ДатаОкончания > Опер.ДатаОперации Тогда
                    СрокЗаймаВДнях = Запрос.Док.ДатаОкончания-Запрос.Док.ДатаНачала;
                    ФактДата = Опер.ДатаОперации;
                    ФактическийСрок = Опер.ДатаОперации - Запрос.Док.ДатаНачала;
                    Если Запрос.Док.Валюта.Выбран() = 1 Тогда
                        Валюта = Запрос.Док.Валюта;
                        НачисленПроцент = Опер.ВалСумма;
                    Иначе
                        НачисленПроцент = Опер.Сумма;
                        Валюта = "-----";
                    КонецЕсли;
                    Таб.ВывестиСекцию("Строка_1");
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
        КонецЦикла;
    КонецЕсли;
   NL
19 - 01.06.04 - 18:42
Я тут немного пургу прогнал: одним глазом в форуме а вторым в отладчике. Я имел ввиду, что запрос обязателен для того, чтобы получить бухитоги, а не складывать проводки по документам за определёный период.
А что касается конкретнго случая... А ХЗ, товарищ майор...


Список тем форума
  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует