Вход | Регистрация


1С:Предприятие ::

Метки: 

Как получить цену закупки

Я
   Danila
 
30.05.04 - 10:59
Конфигурация "торговля и склад". Нужно сделать следующее вывести список товаров из справочника номенклатура и усредненную цену по которой этот товар закупали. Подскажите пожалуйста от куда выдернуть цены закупок по данному товару? Какой регистр это содержит или надо документы перебирать, то какие? Заранее спасибо!
 
  Рекламное место пустует
   SnarkHunter
 
1 - 30.05.04 - 11:05
Ну релиз конфигурации хотя бы... Для приличия... С сообщением типовая это или шаловливые ручки уже потрогали...
   AMV
2 - 30.05.04 - 11:07
А отчет "Остатки ТМЦ" тебя не устраивает. Там уже есть усредненая себестоимость.
   Danila
 
3 - 30.05.04 - 11:07
релиз 9.33 (типовая)
   Danila
 
4 - 30.05.04 - 11:08
[2] нет надо свой отчет писать... :-(
   amv
5 - 30.05.04 - 11:10
Ну тогда из регистра ПартииНаличные. Там товар хранится в ценах закупки. Сумму делишь на количество и будет тебе счастье.
   Danila
 
6 - 30.05.04 - 11:15
[6] Спасибо большое! Буду пробовать!
   SnarkHunter
 
7 - 30.05.04 - 11:15
Причем бери не только остатки по этому регистру, а то информация будет неполной...
   AMV
8 - 30.05.04 - 11:23
А какая информация ему еще нужна кроме "Номенклатура","Количество","СуммаРуб"?
И для чего?
Я так понял - надо просто вывести список товара с уредненой закупочной ценой...
   SnarkHunter
 
9 - 30.05.04 - 11:32
Если брать только остатки по регистру, то в расчет средней цены не попадут цены из партий, которые были полностью проданы за рассматриваемый период...
Если нужна средняя цена именно остатков на складе, то достаточно остатков по регистру...
   Danila
 
10 - 30.05.04 - 11:34
[9] Именно так
 
  Рекламное место пустует
   AMV
11 - 30.05.04 - 11:34
А вы в этом смысле...
Согласен.
   Danila
 
12 - 30.05.04 - 11:40
Только не получается у меня это сделать. Вот код запроса, по которому ни каких результатов не выдается, хотя это странно, т.к. отчет Остатки ТМЦ усредненную себестоимость показывает, где моя ошибка:

Процедура Сформировать()   
    
      Перем Запрос, ТекстЗапроса;

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "
    |Период с '01.01.02' по '01.05.04';
    |ОбрабатыватьДокументы все;
    |Наим = Регистр.ПартииНаличие.Номенклатура; 
    |Группировка Наим упорядочить по Наим.Наименование;  
    |";
    
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
            
    ОчиститьОкноСообщений();
    
        Пока (Запрос.Группировка("Наим") = 1) Цикл 
        Сообщить("+");
        Сообщить(Запрос.Наим);
    КонецЦикла;

КонецПроцедуры


Ведб товар должен выводиться, если его закупали, а его точно закупали в
указанный интервал времени...
   Danila
 
13 - 30.05.04 - 11:42
[12] Замечание. Учет у нас не партионный.
   SnarkHunter
 
14 - 30.05.04 - 11:46
Ну запрос-то того... Кривенький...
При чем тут документы, если запрос по регистру... Функций опять же нету, а должны наличествовать...
   AMV
15 - 30.05.04 - 11:51
Запрос должен выглядеть примерно так:
Номенклатура = Регистр.ПартииНаличие.Номенклатура;
Колво = Регистр.ПартииНаличие.Количество;
Сумма = Регистр.ПартииНаличие.СуммаРуб;
Функция КолвоКонОст = КонОст(Колво);
Функция СуммаНачОст = НачОст(Сумма);
Группировка Номенклатура;
   AMV
16 - 30.05.04 - 11:52
Наличие движений в запросе от типа усановленного у вас учета не зависит (насколько я понимаю)
   Danila
 
17 - 30.05.04 - 11:54
Спасибо. Я еще только начинаю осваивать, поэтому такие ошибки делаю.
   AMV
18 - 30.05.04 - 11:57
Ну тогда в догонку - когда будешь запрос обрабатывать - бери не Колво,Сумма, а КолвоКонОст, СуммаКонОст...
ДА кстати ... в (15)строка:
Функция СуммаНачОст = НачОст(Сумма);
должна выглядеть:
Функция СуммаКонОст = КонОст(Сумма); 
...очепятка...
   Danila
 
19 - 30.05.04 - 11:58
[15] Спасибо! Все работает!
   Danila
 
20 - 30.05.04 - 12:03
[18] Ну да. Дело в том, что я пишу отчет который должен показать менеджеру сколько товара осталось на складе, сколько зарезервировано, ... (там много еще чего)..., и усредненную цену закупки оставшегося товара. Соответственно
УсрЦенаЗакупкиОстатка = КолвоКонОст/СуммаНачОст. Поправьте пожалуйста, если я не прав...
   Danila
 
21 - 30.05.04 - 12:08
В догонку вопрос. Подскажите, чем отличается НачОст от КонОст. Т.е. в чем разница в значениях(см. 15):

НачальныйОстаток = НачОст(Колво);
КонечныйОстаток = КонОст(Колво);
   SnarkHunter
 
22 - 30.05.04 - 12:10
УсрЦенаЗакупкиОстатка = КолвоКонОст/СуммаНачОст
1. Числитель и знаменатель поменяй местами...
2. Используй оба показателя на КОНЕЦ периода...
   AMV
23 - 31.05.04 - 08:22
(21) НачОст - выбирает начальныый остаток по регистру (т.е на начало периода запроса)
КонОст - выбирате остаток на конец периода



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует