Вход | Регистрация


1С:Предприятие ::

Метки: 

Архивы не идут

Я
   прочерк
26.05.04 - 14:10
Други и подруги))
Подскажите а почему могут не идти архивы.
Есть несколько баз, налажены нормально,т.е. с логином всё нормально,время постоянное и т.д.
А архивы не хочут идти. Пишется,что "превышено время выполнения.Вынужден принудительно закрыть."
Хотя некоторые базы настолько маленькие,что обычная выгрузка(вручную) идёт несколько сек.
Если кто сталкивался с такой же проблем,то расскажите как решали..?
Или выскажете своё мнение..
 
 
   Arhitektor
 
1 - 26.05.04 - 14:14
а чем и как делаешь архивы?
   OctoberHammer
 
2 - 26.05.04 - 14:16
ножек нет, вот и не идут. были бы ножки, догда оно конечно да, а так - нет.
   прочерк
3 - 26.05.04 - 14:17
через конфигуратор
задания на архивацию ведутся с ключами.. автоматически(должно быть так по крайней мере) делается выгрузка..
   Arhitektor
 
4 - 26.05.04 - 14:17
умник :)
   Arhitektor
 
5 - 26.05.04 - 14:19
(3) скачай V7Backup и попробуй с помощью него сделать. Должно быть все ОК.
зри: v7backup.narod.ru
   прочерк
6 - 26.05.04 - 14:19
(2)и совсем не забавно.., проблем-то серьёзный!!
   lexa
 
7 - 26.05.04 - 14:22
автоматически это как? опиши подробно как ты это делаешь
   прочерк
8 - 26.05.04 - 14:24
(5) Сеньк ю вери мач за ссылку! Попробуем..
   OctoberHammer
 
9 - 26.05.04 - 14:25
В глобальнике:
Перем ЗапросРезервногоКопирования Экспорт;
Перем ЛСК,СЗ; 
Процедура ПриЗавершенииРаботыСистемы()   
   //(с)2001, Руслана Сапега    

    ЛСК=СоздатьОбъект("ФС");
    ЛСК.УстТекКаталог(КаталогИБ());
    Имя=ЛСК.НайтиПервыйФайл("*.*");
    СЗ=СоздатьОбъект("СписокЗначений");
    Пока ВернутьИмяФайла(Имя)<>"" Цикл
    КонецЦикла;
    Сч=0;
    Для СчЭ=1 По СЗ.РазмерСписка() Цикл 
       //В этом цикле пытаемся удалить все файлы, которые возможно

       //остались после аварийного завершения

        ЛСК.УстТекКаталог(КаталогИБ()+СЗ.ПолучитьЗначение(СчЭ));
        ИмяФайла=ЛСК.НайтиПервыйФайл("*.LCK");
        Если ИмяФайла<>"" Тогда  
            ФС.УдалитьФайл(ИмяФайла);
        КонецЕсли;     
    КонецЦикла;    
    Для СчЭ=1 По СЗ.РазмерСписка() Цикл
       //Ну а в этом цикле считаем количество активных 

       //экземпляров 1С

        ЛСК.УстТекКаталог(КаталогИБ()+СЗ.ПолучитьЗначение(СчЭ));
        ИмяФайла=ЛСК.НайтиПервыйФайл("*.LCK");
        Если ИмяФайла<>"" Тогда  
            Сч=Сч+1;
        КонецЕсли;     
    КонецЦикла;        
    Если Сч>1 Тогда
        Возврат ;  
    Иначе    
       //(с) 1С, 2001; Borges,no_spamto: borges@ua.fm, 2001        

        Если (ЗапросРезервногоКопирования=1) и (ИмяПользователя()<>"Робот") Тогда
            КакойТакойПароль="";  
            СЗпарам=СоздатьОбъект("СписокЗначений");
            Если ОткрытьФормуМодально("Обработка.ДляПароля",СЗПарам)=1 Тогда
            КонецЕсли;    
            ЗакрытьЧтоЛи=СЗПарам.Получить("Закрывать1С");
            Если ЗакрытьЧтоЛи=Да Тогда
                ВыгрузитьЧтоЛи=СЗПарам.Получить("ДелатьВыгрузку"); 
                Если ВыгрузитьЧтоли=Да Тогда
                    КакойТакойПароль=СокрЛП(СЗПарам.Получить("КакойТакойПароль"));
                    ИмяФайлаЗапуска=КаталогПрограммы()+ФС.НайтиПервыйФайл(КаталогПрограммы()+"*.exe");
                    СтрокаЗапуска=ИмяФайлаЗапуска+" CONFIG ";
                    СтрокаЗапуска=СтрокаЗапуска+" /d"+КаталогИБ();
                    СтрокаЗапуска=СтрокаЗапуска+" /N"+ИмяПользователя();
                    Если КакойТакойПароль<>"" Тогда
                        СтрокаЗапуска=СтрокаЗапуска+" /P"+СокрЛП(КакойТакойПароль);    
                    КонецЕсли;
                   //Запуск архивирования в пакетном режиме

                    Текст=СоздатьОбъект("Текст");
                    Текст.ДобавитьСтроку("[General]");
                    Текст.ДобавитьСтроку(""+Константа.АвтоВыгрузка+"=1");
                   //Текст.ДобавитьСтроку("CheckAndRepair=1");

                    Текст.ДобавитьСтроку("Quit=1");
                   //Текст.ДобавитьСтроку("[CheckAndRepair]");

                   //Текст.ДобавитьСтроку("Reindex=1");

                   //Текст.ДобавитьСтроку("RecalcTotals=1");

                   //Текст.ДобавитьСтроку("SkipUnresolved=1");

                   //Текст.ДобавитьСтроку("Pack=1");

                    Текст.ДобавитьСтроку("[UnloadData]");
                    Текст.ДобавитьСтроку("UnloadToFile=ar"+Прав(Формат(ТекущаяДата(),"ДГГГГММДД"),6));
                    Текст.ДобавитьСтроку("IncludeUserDef=1");
                    Текст.ДобавитьСтроку("[SaveData]");
                    Текст.ДобавитьСтроку("SaveToFile=ar"+Прав(Формат(ТекущаяДата(),"ДГГГГММДД"),6));
                    Текст.ДобавитьСтроку("IncludeUserDef=1");                    
                    Текст.Записать(КаталогИБ()+"unload.prm");
                    СтрокаЗапуска=СтрокаЗапуска+" /@"+КаталогИБ()+"unload.prm";
                    ЗапуститьПриложение(СтрокаЗапуска);  
                КонецЕсли;    
            Иначе
                СтатусВозврата(0);
            КонецЕсли;    
        КонецЕсли;
    КонецЕсли;
    СЗ.УдалитьВсе();
   //(с) 2001, Borges    

    ФС.УстТекКаталог(КаталогИБ());
    Имя=ФС.НайтиПервыйФайл("ar*.zip"); 
    СЗ.ДобавитьЗначение(Имя);
    Пока ПустоеЗначение(ФайлВыгрузки())=0 Цикл
    КонецЦикла;
    Если СЗ.РазмерСписка()>0 Тогда
        СЗ.Сортировать(1);
        Для Сч=1 По СЗ.РазмерСписка() Цикл 
            Если Сч>7 Тогда
                ФС.УдалитьФайл(""+СЗ.ПолучитьЗначение(Сч));
            КонецЕсли;    
           //Сообщить(СЗ.ПолучитьЗначение(Сч));

        КонецЦикла;    
    КонецЕсли;
КонецПроцедуры

Если ПустоеЗначение(Константа.АвтоВыгрузка)=0 Тогда
    ЗапросРезервногоКопирования=1;
Иначе
    ЗапросРезервногоКопирования=0;    
КонецЕсли;
// при условии, что каталоги пользователей находятся внутри каталога ИБ,

//мы будем после выхода последнего пользователя из 1С иметь резервную копию. 
//таких копий мы будем хранить - последних 7 экземпляров.
   прочерк
9 - 26.05.04 - 14:25
(7) Это значит,что система настроена так что в опред.время запускается конфиг. и выполняет выгрузку.. как ещё объяснить не знаю..
   Arhitektor
 
11 - 26.05.04 - 14:26
(7) смотри (5)
   OctoberHammer
 
12 - 26.05.04 - 14:29
упс... еще нужна константа в метаданных - АвтоВыгрузка с типом - строка. Там будет написано - либо "UnLoad" либо "Save".
И должна быть обработка для запроса пароля - на ней три кнопки - Ок, Отмена, и какая-то еще и одно поле ввода для принятия пароля.
   прочерк
13 - 26.05.04 - 14:32
ой..щас выговорюсь..
ну выполнялась же она до недавнего времени,а потом бац... ничего экстремального не происходило,просто на другой логин перенастроили выгрузку..и двадцать пять раз перепроверяли логин..
   OctoberHammer
 
14 - 26.05.04 - 14:34
шашки, ехать?
   OctoberHammer
 
15 - 26.05.04 - 14:34
работает, не трожь?
   прочерк
16 - 26.05.04 - 14:36
(15) не совсем понятно..
   lexa
 
17 - 26.05.04 - 14:40
(9) т.е. запуск в пакетном режиме - возможно путь к какому-то файлу неправильео прописан (например русские буквы вместо латинских, у меня такое было: путь лог-файла вместо "C" "С", а конфигуратор даже не ругался). А не проще средсвами ОС или архиваторами. В конце концов внешние обработки, отчеты и формы тоже нужны.
   lexa
 
18 - 26.05.04 - 14:42
(13) а права у этого логина есть?
   OctoberHammer
 
19 - 26.05.04 - 14:43
(16)главное, чтобы было понятно (8)
(17)если мы не выгружаем, а сохраняем данные пакетно (АутоСэйв), то можно настроить файл, в котором указать какие файлы будут сохраняться - например все по маске *.ерт
   прочерк
20 - 26.05.04 - 14:45
(18)естессна.. как положено..админские права..
   lexa
 
21 - 26.05.04 - 14:50
(19) и во вложенных папках тоже?
(20) проверь еще раз параметры запуска. А логин 1С или виндовый?
   OctoberHammer
 
22 - 26.05.04 - 14:56
(21) если в каталогах есть хотя бы один повторяющийся символ, то кажется да, но не уверен. нужно пробовать - лень
   прочерк
23 - 26.05.04 - 14:57
(21) 1С - ный логин
   OctoberHammer
 
24 - 26.05.04 - 14:57
само собой, если указать названия вложенных папок, тогда ответ "да" безусловно.
   lexa
 
25 - 26.05.04 - 15:00
а че бэкапом не хочешь?
   OctoberHammer
 
26 - 26.05.04 - 15:05
что значит не хочу? бэкапом и делаю. А не хочу пользоваться внешними программами, потому что при разворачивании конфы на другом сервере их может не быть. Так у тебя есть кусок, который твой, не зависящий от политики лицензирования архиваторов и т.п. - поставил константу в ИБ, и выгрузки делаются атвоматом.
   прочерк
27 - 26.05.04 - 15:05
ладненько.
Всема бальшое сенькс!
Попробуем разобраться с советуемыми вещами.
Завтра напишу что получилось!
   romix
 
28 - 26.05.04 - 15:06
Короче эта ошибка бывает, если ты запускаешь СКРИПТЫ ЧЕРЕЗ ВЕБ-СЕРВЕР.
У них ЕСТЬ ОГРАНИЧЕНИЕ на запуск длительных скриптов и его дочерних программ. Убери это ограничение, или придумай другой способ запуска. Через планировщик at, например.
Там вроде есть ключи запуска, чтобы единожды (скажем, через минуту) запустить пакетный файл, который уже работает с 1С.



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует