Вход | Регистрация

1С:Предприятие ::

Метки: Обучение и сертификация

Задача2 сертификация 1с77

Я
   MAAlekseev
 
25.05.04 - 15:39
Люди, кто трудится над решением задач. Как реализовать?
Табличная часть  документа может принимать два вида, в зависимости от установленного переключателя. При первом варианте в табличную часть включаются сведения о клиентах-заимодавцах в разрезе заключенных с ними договоров займа (клиент, договор, сумма, валюта, рубл покрытие). При втором варианте в табличную часть включается информация по заимодавцам без раз-бивки по договорам и валютам (клиент, сумма договора). Через видимость не получается обработать суммирование договоров. Извините за бестолковость, но кто решал поймет.....
Если Кратко = Перечисление.Булево.Да Тогда
        Форма.Отметить1.Видимость(0);
        Форма.Договоры.Видимость(0);
        Форма.Отметить2.Видимость(1);        
        Форма.Сумма2.Видимость(1);        
        Форма.Сумма.Видимость(0);        
    ИначеЕсли     Кратко = Перечисление.Булево.Нет Тогда
        Форма.Отметить1.Видимость(1);
        Форма.Договоры.Видимость(1);
        Форма.Отметить2.Видимость(0);        
        Форма.Сумма2.Видимость(0);        
        Форма.Сумма.Видимость(1);        
    КонецЕсли;
 
  Рекламное место пустует
   Таня
 
1 - 25.05.04 - 15:51
Я делала через ТЗ и сворачивала
   MAAlekseev
 
2 - 25.05.04 - 16:01
Через таблицу значений можно, т.е. вызывать каждый раз метод когда переходим на краткий формат? Тогда не очень понятно как это будет сохраняться при следующем открытии документа и формировать проводки тогда по активной форме? или как... Таня ответь поподробнее если справилась, листинг не прошу :) в общих словах - схему
   MAAlekseev
 
3 - 25.05.04 - 16:04
Можно подумать, что один бестолковый мечется в сети, остальные все знают, умные и ленивые, и не хотят связываться с ерундой... Вспомните годы молодые как сами сдавали :)
   SnarkHunter
 
4 - 25.05.04 - 16:09
С чего ты решил, что сдавали?
   Таня
 
5 - 25.05.04 - 16:12
Процедура Заполнить(// я в переключатель вставляла

    УдалитьСтроки();
    Если Дог = 1 Тогда
        Форма.Договор.Видимость(1);
        Форма.Сумма.Видимость(1);
        Форма.Валюта.Видимость(1);
        Формирование();
        ЗагрузитьТабличнуюЧасть(Таб);
    КонецЕсли;
    Если Дог = 2 Тогда
        Форма.Договор.Видимость(0);
        Форма.Сумма.Видимость(0);
        Форма.Валюта.Видимость(0);
        Формирование();
        Таб.Свернуть("Клиент", "РублевоеПокрытие");
        ЗагрузитьТабличнуюЧасть(Таб);
    КонецЕсли;
КонецПроцедуры
   Таня
 
6 - 25.05.04 - 16:24
в общих чертах опиши, как изменял Выписку в 1 задании. Через поступлениеПоДокументам делал? если да, то как бороться с повторным выбором договора, если в первой строке уже есть валютный договор, а второй выбираемый будет рублевый?
   MAAlekseev
 
7 - 25.05.04 - 16:52
секунду, буду смотреть
   MAAlekseev
 
8 - 26.05.04 - 10:38
выписка-поступление по документам модуль формы
545строка     УчитыватьНП = ?((ДокВид = "СчетФактура") или (ДокВид = "ДоговорЗайма") , 0, глПризнакУчетаНалога(Док, "НП"))//чтобы не учитывать налог с продаж

586строка ИначеЕсли ДокВид = "ДоговорЗайма" Тогда
        Кол = ?(Док.КоличествоСтрок() = 0, 1, Док.КоличествоСтрок());
        ТЗ.НоваяСтрока();
        ТЗ.КоррСчет = ?(ОплатаДоговора = 2, Сч66_33, Сч66_3);
        ТЗ.Субконто1 = Док.Контрагент;
        ТЗ.Субконто2 = Док.Договор;
        ТЗ.Субконто3 = "";
        Если (ЦеныВДоговоре = 2) и (ОплатаДоговора = 1) Тогда
            ТЗ.Приход = Док.Сумма*Док.Курс;
        Иначе
            ТЗ.Приход = Док.Сумма;
        КонецЕсли//заполняем таблицу значений

686строка Меню.ДобавитьЗначение("ДоговорЗайма","Договор займа")//добавляем в меню поступление по документам договор займа

4строка Перем Сч66_33, Сч66_//добавляем переменные счетов

1023строка Сч66_3  = СчетПоКоду("66.3");
Сч66_33 = СчетПоКоду("66.33")//раскрываем содержание переменных
Вроде все - теперь заполняем выписку по документам, выбирая договор займа (реквизиты шапки: контрагент,договор,курс,валюта,сумма и др). Выбираем рублевый договор займа, а в следующей строке выписки можно выбрать валютный договор займа.
   MAAlekseev
 
9 - 26.05.04 - 10:39
Извиняюсь за долгую секунду
   MAAlekseev
 
10 - 26.05.04 - 12:00
Для обработки курса и изменения даты документа договора займа
Функция Установить()
    Если Валюта.Выбран() = 1 Тогда
        Курс = Валюта.Курс.Получить(ДатаДок);        
    КонецЕсли;
КонецФункции
//----------------------------------------------

Процедура ИзменитьДату()
Если Валюта.Выбран() = 1 Тогда
    Установить();
КонецЕсли;
КонецПроцедуры
 
  Рекламное место пустует
   Таня
 
11 - 04.06.04 - 13:55
MAAlekseev, я тоже сначала так сделала, а потом если вводить операцию по возврату займа, то ты как сделал?
а я все переделала, добавила просто новую кнопку с менюхой и двумя документами - договор займа для поступления и закрытие договора займа - для возврата.
вот теперь сижу думаю, в третьей задаче как делать?
   Михаил
12 - 10.06.04 - 22:01
Тань а ты случаем не 18-ого будешь сдавать?))
   Nick_
13 - 15.06.04 - 23:15
А как  в 1 задаче вы делали Отчет о задержке в поступлении ден. средств? Как реализовали ввод данных и запись?


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует