Вход | Регистрация

1С:Предприятие ::

Метки: Встроенный язык

Процедура вызывается как функция... Кто поможет?

Я
   Багира
24.05.04 - 16:19
Процедура _Вычислить(Выражение) Экспорт
Шаблон("["+Выражение+"()]");     
КонецПроцедуры

Процедура П()
    _Вычислить("Проба");
КонецПроцедуры

Не вызвыается процедура Проба(), говорит 
Проба<<?>>()
Процедура вызывается как функция (Проба)
 
  Рекламное место пустует
   SnarkHunter
 
1 - 24.05.04 - 16:31
Из формулы элемента диалога?
   Багира
2 - 24.05.04 - 16:37
В том то и дело, что ни в одном элементе диалога не такой формулы.
   SnarkHunter
 
3 - 24.05.04 - 16:47
Сделай Пробу функцией...
   Багира
4 - 24.05.04 - 16:50
Есть на форме кнопка с формулой П(), она запускает проц-ру П(), которая запускает проц-ру Гл. модуля _Вычислить(). В качестве параметра передается строка "Проба". В Гл. модуле формируется строка "Проба()" при мощи функции Шаблон, и после этого происходит ругательство. Я не могу въехать в фразу "Процедура вызывается как функция".
   Багира
5 - 24.05.04 - 16:57
Как тормознуто отправка работает... 4-й пост минут 10 отправлялся
   SnarkHunter
 
6 - 24.05.04 - 16:59
Плин... Я же спрашивал про элемент диалога...
   Багира
7 - 24.05.04 - 17:07
Вообще Проба() - пробная процедура. Вместо нее планируется подставить ПриЗаписи() (для того, чтобы можно было ее запустить при групповом проведении). Может я вообще не тем путем иду?
   Багира
8 - 24.05.04 - 17:56
Ладно, конкретизирую задачу.
Для передачи в модуль проведения документа Таблицы значений, созданной в процессе редактирования документа в пр-ре ПриЗаписи() используем Провести(,ТЗ). На кнопку ОК вешаем (#Записать Закрыть). Интерактивная запись/проведение работает исключительно. При групповом проведении (из обработки) ТЗ создается программно, для передачи ее в модуль проведения необходимо обратиться к ПриЗаписи().
По совету более опытных товарищей :) принято решение вызывать ее через шаблон в Глобальном модуле.

В мод. формы:
Процедура П()
    _Вычислить("ПриЗаписи");
КонецПроцедуры

В гл. мод.:
Процедура _Вычислить(Выражение) Экспорт
    Шаблон("["+Выражение+"()]"); 
КонецПроцедуры

Ругается как сказано выше.

Я вот думаю, может вообще задействовать в обработке Форма.ПриЗаписи() ? Почему опытные товарищи рекомендовали именно такой путь?
   SnarkHunter
 
9 - 25.05.04 - 06:09
Потому что опытные товарищи пользуются ВК Formex...


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует