Вход | Регистрация

1С:Предприятие ::

Метки: 

помогите ВыгрузитьТабличнуюЧасть()

Я
   Таня
 
21.05.04 - 14:56
Как в одну таблицу значений выгрузить табличные части двух документов, чтобы строки в таблицу добавлялись?    

Расходники.ВыбратьСтроки();
    Пока Расходники.ПолучитьСтроку() = 1 Цикл
        Докум.НайтиДокумент(Расходники.Докум);
        Докум.ВыгрузитьТабличнуюЧасть(ТЗ);        
    КонецЦикла;    

У меня остается одна последняя.
 
  Рекламное место пустует
   SnarkHunter
 
1 - 21.05.04 - 14:57
Цикл не нужен...
   SnarkHunter
 
2 - 21.05.04 - 14:57
Фигню сказал...
   alxkorvin
 
3 - 21.05.04 - 14:59
Либо обходи табличную часть по строкам и используй ТЗ.НоваяСтрока(), либо выгружай в 2 ТЗ, а потом вторую выгружай в первую.
   Bzzzzz
 
4 - 21.05.04 - 15:02
Снарк уработался за неделю :-)
Выгрузить... замещает ТЗ, вроде как.
   Таня
 
4 - 21.05.04 - 15:02
Так это если будет не два документа а 100000... и тд. сколько же будет ТЗ??!!
   SnarkHunter
 
6 - 21.05.04 - 15:05
(4)Да, пожалуй... :-)
   alxkorvin
 
7 - 21.05.04 - 15:06
(4) ТЗ все равно будет 2 :)
   Таня
 
8 - 21.05.04 - 15:08
Да я уж сделала через НовуюСтроку(). Всем Спасибо
   alxkorvin
 
9 - 21.05.04 - 15:15
ТЗ = СоздатьОбъект("ТаблицаЗначений");
ТЗВрем = СоздатьОбъект("ТаблицаЗначений");
Пока Расходники.ПолучитьСтроку() = 1 Цикл 
    Докум.НайтиДокумент(Расходники.Докум); 
    Докум.ВыгрузитьТабличнуюЧасть(ТЗВрем);
    ТЗВрем.Выгрузить(ТЗ);
КонецЦикла;     

Вот примерно так :)
   Press
10 - 21.05.04 - 15:19
(9)Чушь...
 
  Рекламное место пустует
   alxkorvin
 
11 - 21.05.04 - 15:21
(10) Почему?
   Bzzzzz
 
12 - 21.05.04 - 15:23
(11) будет всё время последняя ТЗ
   mszsuz
 
13 - 21.05.04 - 15:31
Процедура Сформировать()
    ТЗРезультат=СоздатьОбъект("ТаблицаЗначений");        
    ТЗРезультат.НоваяКолонка("К","Число",10,0);        
    Для СколькоРаз=1 по 3 Цикл 
       // заполним промежуточную

        ТЗ=СоздатьОбъект("ТаблицаЗначений"); 
        ТЗ.НоваяКолонка("К","Число",10,0);        
        Для нс=1 по 10 Цикл
            ТЗ.НоваяСтрока();
            ТЗ.К=нс;         
        КонецЦикла;                 
       // сольём

        ТЗРезультат.КоличествоСтрок(ТЗРезультат.КоличествоСтрок()+ТЗ.КоличествоСтрок());
        ТЗРезультат.Заполнить(ТЗ,ТЗРезультат.КоличествоСтрок()-ТЗ.КоличествоСтрок()+1);
    КонецЦикла;  
   // смотрим

    ТЗРезультат.ВыбратьСтроку();
КонецПроцедуры
   mszsuz
 
14 - 21.05.04 - 15:33
(+13) Ключевое слово "Заполнить()"
   Bzzzzz
 
15 - 21.05.04 - 15:36
(14)Приз в студию!
Заполнить работает быстрее, чем перекидывать построчно?
   mszsuz
 
16 - 21.05.04 - 15:46
(15) В полтора раза.
   Таня
 
17 - 21.05.04 - 15:46
ужжас :)
   mszsuz
 
18 - 21.05.04 - 15:46
(+16) ... для одной колонки.
   lexa
 
19 - 21.05.04 - 18:18
а не проще через запрос?
   alxkorvin
 
20 - 21.05.04 - 18:46
(12) Да что то я прогнал. Мне казалось что Выгрузить не очищает ТЗ.


Список тем форума
Рекламное место пустует   Рекламное место пустует
Компьютер — устройство разработанное для ускорения и автоматизации человеческих ошибок.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует