Вход | Регистрация

1С:Предприятие ::

Метки: запросы, Запросы и построители

Тут вижу тут не вижу ИЛИ Запрос и все, все, все

↓ [Львенок, 19.05.04 - 13:10]
Я
   Львенок
 
19.05.04 - 12:57
Есть ряд впросов... Вот коротенький код отчетика
Процедура Сформировать()
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = 
"
|Фирма = Регистр.ПартииНаличие.Фирма;
|Номенклатура = Регистр.ПартииНаличие.Номенклатура;
|Партия = Регистр.ПартииНаличие.Партия;
|Док = Регистр.ПартииНаличие.ТекущийДокумент;
|КоличествоП = Регистр.ПартииНаличие.Количество;
|СуммаУпр = Регистр.ПартииНаличие.СуммаУпр;
|Функция КоличествоПКонОст = КонОст(КоличествоП);
|Функция СуммаУпрКонОст = КонОст(СуммаУпр);
|Функция Ра=Расход(КоличествоП);     
|Функция К=Счётчик(); 
|Группировка Номенклатура без групп;
|Группировка Партия;
|Группировка Документ;
|Условие(Номенклатура в ВыбНоменклатура);
|";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда Сообщить ("Жопа");Возврат;КонецЕсли;

Запрос.Выгрузить("ТестТабл",0,1)// !!!!!!!!!*1    

Пока Запрос.Группировка(1) = 1 Цикл
   Сообщить ("А: "+Запрос.Номенклатура);
   Пока Запрос.Группировка(2) = 1 Цикл
      Сообщить ("Б: "+Запрос.Партия);
      Пока Запрос.Группировка(3) = 1 Цикл
         Сообщить ("В: "+Запрос.Документ)// !!!!!!!!*2

      КонецЦикла;                                                  
   КонецЦикла;                                     
КонецЦикла;
КонецПроцедуры

ТестТабл - ТаблицаЗначений лежащая на форме, ВыбНоменклатура - справочник номенклатура, лежит там же.

Так вот я не понимаю, то ли я идиот, толи ... все равно я идит... Но результат работы кода - поримерно таков:

1) ТестТабл - остается девственно пустой(!) - каким образом интересно?
2) Группировки обходятся - все кроме третьей - треться вечно пустая, т.е. строк типа "В: Документ-Такой-То" не бывает.
3) Резальтат не меняется, если группироку Документ заменить на группироку Док

Мне не ясно почему ТаблицаЗначений получается пустой, если группировки при этом обходятся (хотя и не все)? И мне не ясно почему группировка по документу не работает упорно. Я туплю? (ТиС 7.70.930, 1С:Предпр SQL 7.70.021)
___
Искренне Ваш, Львенок.
 
  Рекламное место пустует
   SnarkHunter
 
1 - 19.05.04 - 13:04
Кавычки у ТестТабл - лишние...
   SnarkHunter
 
2 - 19.05.04 - 13:06
А по поводу третьей группировки... Остатков на документ нету - только движения...
   Львенок
 
3 - 19.05.04 - 13:07
Вопрос, снимается, я нашел все глюки. Они дейтсивтельно мои и я действительно туплю. Таблицу заключил в кавычки, а запрос без периода. Если это исправить, все работает как ожидается.
___
Искренне Ваш, Львенок.


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует