Вход | Регистрация

1С:Предприятие ::

Метки: 

Табличная часть в 8.0

Я
   Valentin_ Azheronok
 
16.05.04 - 09:06
В документе по кн "подбор" заполняю табличную часть.
Процедура ОбработкаВыбора(ЗначениеВыбора,Источник)
  -что писать здесь, мучаюсь вторые сутки, как добавить строку, если получается то добавляются две?

//не советуйте см. Упр. торговлей, там черт голову сломит. Хочется по простому, как в 7.7.  "НоваяСтрока(); и т.д.
 
 
   Волшебник
 
1 - 16.05.04 - 10:58
НовСтрока = ТабЧасть.Добавить();
НовСтрока.Товар = ...
и т.д.
   Valentin_ Azheronok
 
2 - 16.05.04 - 11:17
У меня добавляются две строки, как от этого избавиться?
   Волшебник
 
3 - 16.05.04 - 11:23
Значит процедура вызывается 2 раза.
Перед добавлением можно проверять, может строка с этим товаром уже есть.
   Valentin_ Azheronok
 
4 - 16.05.04 - 11:59
вот процедуры модуля формы:
Процедура КоманднаяПанель1Подбор(Кнопка)
    Форма=Справочники.Номенклатура.ПолучитьФормуВыбора(,ЭтаФорма);
    Если Не Форма.Открыта() Тогда
        Форма.ИмяСохраненияПоложенияОкна="Подбор Номенклатуры";
    КонецЕсли;
    Форма.РежимВыбора=Истина;
    Форма.ЗакрыватьПриВыборе=Ложь;
    Форма.РазрешитьСостояниеПрикрепленное=Истина;
    Форма.Открыть();
КонецПроцедуры

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    НовСтрока=Товары.Добавить();
    НовСтрока.Товар=ЗначениеВыбора;
КонецПроцедуры

а это в модуле справочника:
Процедура СправочникСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    ОповеститьОВыборе(ВыбраннаяСтрока);
КонецПроцедуры

и больше ничего.
   Valentin_ Azheronok
 
5 - 16.05.04 - 12:40
Волшебнику спасибо, разобрался. Убрал из модуля справочника все процедуры, теперь добавляет одну строку.
   Волшебник
 
6 - 16.05.04 - 12:45
Напоминает лечение перхоти отсечением головы.
Нужно было поставить точку останова на первую строку процедуры и просмотреть стек вызовов в отладчике.
   afk
7 - 16.05.04 - 12:56
(5) или, как я понимаю, надо использовать в мф дока процедуру ОбработкаПодбора()


Список тем форума
  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует