Вход | Регистрация

1С:Предприятие ::

Метки: формы

Как вставить формулу в элемент диалога Поле со списком

Я
   Таня
 
12.05.04 - 15:47
Я вставила формулу и соответственно в модуле формы документа есть процедура, то при выборе значения (позиции) в списке, должна меняться видимость одного из полей формы. Почему, когда я выбираю второе значение, то выполняется процедура, но при этом список показывает первое значение. Что делать?
 
  Рекламное место пустует
   Gavrila
 
1 - 12.05.04 - 16:04
ищи в модуле .ТекущаяСтрока()
   Таня
 
2 - 12.05.04 - 16:06
Есть у меня ТекущаяСтрока()
Щас кусок напишу:

Процедура ВыборОтгрузки();
    Если Константа.КомиссионнаяТорговля = Перечисление.Булево.Нет Тогда
       Иначе
        Если СписокВидовОтгрузки.ТекущаяСтрока() = 1 Тогда
            Форма.ДоходыРасходы.Видимость(1);
            Форма.ЗагДох.Видимость(1);
        ИначеЕсли  СписокВидовОтгрузки.ТекущаяСтрока() = 2 Тогда
            Форма.ДоходыРасходы.Видимость(0);
            Форма.ЗагДох.Видимость(0);
        КонецЕсли;              
    КонецЕсли;
КонецПроцедуры
   Таня
 
3 - 12.05.04 - 16:10
В принципе задача такая: надо чтобы если основным видом деятельности является комиссионная торговля (переключается константой), то надо в отгрузке выручку на 91 счет, поэтому, если комиссионка = да, тогда в списке значений видов отгрузки должно быть 91 и 45, иначе 90 и 45
когда отладчиком смотрю, то если выбираю 45 СписокВидовОтгрузки.ТекущаяСтрока() показывает =2, а в самом списке показывает все время 91, хотя видимость поля ДоходыРасходы меняется как надо.
   Gavrila
 
4 - 12.05.04 - 16:35
А список правильно заполнен?:) может там одинаковые значения?:)
   Таня
 
5 - 12.05.04 - 16:37
Нет, значения разные
в конце модуля :
Если Константа.КомиссионнаяТорговля = Перечисление.Булево.Да Тогда
        СписокВидовОтгрузки.ДобавитьЗначение(1, "Продажа (счет 91)"); 
        Форма.ДоходыРасходы.Видимость(1);
        Форма.ЗагДох.Видимость(1);
    Иначе
        СписокВидовОтгрузки.ДобавитьЗначение(1, "Продажа (счет 90)"); 
        Форма.ДоходыРасходы.Видимость(0);
        Форма.ЗагДох.Видимость(0);
    КонецЕсли;
СписокВидовОтгрузки.ДобавитьЗначение(2, "Отгрузка (счет 45)");
   Таня
 
6 - 12.05.04 - 16:40
Когда отладчиком смотрю, то успеваю заметить, что до перехода в отладчик в поле отражается 45 счет (то что выбираю), а когда из отладчика обратно в бухгалтерию возвращаюсь, то уже 91 написано
   Gavrila
 
8 - 12.05.04 - 17:01
в чем проблемс то был ?
   Таня
 
9 - 12.05.04 - 17:03
а процедура, вставленная в поле со списком ничего не хочет выполнять, она только смогла присвоить значение переменной и передать управление на функцию, тогда я то что хотела в функцию вписала.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует