Вход | Регистрация

1С:Предприятие ::

Метки: 

Процедура МФО() Экспорт не пашет

Я
   LOSS
 
04.05.04 - 20:19
Перем МФОБанкаРасч Экспорт;
Процедура МФО() Экспорт
Если МФОБанкаРасч=    191201104    Тогда БанкРасч="AТЫРАУСКИЙ Ф-Л ГОС.УЧРЕЖДЕНИЯ ""НАЦ.БАНК РК"""
КонецЕсли
КонецПроцедуры

//В форме платежки набиваю

МФО(Контекст);
Далее в форме ругается. Где яне прав

МФО(<<?>>Контекст);    
{Справочник.Контрагенты.Форма.Модуль(4)}: Слишком много фактических параметров
МФО(<<?>>Контекст);    
{Справочник.Контрагенты.Форма.Модуль(4)}: Ожидается выражение
 
  Рекламное место пустует
   skunk
 
1 - 04.05.04 - 20:33
Процедура МФО(Переменная) Экспорт
   LOSS
 
2 - 04.05.04 - 20:43
//теперь  

Процедура МФО(МФОБанкаРасч) Экспорт
//но не хочет выполнять просто пусто


Если МФОБанкаРасч=    191201104    Тогда БанкРасч="AТЫРАУСКИЙ Ф-Л ГОС.УЧРЕЖДЕНИЯ ""НАЦ.БАНК РК""" 

//в форме два рекв диалога МФОБанкаРасч и БанкРасч
   skunk
 
3 - 04.05.04 - 20:59
объяви ее функцией...
   LOSS
 
4 - 04.05.04 - 21:07
голо..... Что еще попможет
Могу напрямую в модуль формы кинуть, так работает но нужен Экспорт
   kvm
 
5 - 04.05.04 - 21:52
Если МФОБанкаРасч.МФОБанкаРасч=191201104 Тогда
    МФОБанкаРасч.БанкРасч="//и т.л.,

 ты-же контекст передал, а надо конкретное поле.
   kvm
 
6 - 04.05.04 - 22:02
процедура глМФОБанкаРасч (Конт) Экспорт
    Если Конт.МФОБанкаРасч=191201104 Тогда
        Конт.БанкРасч=AТЫРАУСКИЙ Ф-Л ГОС.УЧРЕЖДЕНИЯ ""НАЦ.БАНК РК""";
    КонецЕСли;
КонецПроцедуры
   LOSS
 
7 - 04.05.04 - 22:12
2kvm сорри за ламеризм, унас поздняя ночь вот глюконат пред глазами. Заработало


Список тем форума
Рекламное место пустует   Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует