Вход | Регистрация

1С:Предприятие ::

Метки: 

Сбилась нумерация докумнетов с префиксом

Я
   Killgur
 
28.04.04 - 14:46
1С77, бухгалтерия
Документ Поступление материалов доработан. При выборе склада приходования документу назначается свой префикс код (2 символа, из справочника Места хранения). С некоторых пор сбилась нумерация (руками заменяли коды не по порядку). Сейчас при выборе склада 1, назначается первый номер - СГ000001, который уже существует. Если создать документ с нормальным номером после которого их уже нет, следующий автоматический номер все равно будет СГ000001.

Как восстановить автоматическую нумерацию?
Каким образом 1С формирует номера?
 
  Рекламное место пустует
   SnarkHunter
 
1 - 28.04.04 - 14:47
УстановитьНовыйНомер
   Мистика
 
2 - 28.04.04 - 14:48
искать где не правильно поменяли или сделать не очень правильно
изменить букву С русскую на С английскую
   Killgur
 
3 - 28.04.04 - 14:52
Процедура ПриВыбореМестаХранения()
    УстановитьНовыйНомер(МестоХранения.ПрефиксКода)
КонецПроцедуры//ПриВыбореМестаХранения


(2) На счет "С" проверю ...
   Killgur
 
4 - 28.04.04 - 14:57
(2) да вроде все русское

.. или сделать не очень правильно..
Это как?

Пытался сделать новый документ с завышенным номером. По фигу. Все равно начинаем потом с СГ000001
   SnarkHunter
 
5 - 28.04.04 - 14:58
Длина номера какая?
   Killgur
 
6 - 28.04.04 - 15:00
(5) Текстовый 8
   SnarkHunter
 
7 - 28.04.04 - 15:03
А документ с номером СГ000001 имеется?
   lexa
 
10 - 28.04.04 - 15:13
Попробуй
ПрефиксАвтоНумерации
Установить префикс для автоматического создания новых номеров.

Синтаксис:

ПрефиксАвтоНумерации(<ИмяВида>, <Префикс>)

Англоязычный синоним:

AutoNumPrefix

Параметры:

<ИмяВида>
Строковое выражение с полным названием справочника или документа, как он назван в конфигурации.

<Префикс>
Строковое выражение — префикс номеров документов или кодов элементов справочника.


Описание:

Процедура ПрефиксАвтоНумерации устанавливает префикс для автоматического создания новых номеров документов или кодов элементов справочника.

Вызов данного метода может быть использован для установки префикса всем документам или справочникам. При этом используется символ \\\"*\\\" вместо идентификатора вида документа/справочника, например

ПрефиксАвтоНумерации(\\\"Документ.*\\\", \\\"ПР-\\\")

Пример:

ПрефиксАвтоНумерации(\\\"Документ.РасходнаяНакл\\\", \\\"Рн-\\\");
 
  Рекламное место пустует
   Killgur
 
11 - 28.04.04 - 15:18
(9) Повторяю. Да, имеется.
(10) Один и тот же документ нумеруется в зависимости от склада приходования с разными префиксами. Так что думаю ПрефиксАвтоНумерации тут не совсем кстати. Я использую (3).
Да, и синтаксис-помощник у меня есть. Незачем столько из него приводить :)
   SnarkHunter
 
12 - 28.04.04 - 15:20
Не синтаксис, а синтакс...
Документ с этим номером в том же периоде нумерации, что и создаваемый?..
   Killgur
 
13 - 28.04.04 - 15:25
(12) Да. Год тот же.
Периодичность Год, Автоматическая нумерация, контроль уникальности, нумератора нет.
При попытке записать с номером СГ000001 ругается на неуникальный номер.
   lexa
 
14 - 28.04.04 - 15:31
Попробуй
Процедура ПриВыбореМестаХранения() 
   УстановитьНовыйНомер(СокрЛП(МестоХранения.ПрефиксКода)); 
КонецПроцедуры//ПриВыбореМестаХранения
   lexa
 
16 - 28.04.04 - 15:54
а ты попробуй в ТиС в глобальном модуле в процедуре аналогичной твоей именно так не Префикс а СокрЛП(префикс)
   Killgur
 
17 - 28.04.04 - 16:03
(16)
Да я попробовал - разницы никакой. Кстати метод нормально отрабатывает и префикс "Г ", пробел он просто не замечает. Номер формируется вида Гххххххх (8 символов)
В данном случае СокрЛП("СГ") = "СГ", так что на результат не влияет. :(
   FAM
 
19 - 29.04.04 - 09:11
Обработкой перенумеруй документы.
Док = СоздатьОбъект("Документ.ПоступлениеМатериалов");
Док.ВыбратьДокументы(Дата1,Дата2);

Пока Док.ПолучитьДокумент() = 1 Цикл
     Если УстановитьНовыйПрефикс = 1 Тогда 
          Док.УстановитьНовыйНомер("Н"); 
     Иначе 
    Док.УстановитьНовыйНомер(СокрЛП(Док.МестоХранения.ПрефиксКода));    
     КонецЕсли;    
     Док.Записать();
КонецЦикла;


Список тем форума
 
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует