Вход | Регистрация

1С:Предприятие ::

Метки: 

Подмена субконто в проводках бех проведения документа

Я
   Killgur
 
26.04.04 - 08:59
Навеяно Глюки или что???

Как подменить субконто в проводках? Знаю что можно. Где то пробегало, но найти не могу. Возможна ли такая подмена в движениях регистров или тут только перепроведение с новыми значениями?
 
  Рекламное место пустует
   SnarkHunter
 
1 - 26.04.04 - 09:10
Подменить можно... До первого перепроведения документа...
   Killgur
 
2 - 26.04.04 - 09:23
(1) А в документах? Опять же без перепроведения.

Ссылочки не кто не подбросит?
   SnarkHunter
 
3 - 26.04.04 - 09:32
У тебя компонента какая?
   Killgur
 
4 - 26.04.04 - 10:00
v77 все компоненты
   SnarkHunter
 
5 - 26.04.04 - 10:05
Млин... ДокУменты у тебя только бух проводки делают или еще движения по регистрам?
   mszsuz
 
6 - 26.04.04 - 10:50
Для Бухгалтерии можно взять за основу эту: http://1c.klim.org/pafiledb/pafiledb.php?action=file&id=17
Для Регистров - посмотри на ИТС в метод.конфе или поищи в Инете по словам "технологическое проведение".
   Killgur
 
7 - 26.04.04 - 11:47
(5) Только проводки.
(6) Спасибо.
А не будет ли перепроводиться документ по Док.Записать(); если в нем стоит      ПриЗаписиПерепроводить(1);
   SnarkHunter
 
8 - 26.04.04 - 11:49
Будет... Метод ведь так и называется - ПриЗаписиПерепроводить...
   Killgur
 
9 - 26.04.04 - 12:25
(8) Речь шла о таком коде:

Док = СоздатьОбъект("Документ");
Опер = СоздатьОбъект("Операция");
Опер.ВыбратьОперации(Дата1,Дата2);

Пока Опер.ПолучитьОперацию()=1 Цикл 
    Если Опер.Документ.Вид() <> "Операция" Тогда
        ВидДок=Опер.Документ.Вид();
        Док.НайтиДокумент(Опер.Документ);
            ..............
        Док.Записать();
      КонецЕсли;
КонецЦикла;

Судя по тесту не будет.
   AVP
10 - 26.04.04 - 13:41
(9)
1) Во-первых, при программной записи предопределенные функции модуля формы документы НЕ вызываются.
2) Проводки все же лучше менять через такую конструкцию:
Опер = СоздатьОбъект("Операция"); 
Опер.ВыбратьОперации(Дата1,Дата2); 
Пока Опер.ПолучитьОперацию()=1 Цикл
  Опер.ВыбратьПроводки();
  Пока Опер.ПолучитьПроводку()=1 Цикл
   // А здесь меняем по условию нужное субконто

...
  КонецЦикла;
  Опер.Записать();// Можно и по условию, что выше что-то меняли...

КонецЦикла;
 
  Рекламное место пустует
   Killgur
 
11 - 26.04.04 - 14:57
Все понял. Вопрос исперчен.
Всем спасибо.
   SnarkHunter
 
12 - 26.04.04 - 15:29
Может посолён?


Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует