Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки: 

Проверка дублей строк

Ø
Я
  
28.06.01 - 13:55
Привет всем.
При введении товара в накладную осуществляется проверка на повторное введение такого же товара. Если такой товар уже был ранее введен, проверяющая функция возвращает номер строки, в которой уже естть данный товар.
Вопрос.
Каким образом програмно можно прервать ввод строки табличной части документа и спозиционировать курсор на строку с определенным номером Х?
 
  Рекламное место пустует
   Чингачгук
1 - 28.06.01 - 13:57
ТекущаяСтрока(Х)?
   modelist
2 - 28.06.01 - 13:59
АктивизироватьСтроку(<?>)
   Чингачгук
3 - 28.06.01 - 14:04
сорри за (1). см. (2)
   Angle
4 - 28.06.01 - 14:12
А как прервать редактирование текущей строки?
   AndyG
5 - 28.06.01 - 14:30
Друзья!
А объясните мне, пожалуйста, из-за чего все так боятся дублирования строк?
   Searcher
6 - 28.06.01 - 14:36
(5) а потому, что в типовых при этом себестоимость летит...
   .
7 - 28.06.01 - 14:38
2(5) Ну например:
У тебя в прих. накладной одинаковый товар, но по разной цене, а списание ведется по FIFO (LIFO).
   Angle
8 - 28.06.01 - 14:38
Ну, вот, например, вводиш приходную накладную исходя из расхода за день (неделю, месяц), приходные цены от балды (~70-80% от продажных) и в одной приходной накладной у тебя один и тотже товар приходуется по разным ценам. Нехорошо.
При реализации, если накладная позиций этак на 300, из которых 80 повторяются, это тоже никому не нужно.
 
И всеже, (4)?
   dbhost
9 - 28.06.01 - 14:40
2 (5)
Однако ....
Допустим, товара ХХХХ есть 10 единиц:
1. Выбрали товар ХХХХ, указали колво 7, программа проверила отстаотк на складе - все нормально
2. Еще раз выбрали товар ХХХХ, указали колво 8, программа проверила остаток - все нормально
3. Сделали расход... и получили -5
Вот такие дела...
   .
10 - 28.06.01 - 14:40
2(4,8) А ты делай через подбор.
 
  Рекламное место пустует
   Angle
11 - 28.06.01 - 14:46
2(10) Была мысль через подбор, но он для других целей используется. Можно ли сделать два разных подбора в одном док-те?
   Vspl
12 - 28.06.01 - 14:52
(7),(9) Ну если так написать алгоритм проведения,
то конечно. Но обычно проводится не табличная часть,
а предварительно свернутая. Так что этих проблем нет.
   AndyG
13 - 28.06.01 - 14:54
Про FIFO и LIFO не говорю - веду по средней себестоимости.
А в расходной (перемещение) я завожу значения в СписокЗначений, а потом сверяю остаток данного товара в регистре с значением из СпискаЗначений.
А дублировать строки работники нашего отдела сбыта ох как хотят и любят!
   Gero
14 - 28.06.01 - 14:56
2(0) Скажи, а у тебя какой расчет списания себестоимости?
//-------------------------------------------------------
Если по средней - повезло, тогда ограничение на дубли вообще можно снять, только вот в счетах/резервах аккуратней, и вообще в подобных документах, которых основанием других являются.
   .
15 - 28.06.01 - 15:22
2(11)Да легко.
Процедура ОбработкаПодбора(Выб)
КонецПроцедуры
   .
16 - 28.06.01 - 15:24
Sorry
2(11)Да легко.
Процедура ОбработкаПодбора(Выб)
 Если Выб.Вид()="ХХХХ" Тогда
 ИначеЕсли Выб.Вид()="YYY" Тогда
 КонецЕсли;
КонецПроцедуры



Список тем форума

Форум Территория 1С

  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует