Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки: 

???????????? - ФС.НайтиПервыйФайл(

Ø
Я
  
12.02.01 - 14:29
Процедура Отчет()
Folder = КаталогБазыДанных() + "Dbfs\";
ФС.НайтиПервыйФайл(Folder+"*.dbf");
Пока ПустаяСтрока(ФС.НайтиСледующийФайл())<>1 Цикл
ФС.АтрибутыФайла(Имя,Размер,Атр,ВремяСоздания,ВремяПослДоступа,ВремяПослЗаписи,РасшИмя);
Сообщить(Имя);
КонецЦикла;
Вобщем мне нужно получить имена файлов с расширением *.dbf в какой-нибудь
папке, а у меня никак не получается ...
Может я че то не то делаю ????
Подскажите кто может ... :-)
КонецПроцедуры
 
 
   Dag
1 - 12.02.01 - 14:34
Ищи. Буквально не той неделе кто-то сталкивался с этой проблемой. И ее решил.
   Хоменко Валерий
2 - 12.02.01 - 14:45
А где же ей бедной искать следующий файл?
Поставь сначала
ФС.УстТекКаталог(Folder );
   Mx
3 - 12.02.01 - 14:51
Ну для начала:
Строка "Пока ПустаяСтрока(ФС.НайтиСледующийФайл())<>1 Цикл"
_УЖЕ_ переходит на следующий файл, т.е. первый файл не хватается...
   Vladimir Kozlov
4 - 12.02.01 - 15:08
У меня такой код работает без проблем еще со времен 7.5 :
........................
ФС.УстТекКаталог(ПутьБД);
Файл=ФС.НайтиПервыйФайл("*.DBF");
Пока ПустаяСтрока(Файл)=0 Цикл
	ДБФ.ОткрытьФайл(Файл);
	Если ДБФ.Открыта()=1 Тогда
            ................// требуемые манипуляции
		ДБФ.ЗакрытьФайл();
	Иначе
		Сообщение("Ошибка при открытии файла : <"+ПутьБД+Файл+">!");
	КонецЕсли;
      ..........
      Файл=ФС.НайтиСледующийФайл();
КонецЦикла;
   1cNick
5 - 12.02.01 - 15:10
Огромное всем спасибо !!!
   Акела
6 - 13.02.01 - 12:06
Вот такой кусочек:
ФС.УстТекКаталог("C:\astra\MAILBOX\SCLAD\R\");//Загрузка заказов	
Файл=ФС.НайтиПервыйФайл("sf*.*");
  Пока ФС.СуществуетФайл(Файл)=1 Цикл
  //некая фигня ...........
  //....................
  ФС.УдалитьФайл(Файл);
  Файл=ФС.НайтиСледующийФайл();
  сообщить(файл);
КонецЦикла;
Так вот эта фигня у меня (14 релиз) находит все файлы с соотв. расширением,
а на складе, где "умный" мальчик поставил 4-й релиз - только один файл за каждый запуск обработки. Релиз-то я ему сегодня переставлю, но интересно... Может кто встречал?
   ОЩРТ
7 - 13.02.01 - 12:11
Да здравствует 4-й релиз, самый рулезный релиз- работающий на эмуле, без патча екзешника! 8-)
   Акела
8 - 13.02.01 - 13:25
7: не издевайся. Сам знаю. "Малчик" его с какого-то бащарного компакта ставил. Лучше скажи: это действительно глюк или я на своем 14-м "что-то делаю неправильно"?
   Ал
9 - 13.02.01 - 13:26
Встречал.
У четвёртого релиза много-о-о таких приколов. И с таблицами и с календарями и с запросами.



Список тем форума

Форум Территория 1С

Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует