Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки: 

А кому еще глюк под SQL?

Ø
Я
  
27.12.00 - 15:41
Olga_A
 
 
   Alex
1 - 27.12.00 - 16:54
Проверил на 14 билде (15 не имею). По образцу стр. 1 работает нормально, без глюков.
   Mike
2 - 27.12.00 - 17:41
А "нерасчет" временных итогов в SQL это известная ошибка?
Я, кажется, сообщение про это видел а сейчас вот напоролся :((((
   Alex
3 - 27.12.00 - 17:51
О чем это ты? Считает все итоги, как же без них то?
   Mike
4 - 27.12.00 - 17:58
Следующий код работает под ДБФ и не работает под SQL:
Ит.ПериодМ(ТДата);
Ит.Рассчитать(НачМесяца(ТДата),КонМесяца(ТДата),"100");
Спр1.ВыбратьЭлементы();
Пока Спр1.ПолучитьЭлемент()=1 Цикл
КО1=Ит.КО("100",,,Спр2.ТекущийЭлемент(),Спр1.ТекущийЭлемент());
ДО1=Ит.ДО("100",,,Спр2.ТекущийЭлемент(),Спр1.ТекущийЭлемент());
Р1=КО1-ДО1;
Если (КО1<>0) или (ДО1<>0)Тогда
Таб.ВывестиСекцию("С1");
Спр2.ВыбратьЭлементы();
Пока Спр2.ПолучитьЭлемент()=1 Цикл
КО1=Ит.КО("100",,,Спр2.ТекущийЭлемент(),Спр1.ТекущийЭлемент());
ДО1=Ит.ДО("100",,,Спр2.ТекущийЭлемент(),Спр1.ТекущийЭлемент());
Р1=КО1-ДО1;
Если (КО1<>0) или (ДО1<>0)Тогда
Если Р1<0 Тогда
Таб.ВывестиСекцию("СтрокаБ");
Иначе
Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
Правда, ДатаТ находится в следующем периоде БИ...



Список тем форума

Форум Территория 1С

 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует