Вход | Регистрация

1С:Предприятие ::

Метки: 

Выгружаю в файлик XBase строковую переменную, а там ... ?!

Я
   ValleySilence
 
03.12.03 - 14:47
Создал обработку по выгрузке многострочной части документа в файл формата XBase. Документ в многострочной части имеет идентификатор "ФИО", который выбирается из справочника "Студенты". Я не могу понять, почему вместо фамилии (поле "ФИО") в файл, в поле ФИО появляются цифры 11,12,13.
 
  Рекламное место пустует
   Puh
1 - 03.12.03 - 14:59
Это коды из справочника Сотрудники. В модуле используй ДБФ.ФИО=Спр.Сотрудники.Наименование тогда в файл попадут фамилия имя отчество из справочника
   Puh
2 - 03.12.03 - 15:02
Виноват, вместо "Сотрудники" должны быть "студенты" конечно
   ValleySilence
 
3 - 03.12.03 - 15:04
Слушай Пух, а если у меня идет выборка в файлик из документа ничего страшного не случится когда я добавлю еще выборку из справочника ?
Вот код моей обработки:
//*******************************************

Процедура Выполнить()

ДБФ = СоздатьОбъект("XBase");
ДБФ.ДобавитьПоле("SBB", "S", 25,0);
ДБФ.ДобавитьПоле("OSB", "S", 25,0);
ДБФ.ДобавитьПоле("NVD", "S", 4,0);
ДБФ.ДобавитьПоле("GOD", "S", 2,0);
ДБФ.ДобавитьПоле("MES", "S", 2,0);
ДБФ.ДобавитьПоле("NPD", "S", 6,0);
ДБФ.ДобавитьПоле("FIO", "S", 50,0);
ДБФ.ДобавитьПоле("LSH", "S", 24,0);
ДБФ.ДобавитьПоле("SUM", "N", 14,2);
ДБФ.ДобавитьПоле("NV", "S", 1,0);
ДБФ.ДобавитьПоле("TDK", "S", 1,0);
ДБФ.ДобавитьПоле("DVP", "S", 2,0);
ДБФ.ДобавитьПоле("TIP", "S", 1,0);
ДБФ.СоздатьФайл("a:\filial.dbf");

Док = СоздатьОбъект("Документ");    
Док.ВыбратьДокументы(НачПериода, КонПериода);

Пока Док.ПолучитьДокумент() > 0 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку() > 0 Цикл
        ДБФ.Добавить();
        ДБФ.SBB = Док.НомерБанка;
        ДБФ.OSB = Док.НомерФилиала;
        ДБФ.GOD = Год;
        ДБФ.MES = Месяц;
        ДБФ.FIO = Док.ФИО;        
        ДБФ.LSH = Док.ЛицевойСчет;
        ДБФ.SUM = Док.Всего;
        ДБФ.Записать();
    КонецЦикла;
КонецЦикла;

ДБФ.ЗакрытьФайл();

КонецПроцедуры
   Puh
4 - 03.12.03 - 15:10
Сделай так ДБФ.FIO = Док.ФИО.Наименование
Док.ФИО - это объект справочника,значит строка "Док.ФИО.Наименование" корректна.
Хотя можно создать справочник и выбирать из него по коду
   ValleySilence
 
5 - 03.12.03 - 15:18
Пух, все получилось ! Спасибо, дружище :)
   Puh
6 - 03.12.03 - 15:21
Пожалста. Сам когда-то с такой проблемой парился


Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует