Вход | Регистрация

1С:Предприятие ::

Метки: 

Почему не получается вставить в табличную часть справочник?

Я
   777
03.03.04 - 15:46
Надо переделать ряд документов, так вот, нужный справочник ни как не хочет влезать.

Процедура Вставка()   
    док = создатьобъект("документ.приход"); 
    спрМатериал=СоздатьОбъект("Справочник.Материалы"); 
    док.выбратьдокументы();
    пока док.ПолучитьДокумент() > 0 цикл 
        
        очиститьОкноСообщений();
        если спрМатериал.НайтиПоНаименованию("ххх")=0 тогда 
            Сообщить("не найден");
        иначе 
            Сообщить("найден!");
            спрН=спрМатериал.Наименование;
        КонецЕсли;    
                док.выбратьСтроки();
        пока док.ПолучитьСтроку()>0 цикл
            док.количество=20;
            док.стоимость=10;
            док.суммаРуб=док.стоимость * док.количество  ;
            док.Материал= спрН;
            док.провести(2,"Программно");  
        КонецЦикла; 
    конеццикла;
КонецПроцедуры

всё работает за исключением  " док.Материал= спрН;" ???
 
  Рекламное место пустует
   Кое-кто@где-то.там
1 - 03.03.04 - 15:48
док.Материал=спрН.ТЕКУЩИЙЭЛЕМЕНТ();
   afk
2 - 03.03.04 - 15:50
док.Материал = спрМатериал.ТекущийЭлемент()
   SnarkHunter
 
3 - 03.03.04 - 15:50
Бог Троицу любит...
Док.Материал = спрН.ТекущийЭлемент();
   afk
4 - 03.03.04 - 15:55
там выше строчка 
"спрН=спрМатериал.Наименование;"
   SnarkHunter
 
5 - 03.03.04 - 15:56
Точно... Молодец, глазастый... :-)
   777
 
6 - 03.03.04 - 16:06
Спасибо всем троим…
Ну вы и приколисты блин.

круто, всё заяботало :)

только вот хостинг ТРЫНДЕЦЦЦЦ...
" Ошибка у хостера ValueHost.Ru. Форум заработает через 3-5 минут! Подождите немного! Хостер обещал бороться с перегрузками и уже закупил 20 новых серверов. " 
пора бы поставить…
   SnarkHunter
 
7 - 03.03.04 - 16:10
Да, мы такие...
   Рупор абсурда
 
8 - 03.03.04 - 16:14
(7) Допрыгаешься ты ...
   SnarkHunter
 
9 - 03.03.04 - 16:14
Куда?
   Рупор абсурда
 
10 - 03.03.04 - 16:15
(9) Дофлудишься т.е. ...
 
  Рекламное место пустует
   SnarkHunter
 
11 - 03.03.04 - 16:21
Я в танке...
   327
12 - 03.03.04 - 18:31
Флудометы ... хреновы ....


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует