Вход | Регистрация


1С:Предприятие ::

Метки: 

Бухгалтерские итоги

Я
   Yulia
03.03.04 - 14:40
Как через бухгалтерские итоги вытянуть данные из банковской выписки?
 
 
   Кое-кто@где-то.там
1 - 03.03.04 - 14:44
А в итогах Операция есть?
   327
2 - 03.03.04 - 15:07
(1) банковская выписка... делает проводки ...
..............................................

банковская выписка делает движения по 51 и 52 счетам...

если 51 и 52 счета в дебете - приход денег на счет ... если в кредите - расход денег....

если нужен документ движения - запрос с детализацией до проводок.... Чтобы оттель вытянуть документ движения ...

Сам запрос ... ну, его я писать здесь не собираюсь ... ибо если и напишу - не поймешь ...
   Yulia
3 - 03.03.04 - 15:36
В итогах есть Операция. А можно ли обойтись без запроса?
   Yulia
4 - 03.03.04 - 15:41
Мне нужно сделать отчет по Контрагентах используя документ Банковская выписка.в отчете должна быть информация :Контрагент,датадок,номердок и сумма
   GrayT
 
5 - 03.03.04 - 15:41
Можно и без запроса. Перебором документов
"бухгалтерские итоги вытянуть данные из банковской выписки" - какие данные?
   SnarkHunter
 
6 - 03.03.04 - 15:41
Отчет по контрагентам о чем?
   Кое-кто@где-то.там
7 - 03.03.04 - 15:46
(3) Вот и обращайся: н-р
Операция.ТекущийДокумент().НомерДок;
   Yulia
8 - 03.03.04 - 15:50
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    
    Если   Подразделение.Выбран()=1 тогда
        Ит.ИспользоватьСубконто(ВидыСубконто.Подразделения,Подразделение , 2)//отбор

    иначе 
        Ит.ИспользоватьСубконто(ВидыСубконто.Подразделения, , 1)//разворачивать    

    КонецЕсли;
    
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты, ВыбСубконто1, 2);
    Ит.ВыполнитьЗапрос(ДатаН, ДатаК, СписокСчетов,,, 1, "Проводка", "С");
    Ит.ВыбратьПериоды();
    
    Пока Ит.ПолучитьПериод() = 1 Цикл
        Ит.ВыбратьСубконто(1); 
        Пока  Ит.ПолучитьСубконто(1)=1 Цикл
            Ит.ВыбратьСубконто(2);
            Пока  Ит.ПолучитьСубконто(2)=1 Цикл 
                
                Опер= Ит.Операция;
                
                Док= Ит.Операция.Документ;
                Если ((СписокСчетов.НайтиЗначение(Опер.Дебет.Счет)=0) И
                (СписокСчетов.НайтиЗначение(Опер.Кредит.Счет)=0)) 
                Тогда
                    Продолжить;
                Иначе 
                    Таб.ВывестиСекцию("Шапка");
                    Если Док.Вид()="БанковскаяВыписка"тогда 
                        Контр=Док.Контрагент;
                        дат=Док.НомерДок;
                        ном=Док.ДатаДок;
                        сумОп=Док.СуммаСНДС;
                        сумПр="";
                        сумРз="";
                    
                    КонецЕсли;
    КонецЦикла;
    КонецЦикла;
   Yulia
9 - 03.03.04 - 15:51
Не хочет так работать.Не вытягивает из Банковской выписки Контрагента и суммы
   Кое-кто@где-то.там
10 - 03.03.04 - 15:54
Так а там они разве не в табличной части расположены?
Если да, тогда надо так:
Док.ВыбратьСтроки();
Пока Док.ПолучитьСтроку()=1 Цикл
...
КонецЦикла;
 
 
   GrayT
 
11 - 03.03.04 - 15:54
Шапка в цикле. - забрасываем шапками? :))
И ни одной строки
   SnarkHunter
 
12 - 03.03.04 - 15:55
А секцию таблицы кто выводить будет с этими реквизитами? Пушкин А.С.?
   Yulia
13 - 03.03.04 - 15:57
Там есть вывод строки,я просто доконца не перекопировала  модуль
   SnarkHunter
 
14 - 03.03.04 - 15:58
Тогда смотри (10)...
   Yulia
15 - 03.03.04 - 16:06
Что такое (10)?
   SnarkHunter
 
16 - 03.03.04 - 16:07
Пост номер 10...
   GrayT
 
17 - 03.03.04 - 16:07
А что это за конфигурация. В Бухгалтерии вроде документ Выписка называется и в нем нет Контрагента (в чистом виде)
   Yulia
18 - 03.03.04 - 16:08
Понимаете в чем загвоздка,не хочет через Операцию из документа выбиратся сумма и Контрагент. Может надо как- то через Проводку?
   SnarkHunter
 
19 - 03.03.04 - 16:09
Кое-кто@где-то.там
10 - 03.03.04 - 15:54
Так а там они разве не в табличной части расположены?
Если да, тогда надо так:
Док.ВыбратьСтроки(); 
Пока Док.ПолучитьСтроку()=1 Цикл 
... 
КонецЦикла;
   Кое-кто@где-то.там
20 - 03.03.04 - 16:10
(10) Хинт: нажмите на синенькую десятку в начале этой строки ... :)
   327
21 - 03.03.04 - 18:31
И ни одного правильного ответа ..... Я пона мадам ....
   It is me
 
22 - 03.03.04 - 18:49
Правильные ответы могут быть только при наличии правильных вопросов. Таковых на данной ветке не обнаружено
   327
23 - 03.03.04 - 18:56
Вопрос поставлен вполне корректно ....



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует