Вход | Регистрация

Форумы на Кубань.Ру


1С:Предприятие ::

Метки: 

Из формы справочника сделать отбор в общем журнале документов

Ø
Я
   ЛюдмилаФ
29.11.04 - 05:46
Есть справочник "Контрагенты", есть документ "Спецификация". Можно ли выбрав контрагента, открыть общий журнал с отобранными документами "Спецификация" по выбранному контрагенту? Т.е. из формы справочника сделать отбор в общем журнале? Если можно, подскажите как?
 
 
   pit
1 - 29.11.04 - 05:53
Да, можно.
УстановитьОтбор(...) поможет в этом благородном деле
   ЛюдмилаФ
2 - 29.11.04 - 07:06
В форме спр-ка "Контрагенты" :
  Если Выбран() = 1 Тогда
    СписокПараметров = СоздатьОбъект("СписокЗначений");
    СписокПараметров.ДобавитьЗначение("Контрагент", "ВидОтбора");
    Параметр = ТекущийЭлемент();
    СписокПараметров.ДобавитьЗначение(Параметр, "Параметр");
    Если ПустоеЗначение(Параметр) = 0  Тогда
      ОткрытьФорму("Журнал.Спецификации.ФормаСОтбором#"+ ЗначениеВСтрокуВнутр(Параметр), СписокПараметров);
    КонецЕсли;
  КонецЕсли;
В общем журнале:
  Парам = Форма.Параметр;
  Если ПустоеЗначение(Парам) = 1 Тогда
    СтатусВозврата(0);
    Возврат;
  КонецЕсли;
  ВидыОтбора("");
  ВидОтбора = Парам.Получить("ВидОтбора");
  Параметр  = Парам.Получить("Параметр");
  Если ВидОтбора = "Контрагент"  Тогда
    УстановитьОтбор(ВидОтбора, Параметр);
  КонецЕсли;
Получаю журнал со всеми видами документов по заданному контрагенту, а мне надо только спецификации! Как передать в качестве параметра еще и вид документа=спецификация ???
   Frog
3 - 29.11.04 - 07:14
Возьми уникальный реквизит документа спецификация или сделай его и по нему сделай отбор
   Frog
4 - 29.11.04 - 07:16
Только сначала добавь графу отбора, по этому документу
   Mihasya
5 - 29.11.04 - 07:18
Никак.
Можно сделать еще одину графу отбора, напиример "КонтрагентСпецификации"
в свойствах (в выбранных значениях) указать только контрагента из документа "Спецификация"
и далее:
Если ВидОтбора = "КонтрагентСпецификации" Тогда
    УстановитьОтбор(ВидОтбора, Параметр);
КонецЕсли;
   ЛюдмилаФ
6 - 29.11.04 - 08:31
(5) Не получается, т.к. в остальные документы являются подчиненными спецификации и поле "Спецификация" присутствует в них как документ-основание. Поэтому в журнале есть все эти подчиненные документы.
Еще варианты есть?
   ЛюдмилаФ
7 - 29.11.04 - 08:39
(5) Извиняюсь, исправления сделала не в том журнале.
Все получилось! Спасибо огромное за помощь.



Список тем форума

Форум Территория 1С

 
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует