Вход | Регистрация

1С:Предприятие ::

Метки: 

2 запроаса в отчете!!!

Я
   Юра _Агро
20.02.04 - 12:05
Я НАЧИНАЮЩИЙ!!! Есть отчет. Внем 2 запроса. 1 из справоника Сотрудники, а 2 из документа зарплата?! Нужно как-бы проверить Существует сотрудник в справочнике, и не пропустили ли его с начислениями. При попытке присоединить секцию по первому запросу секции выстраиваются в колонку, а для 2 запроса - в ряд!!!
СПАСИБО если КТО откликнется!
 
 
   SnarkHunter
 
1 - 20.02.04 - 12:08
Увидел только один знак вопроса... Причем в предложении по смыслу никак не вопросительном...
   Wow__cooL
2 - 20.02.04 - 12:12
(1) человек явно в шоке!!! грамматику и пунктуацию не соблюдает - такое возможно только при сильном удивлениии... :)
   Юра_Агро
3 - 20.02.04 - 12:20
Согласен. Почему при присоединении секции по второму запросу, секция выстраивается в ряд?
 
Пока Запрос.Группировка(1)=Цикл
Если Запрос.ТипСотрудника=1 Тогда
Таб.ВывестиСекцию("Секция_1|Секция_2");
Таб.ПрисоединитьСекцию("Секция_1|Секция_3");
КонецЕсли;
КонецЦикла;
Пока Запрос1.Группировка(1)=Цикл
Таб.ПрисоединитьСекцию("Секция_1|Секция_4");
КонецЦикла;
   SnarkHunter
 
4 - 20.02.04 - 12:22
Потому что ты так написАл...
   GrayT
 
5 - 20.02.04 - 14:20
Судя по вопросу тебе не с таблицами надо играться, а с самими запросами
   GrayT
 
6 - 20.02.04 - 14:34
Запрос1 - Выбрать всех сотрудников из документов и сгруппировать по сотрудникам. Полученных сотрудников запихнуть в список значений
Запрос2 - Выбрать сотрудников из справочников исключая тех кто уже выбран в списке из первого запроса.
Условие(не (Сотрудник в сзВыбранныеПоДокумента))
Полученный список и будет те, кто не попал в документы
   Юра_Агро
7 - 20.02.04 - 14:37
А может быть ошибкой Групптровка в запросе?
Для 1 запроса по справочнику - Наименование, а для 2 запроса по документу - ДатаДок.
   Юра_Агро
8 - 20.02.04 - 14:40
Спасибо GrayT! Я кажется понял откуда нужно копать.
   GrayT
 
9 - 20.02.04 - 14:42
(7) На будущее. Спрашиваешь про запросы - запросы в студию :))
   Львенок
 
11 - 20.02.04 - 20:51
Человек меня прямо вдохновил? Я вот уж думаю не сделать ли мне левый ник и не начать ли задавать вопросы в таком духе... А что. Прикольно?!
___
Искренне Ваш, Львенок?
   GrayT
 
12 - 20.02.04 - 22:56
(11) Ты о чем?
   Юра_Агро
13 - 21.02.04 - 12:18
Ничего прикольного!!! Я действительно первый раз на Вашем форуме. Прошу извенить за некоректно поставленные вопросы.
   GrayT
 
14 - 21.02.04 - 12:24
(13)Все нормально. Но правильно поставленнный вопрос - это половина ответа.
"Ну ты это, заходи если что" (Жил был пес)  ;)
   Wow__cooL
15 - 21.02.04 - 13:53
(12) обрати внимание на его знаки препинания...
они о многом говорят...
   SnarkHunter
 
16 - 21.02.04 - 16:36
(13)Если будешь писАть "извенить" и "некоректно", то я тебя достану... :-))


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует