Вход | Регистрация


1С:Предприятие ::

Метки: 

Про половую дискриминацию.

Я
   uchenik
 
22.11.04 - 23:57
Нужен отчет о зарплате, с выделением женщин. Приведите пример запроса плиз, а то лень искать. Знаю что через пол основного элемента объекта, а как?
 
 
   miki
 
1 - 23.11.04 - 00:21
(0) Вот тебе про зарплату:
    МЖ=СоздатьОбъект("ЖурналРасчетов.Зарплата");
    Если ВыбСотр.Выбран()=0 Тогда
        Если МЖ.ВыбратьПериод(ДатаНач)=0 Тогда
            Предупреждение("За выбранный период нет записей!");
            Возврат;
        КонецЕсли;
    Иначе
        Если МЖ.ВыбратьПериодПоОбъекту(ВыбСотр,ДатаНач)=0 Тогда
            Предупреждение("За выбранный период нет записей!");
            Возврат;
        КонецЕсли;
    КонецЕсли;    
    
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ПовторятьПриПечатиСтроки(5,6);
    Таб.ВывестиСекцию("Шапка");
    Нстр=0;
    Пока МЖ.ПолучитьЗапись()=1 Цикл
            Нстр=Нстр+1;
            Таб.ВывестиСекцию("Строка");
    КонецЦикла;    
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Печать журнала","");

А вот тут есть про женщин:
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаРеестра по ДатаРеестра;
    |Сотрудник = Справочник.Сотрудники.ТекущийЭлемент;
    |СотрПол = Справочник.Сотрудники.Пол;
    |СотрСостояние = Справочник.Сотрудники.СостояниеФизлица;
    |СотрПодразделение = Справочник.Сотрудники.Подразделение;
    |Группировка СотрСостояние;
    |Группировка СотрПол;
    |Группировка СотрПодразделение без групп;
    |Группировка Сотрудник Упорядочить по Сотрудник.Наименование без групп;
    |Условие(Сотрудник.ПометкаУдаления()=0);
    |Условие(СотрПодразделение в Подразделение);
    |//}}ЗАПРОС
   miki
 
2 - 23.11.04 - 00:27
(0)Вот тебе еще кусок про женщин:

Перем СпрСоттрЖ;
//***************

....
        Сотрудник = СпрСотрудники.ТекущийЭлемент();
        Если Сотрудник.ОсновнойЭлемент<>Сотрудник Тогда
            Продолжить
        КонецЕсли;
        
        Если Сотрудник.Пол<>СпрСоттрЖ Тогда
            Продолжить
        КонецЕсли;
.....

//*****************************

СПППП=СоздатьОбъект("Справочник.ОКИН");
СПППП.НайтиПоНаименованию("Женский");
Если СПППП.Выбран()>0 тогда
    СпрСоттрЖ = СПППП.ТекущийЭлемент() 
Иначе
    Предупреждение("В справочнике ОКИН не задан женский пол");
    СпрСоттрЖ=0;
КонецЕсли;
   Fеникс
 
3 - 23.11.04 - 00:34
Задумал как-то Бог:
"Создам-ка я 74 пола, а скажу, что есть только 2!"
(С) Анекдот
   uchenik
 
4 - 23.11.04 - 00:51
(1) Немного не то, но все равно спасибо. Вообще то нужно вывести расчеты сотрудникам за период, с отдельной колонкой "В т.ч. жен.".
(2) А где смеяться?
   miki
 
5 - 23.11.04 - 00:58
(4) Насчет (2) не понял, буду.
   uchenik
 
6 - 23.11.04 - 01:01
В (4)-"(3) А где смеяться?". Очепяточка вышла, сильную пятку сделал.
   Fеникс
 
7 - 23.11.04 - 01:03
(6) Как обычно, после слова "лопата".
   miki
 
8 - 23.11.04 - 01:04
То что бухи просили как-то.
Первый кусок - это распечатка журнала зарплаты.
Второй - из реестра сотрудников.
Третий - из переделанного среднесписочной численности с выделением женщин.
   miki
 
9 - 23.11.04 - 01:07
(6) см. справочник ОКИН, наверное.
   Венеролог
10 - 23.11.04 - 01:09
С выделениями-это в КВД!
 
 
   uchenik
 
11 - 23.11.04 - 01:19
(7) Во прет! Лопата! Ха-ха-ха.
(8) Не поделишся?
   uchenik
 
12 - 23.11.04 - 01:21
(10) Откуда медицина?
   Венеролог
13 - 23.11.04 - 01:23
Угадай с 3-х раз!
   uchenik
 
14 - 23.11.04 - 01:35
(13) А по теме есть что?
   miki
 
15 - 23.11.04 - 01:45
(11) Во что? В смысле, куда тебе?
   uchenik
 
16 - 23.11.04 - 01:48
(15) Давай сюда.
   miki
 
17 - 23.11.04 - 01:58
Лови. Там еще разное, что по зарпллате просили. Не пинать. Расчет почти совсем не знаю. Пытался несколько раз погрузится, Но "столько я не выпью". Переделанный среднесписочный только и отличается, что дважды вызывается родная процедурка, один раз с условием как в (2). Это я к том, что сам за то что "работает-не трогай" в чем не разбираешься.
   uchenik
 
18 - 23.11.04 - 02:13
(17) А ты ее не в конверте отправил? Ха-ха-ха!
   miki
 
19 - 23.11.04 - 02:19
(18)День у меня сегодня не тот чтобы ха-ха. смотри в uchenik7772004@mail.ru
   uchenik
 
20 - 23.11.04 - 02:23
(19)Понял.Получил.Разбираюсь.Спасибо.
PS. Уже отпустило.
   Пролд
 
21 - 23.11.04 - 03:09
Тема должна суть сообщения.
Должно звучать так "Про половую детерминацию"

П.С. Садитесь, Вам двойка.
   uchenik
 
22 - 23.11.04 - 12:23
(21) Умные все стали, плюнуть некуда.(с)
А если серьезно, как запросом выдернуть выплаты женщинам и мужчинам по виду расчета отдельно?
   miki
 
23 - 23.11.04 - 12:25
(22) Если еще отдельно по  видам расчета - добавь группировку по видам расчета в запрос.
   Пролд
 
24 - 23.11.04 - 12:30
(22) Беда с запросами к ЖР в 7-ке.
Реквизит в ЖР надоть добавлять.
Или в ТЗ запрос выгружать, колонку "sex" программно заполнять.

Или крайний (на самый распоследний случай) вариант - в типовой ЗиК запустить обработку универсальный отчет.



Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует