Вход | Регистрация


О жизни... ::

Метки: Встроенный язык

OFF: Вот писал сам лично. В чем обшибка???

Я
   bazvan
 
 
17.11.04 - 22:43
Процедура РасчетатьНаценку()
   БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
   ВыбратьСтроки();
   Пока ПолучитьСтроку() = 1 Цикл
       ОстКолНаСкладе = 0;
       ОстКол = 0;
       ОстСум = 0;
       БухИт.Рассчитать(,ДатаДок,Материал.СубСчет10,,,);
       ОстСум = БухИт.СКД(Материал.СубСчет10,"С",,Материал); // Суммовой остаток, потребуется для расчета средней цены
       ОстКол = БухИт.СКД(Материал.СубСчет10,"К",,Материал);
       СредЦена = Окр(ОстСум/ОстКол,2,1);
       Цена = СредЦена + Окр(СредЦена*ПрНаценки/100,2,1);
       
       Пересчет("Цена");
   КонецЦикла;    
КонецПроцедуры
 
  Рекламное место пустует
   bazvan
 
 
1 - 17.11.04 - 22:48
Вот процедура пересчета
Процедура Пересчет(ИмяРеквизита="")
       
   Если ИмяРеквизита = "" Тогда // вызов из формулы колонки табличной части
       ИмяРеквизита = Форма.ТекущаяКолонка();
   КонецЕсли;

   Если ВидОтпуска <> 1 Тогда
       Если Материал.Выбран() = 1 Тогда
           Если (ИмяРеквизита = "Материал") Тогда
               Цена = глСуммаДокумента(Контекст, Материал);
               Если КоличествоНадлежитОтпустить <> 0 Тогда
                   Пересчет("Цена");
               КонецЕсли;
               
           ИначеЕсли (ИмяРеквизита = "КоличествоНадлежитОтпустить") или (ИмяРеквизита = "КоличествоОтпущено")Тогда
               Если ИмяРеквизита = "КоличествоНадлежитОтпустить" Тогда
                   КоличествоОтпущено = КоличествоНадлежитОтпустить;
                   Количество = КоличествоНадлежитОтпустить;
               Иначе
                   Количество = КоличествоОтпущено;
               КонецЕсли;
               
               Сумма = Цена*Количество;
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               СуммаНац = Окр(СредЦена*КоличествоОтпущено*ПрНаценки/100,2,1);
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               РассчитатьНалоги();
               
           ИначеЕсли (ИмяРеквизита = "Цена") Тогда
               Сумма = Цена*КоличествоОтпущено;
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               СуммаНац = Окр(СредЦена*КоличествоОтпущено*ПрНаценки/100,2,1);
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               РассчитатьНалоги();
           ИначеЕсли (ИмяРеквизита = "Сумма") Тогда
               РассчитатьНалоги();
               Цена = ?(КоличествоОтпущено = 0, Сумма, Сумма/КоличествоОтпущено);
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               СуммаНац = Окр(СредЦена*КоличествоОтпущено*ПрНаценки/100,2,1);
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
           ИначеЕсли (ИмяРеквизита = "НДС") или (ИмяРеквизита = "НП") Тогда
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               СуммаНац = Окр(СредЦена*КоличествоОтпущено*ПрНаценки/100,2,1);
               //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
               Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
           КонецЕсли;
       КонецЕсли;
   КонецЕсли;
КонецПроцедуры // Пересчет()
   Волшебник
 
2 - 17.11.04 - 22:51
Ты себя раскрыл:
Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56
   Marni
 
3 - 17.11.04 - 22:53
Да, bavz, неосторожно ты как-то...
   GrayT
 
4 - 17.11.04 - 22:54
(3)bavz - это уменьшительно ласкательное?
   Marni
 
5 - 17.11.04 - 22:55
(4) ага... завидно?
   GrayT
 
6 - 17.11.04 - 22:57
Не-а. Так язык сломаешь, да и на слух - звук удара по голове (не моей) :)
   Marni
 
7 - 17.11.04 - 22:58
(6) ему все равно пох, а мне так приятнее :))
   GrayT
 
8 - 17.11.04 - 22:59
:)
   Marni
 
9 - 17.11.04 - 23:05
Ниче смешного, между прочим... прийдет bavz, увидит, что ошибку мы так и не нашли... и все... тогда точно пох всем будет :)
   Просто BorisG
10 - 17.11.04 - 23:06
(2) А ты этого ранее не знал?
 
  Рекламное место пустует
   Marni
 
11 - 17.11.04 - 23:13
Просто BorisG, а ты типа знал?! :)
   Просто BorisG
12 - 17.11.04 - 23:26
(11) Да мы Александром как бы и лично знакомы ;-)))
   Marni
 
13 - 17.11.04 - 23:30
(12) Да ну! Брось ты! Это были глюки! Я тя уверяю!

ЗЫ: с тобой можно как-то кроме форума связаться?
   Asmody
 
14 - 17.11.04 - 23:55
мдя...
нах это в цикле?
  БухИт.Рассчитать(,ДатаДок,Материал.СубСчет10,,,);
...
тут может вылезти div by zero:
  СредЦена = Окр(ОстСум/ОстКол,2,1);
...
это так задумано, цены во всех строках снести?
           Если (ИмяРеквизита = "Материал") Тогда
              Цена = глСуммаДокумента(Контекст, Материал);
              Если КоличествоНадлежитОтпустить <> 0 Тогда
                  Пересчет("Цена");
              КонецЕсли;
...
   Asmody
 
15 - 17.11.04 - 23:57
(14+)
 //Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
- это скрытая контекстная реклама себя на форуме? >;))
   Дмитрий
 
16 - 18.11.04 - 00:00
(0)
БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
БухИт.Рассчитать(,ДатаДок);
  ВыбратьСтроки();
  Пока ПолучитьСтроку() = 1 Цикл
      ОстКолНаСкладе = 0;
      ОстСум = БухИт.СКД(Материал.СубСчет10,"С",,Материал); // Надо смотреть, чтоб Материал.Субсчет10 был определен, тип его был либо счет либо строка (должен тогда содержать код счета), и первое субконто на данном счете в конфигураторе было того же типа, что и Материал.
      ОстКол = БухИт.СКД(Материал.СубСчет10,"К",,Материал);
      СредЦена = Окр(ОстСум/ОстКол,2,1);
      Цена = СредЦена + Окр(СредЦена*ПрНаценки/100,2,1);
      Пересчет("Цена");
  КонецЦикла;    


ИЛИ

  ВыбратьСтроки();
  Пока ПолучитьСтроку() = 1 Цикл
      ОстКолНаСкладе = 0;
      БухИт = СоздатьОбъект("БухгалтерскиеИтоги");
      БухИт.ИспользоватьСубконто(ВидыСубконто.Материалы,Материал,2);
      БухИт.ВыполнитьЗапрос(,ДатаДок,Материал.Субсчет10);
      ОстСум = БухИт.СКД("С"); // // Надо смотреть, чтоб Материал.Субсчет10 был определен, тип его был либо счет либо строка (должен тогда содержать код счета), и первое субконто на данном счете в конфигураторе было того же типа, что и Материал.
      ОстКол = БухИт.СКД("К");
      СредЦена = Окр(ОстСум/ОстКол,2,1);
      Цена = СредЦена + Окр(СредЦена*ПрНаценки/100,2,1);
      Пересчет("Цена");
  КонецЦикла;
   IAm
 
17 - 18.11.04 - 00:28
(2) Он этого никогда и не скрывал.
   Asmody
 
18 - 18.11.04 - 00:35
развод
   Marni
 
19 - 18.11.04 - 00:37
(17) Как? и ты это знал?! :)
(18) АднАзнАчнА!
   IAm
 
20 - 18.11.04 - 00:40
//Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
эту строчку по хрошему надо заменить во всеё конфигурации на
Сообщить("Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56");
   Asmody
 
21 - 18.11.04 - 00:40
точно развод.
bazvan не пишет на 1С...
он до ВС:Бухгалтерии охотник >;))
   Asmody
 
22 - 18.11.04 - 00:42
(20) предложи одномуэсу вставить в типовые. >;))
   wolk
 
23 - 18.11.04 - 01:38
Смотрите как клёво базвик себя разрекламировал. Кинул 2 поста в самом начале и ушёл спать. А ветка сама собой тлеет. А утром он будет читать это всё "и ржать как индюк ...дь плывущий галопом" (с)"Красная плесень".
   bazvan
 
 
24 - 18.11.04 - 11:32
Да ужжж а вот Бекас сразу ошибку нашел
Нет тут профессионалов. Даже волшебник который бдит не нашел ошибку позор
   GrayT
 
25 - 18.11.04 - 11:42
(24)Требуешь продолжения банкета?
   bazvan
 
 
26 - 18.11.04 - 11:44
Ну что разгатку та сказать??
   Dema
 
27 - 18.11.04 - 11:47
да
   bazvan
 
 
28 - 18.11.04 - 11:48
РасчетатьНаценку()
Расчетать пишется с 2 С
Да короче все свами ястно.
Бекас форева
   Dema
 
29 - 18.11.04 - 11:50
//Базванов А.А. ООО "Единый стандарт" г. Рязань (0912) 24-05-56  
Весь мозг забила, понять тяжело че делается, это отвлекающий маневр
   GrayT
 
30 - 18.11.04 - 11:51
И через и тогда уж
   Антон ORIGINAL
 
31 - 18.11.04 - 11:52
А всё-таки тут ошибка в... днк
   bazvan
 
 
32 - 18.11.04 - 11:53
Да нет это просто делалось клиенту за 200 км. Вот и оставил специально координаты что бы если что позванили
   laeg
 
33 - 18.11.04 - 11:57
(28)
Вопрос - вопросу рознь ...
Твоя ошибка в том, что ты не задал вопроса.
 
 
   bazvan
 
 
34 - 18.11.04 - 11:58
Так я на Т1С то же не задавал. Просто попрасили я и вылажил. Бекас сразу сказал что это делал базван только он мог так написать
   Dema
 
35 - 18.11.04 - 11:59
Да нет это просто делалось клиенту за 200 км. Вот и оставил специально координаты что бы если что позванили....
Ага в тексте модуля, чтоб когда в режиме Предприятия работал не забыл....  :-)
   bazvan
 
 
36 - 18.11.04 - 12:08
Для специалиста который бы там сел конфигурить и если что то не понятно спросить
   SnarkHunter
 
37 - 18.11.04 - 12:29
(36)Не только с двумя "с", но и через "и"... :-))
   Микки-Маус
38 - 18.11.04 - 12:30
В генах
   Asmody
 
39 - 18.11.04 - 14:52
гм... если ошибка - это название функции, то какая нах разница?
да я ее хоть ИпанутьсяОбАсфальт() назову, лишь бы работала. Тем более за 200 км. >;))
   bazvan
 
 
40 - 18.11.04 - 14:53
Так то енто понятно:)))
   bazvan
 
 
41 - 18.11.04 - 14:54
Я из за такой ошибки один раз 30 минут не мог понять по чему РасчитатьИтоги() не работает
Оказывается 2 буквы С нуно:)))))))))))
   57г6емпплр
42 - 18.11.04 - 15:03
ахтунг! он нас гипнотизирует!
---
18 постов после очередного бана
   79п8ни7ш
43 - 18.11.04 - 15:09
42+
Инженер знаний воспользовался бы ВыполнитьЗапрос
   Asmody
 
44 - 18.11.04 - 15:12
(41) используй телепат.длл >;))



Список тем форума
Рекламное место пустует   Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует