Вход | Регистрация

1С:Предприятие ::

Метки: 

Для от и До

Я
   skunk
 
11.02.04 - 12:48
Раньше никогда не надо было, а тут решил так крутануть цикл по аннолгии с васиком

for x=1 to 100 step 2


и оказалась step нету, или я чего незнаю
 
 
   Шершень
 
1 - 11.02.04 - 13:16
В Одинэсике, что ли? - Да, нету. И в обратку (downto, как в Паскале), тоже нельзя.
   Волшебник
 
2 - 11.02.04 - 20:36
Цикл "для" (for) является частным случаем цикла "Пока" (while)
   Z1
3 - 11.02.04 - 21:23
Для И1 = 1 по 50 Цикл
    И2 = И1*2;
...
КонецЦикла

можно через goto
   GrayT
 
4 - 11.02.04 - 21:36
Умно, особенно при первом шаге
   Львенок
 
5 - 11.02.04 - 22:14
Еще варианты будут? 8) Ну там например:
Для Х=1 По 50 Цикл
   Если X/2=Цел(Х/2) Тогда Продолжить; КонецЕсли;
   ...
КонецЦикла;

Извращаться можно бесконечно.
___
Искренне Ваш, Львенок.
   GrayT
 
6 - 11.02.04 - 22:18
Жаль сдвига нет
   Львенок
 
7 - 11.02.04 - 22:46
(6) Да. Битовых операций вообще сильно нехватает. 8)
___
Искренне Ваш, Львенок.


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует