Вход | Регистрация


Информационные технологии ::

Метки:Запросы и построители

Запрос не получается

Я
   Таня
 
18.01.04 - 21:52
У меня почему-то запрос не хочет выбирать информацию из регистра.

оборотный регистр ПродажиТоваров:
Товар
Поставщик
Отдел
Количество
Сумма

Туда записываются обороты с документа ТоварныйЧек:
ВыбратьСтроки();
   Пока ПолучитьСтроку() = 1 Цикл
Регистр.ПродажиТоваров.Движение(Товар,Товар.Поставщик,Отдел,Количество,Стоимость);
   КонецЦикла;

В обработке я пишу:
Процедура Выполнить()
ДатаПрихода=Дата(НомерГода,ВыбМесяц.ТекущаяСтрока(),01);
ДатаКонца =  КонМесяца(ДатаПрихода);
ДатаНачала = ДатаПрихода;  
   
УстановитьТАна(ДатаКонца);
РассчитатьРегистрыНа(ДатаКонца,);          

ПрихНакл=СоздатьОбъект("Документ.ПриходнаяНакладная");
Перемещение = СоздатьОбъект("Документ.Перемещение");
ТовЧек = СоздатьОбъект("Документ.ТоварныйЧек");    
   
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Выполнить)
   |Период с ДатаНачала по ДатаКонца;
   |Товар = Регистр.ПродажиТоваров.Товар;
   |Поставщик = Регистр.ПродажиТоваров.Поставщик;
   |Группировка Поставщик;
   |Группировка Товар;
   |"//}}ЗАПРОС
   ;
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
       Возврат;
   КонецЕсли;
   
   Пока Запрос.Группировка("Поставщик") = 1 Цикл
       ПрихНакл.Новый();
       ПрихНакл.ДатаДок = ДатаПрихода;
       ПрихНакл.АвтоВремяНачалоДня();
       ПрихНакл.Поставщик = Запрос.Поставщик;
       Пока Запрос.Группировка(2) = 1 Цикл
           ПрихНакл.НоваяСтрока();
           ПрихНакл.Товар = Запрос.Товар;
ПрихНакл.Количество=Регистр.ПродажиТоваров.Итог(Запрос.Товар,,"Количество");
ПрихНакл.Стоимость=Регистр.ПродажиТоваров.Итог(Запрос.Товар,,"Сумма");
ПрихНакл.ЦенаЗакупки=ПрихНакл.Сумма/ПрихНакл.Количество;
       КонецЦикла;
       ПрихНакл.Записать();
       ПрихНакл.Провести();
   КонецЦикла;
КонецПроцедуры

в документе ПриходнаяНакладная я пишу:
Процедура ОбработкаПроведения()
   Спр = СоздатьОбъект("Справочник.Отделы");
Отдел = Спр.НайтиПоНаименованию("Склад магазина",1);
   ВыбратьСтроки();
   Пока ПолучитьСтроку() = 1 Цикл
Регистр.ТоварныйЗапас.ДвижениеПриход(Товар,Отдел,Количество,Стоимость);
   КонецЦикла;
КонецПроцедуры

Ни на чё не ругается, но и Приходник не записывает
Товарный Чек все формирует, то есть регистр не пустой

Отладчиком проверяла обработку, он в месте
   Пока Запрос.Группировка("Поставщик") = 1 Цикл
выдает Запрос.Группировка("Поставщик") = 0

Помогите мне кто-нибудь. Пожалуйста.
 
  Рекламное место пустует



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует