Вход | Регистрация

1С:Предприятие ::

Метки:

Подскажите немножко пожайлуста, очень надо (Таблица значений)

Я
   Lucky
 
16.01.04 - 16:06
1С 7.7
есть таблица значений Например(имя, статус(перечисление)).Есть несколько кнопок (занести отказ), (принять)
как сделать что б при нажатии   кнопки  отказа происходило следующее (при  просмотре всех строк и нахождении статуса отказа) выполнялтсь какие-то действия.
 
  Рекламное место пустует
   345
1 - 16.01.04 - 16:28
Плиз, еще раз ... медленнее, и главное, подробнее ... Что надо ... а то вкурить не могу ....
   Garry74
 
2 - 16.01.04 - 16:30
Функция ОбрКнопку()
стр="";
Если ТабЗнач.НайтиЗначение(отказ,стр,"статус")=1 Тогда
   Че-тоделаем();
КонецЕсли
Возврат "";
КонецФункции;
В кнопке в закладке "дополнительно" ф формуле ставишь ОбрКнопка()
   Львенок
 
3 - 16.01.04 - 16:47
(2) Угу. Находит только первое значение "отказ", и что-то делает [с ним]. А со всеми остальнми отказами?
___
Искренне Ваш, Львенок.
   Garry74
 
4 - 16.01.04 - 16:52
ТабЗнач.ВыбратьСтроки();
Пока ТабЗанч.ПолучитьСтроку()=1 Цикл
если ТабЗнач.Статус="Отказ" Тогда
Че=тоделаем();
КонецЕсли;
КонецЦикла;
   Lucky
 
7 - 16.01.04 - 17:34
Спасибо, попробую.
Встречный вопрос -> а если это что то делаю будет так:
заностятся данные об отказе в другую таблицу значений, но как сделать чтоб эти данные не повторялись?ю т.е. если я уже раз занес эту строку (имя дата статус)чтоб она больше не вводилась.
Сильно не пинайте, у меня проблеммы не только с 1С но и с логикой... тяжелый день ;-(((


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует