Вход | Регистрация

1С:Предприятие ::

Метки:

Подскажите, кто-нибудь, как мне отсортировать записи в отчете КнигаПродаж п

Я
   Valley Silence
16.01.04 - 12:09
Граждане программисты !

Подскажите, кто-нибудь, как мне отсортировать записи в отчете КнигаПродаж по полю НомерДок ???
Дело в том, что в формировании этого отчета задействованы 2 документа, СчетФактура и СчетФактура1(Водится на основании документа "расчет").

Задача в том, чтобы Книга Продаж формировалась с сортировкой по полю Номер документа СчетаФактуры.

Вот моё формирование отчета:

//*******************************************

// Процедура генерации запроса Выполнить.
//

Процедура Выполнить()
    Перем Запрос, ТекстЗапроса, Таб;
   //Создание объекта типа Запрос

    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Выполнить)

    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Покупатель = Документ.СчетФактура.Покупатель;
    |Покупатель1 = Документ.СчетФактура1.Покупатель;
    |Сумма = Документ.СчетФактура.Сумма, Документ.СчетФактура1.Сумма;
    |НДС = Документ.СчетФактура.НДС, Документ.СчетФактура1.НДС;
    |Всего = Документ.СчетФактура.Всего, Документ.СчетФактура1.Всего;
    |ДатаДок = Документ.СчетФактура.ДатаДок, Документ.СчетФактура1.ДатаДок;
    |НомерДок = Документ.СчетФактура.НомерДок, Документ.СчетФактура1.НомерДок;
    |Функция СуммаСумма = Сумма(Сумма);
    |Функция НДССумма = Сумма(НДС);
    |Функция ВсегоСумма = Сумма(Всего);
    |Группировка Покупатель упорядочить по Покупатель.Наименование, Покупатель.ИНН;
    |Группировка Покупатель1 упорядочить по Покупатель1.Наименование, Покупатель1.ИНН;
    |Группировка Сумма упорядочить по СуммаСумма;
    |Группировка НДС упорядочить по НДССумма;
    |Группировка Всего упорядочить по ВсегоСумма;
    |//}}ЗАПРОС

    ;
   // Если ошибка в запросе, то выход из процедуры

    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса

    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Выполнить");
   // Заполнение полей "Заголовок"

    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
       // Заполнение полей Покупатель

        Таб.ВывестиСекцию("Покупатель");
        Пока Запрос.Группировка(2) = 1 Цикл
           // Заполнение полей Покупатель1

            Таб.ВывестиСекцию("Покупатель1");
            Пока Запрос.Группировка(3) = 1 Цикл
               // Заполнение полей Сумма

                Пока Запрос.Группировка(4) = 1 Цикл
                   // Заполнение полей НДС

                    Пока Запрос.Группировка(5) = 1 Цикл
                       // Заполнение полей Всего

                    КонецЦикла;
                КонецЦикла;
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;
   // Заполнение полей "Итого"

    Таб.ВывестиСекцию("Итого");
   // Вывод заполненной формы

    Таб.ТолькоПросмотр(1);
    Таб.Показать("Выполнить", "");
КонецПроцедуры
 
  Рекламное место пустует
   345
1 - 16.01.04 - 13:29
Запрос ---> тз ---> Сортировка тз ---> Печать
   ally
 
2 - 16.01.04 - 13:59
(1) Как порой не хватает именно таких схем :-)


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует