Вход | Регистрация

1С:Предприятие ::

Метки:

Отправка почты черех v7plus

Я
   Чебурашка
 
13.01.04 - 10:22
Добрый день, господа!
Кто-нибудь использовал v7plus для отправки почты, подскажите, пожалуйста. Пишу:
Процедура Сформировать() 
    Если ЗагрузитьВнешнююКомпоненту(КаталогИБ() + "v7plus.dll") <> 1 Тогда
        Если ЗагрузитьВнешнююКомпоненту(КаталогПрограммы() + "v7plus.dll") <> 1 Тогда
            Предупреждение("Компонента v7plus.dll не найдена!");
        КонецЕсли;
    КонецЕсли;
    
    почта=СоздатьОбъект("AddIn.V7Mail");
    почта.Подключиться();
    почта.НовоеСообщение();
    почта.ДобавитьАдрес(СокрЛП(адрес));
    file="F:\1\test\1.txt";
    почта.ДобавитьФайл(file);
    почта.Заголовок= " ";
    почта.send();
    почта.Отключиться();  

КонецПроцедуры

Соединяется, а потом все отключается и в итоге ошибка:
   
//Почта.send();
//{F:\REPORT1C\почта.ERT(26)}:поле агрегатного
объекта не обнаружено (send)

Что делать?
 
 
   Чебурашка
 
1 - 13.01.04 - 14:31
Ура заработало!!!
Вопрос отменяется.


Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует