Вход | Регистрация

1С:Предприятие ::

Метки:

Справочники. Опять

Я
   kos
 
12.01.04 - 20:35
Можно ли узнать сколько фирм в ТиС? Я написал типа:
Фирмы=СоздатьОбъект("Справочник.Фирмы");
 
 СчетчикЦикла = 0;
 Для СчетчикЦикла = 1 По Фирмы....????  Цикл  
 
     
 КонецЦикла;
 
 
   klon
 
1 - 12.01.04 - 21:06
Фирмы.ВыбратьЭлементы();
Пока Фирмы.ПолучиьЭлемент()=1 Цикл
    .......
КонецЦикла;
   kos
 
2 - 12.01.04 - 21:32
Ой народ, пока вас дождешься, я уже успел сбегать на Т1С  и решил все свои проблемки.
___
:)
   345
3 - 12.01.04 - 21:53
А вот и неясно

в (1) еще одной строки не достает

Фирмы.ВыбратьЭлементы(); 
Сч = 0;
Пока Фирмы.ПолучитьЭлемент()=1 Цикл 
если Фирмы.ЭтоГруппа()=1 тогда продолжить; конецесли;
если Фирмы.ПометкаУдаления()=1 тогда продолжить; Конецесли;
Сч=Сч+1;
КонецЦикла; 

хотя справочник фирмы обычно одноуровневый ....
   345
4 - 12.01.04 - 22:05
Да там все ответили ....
   kos
 
5 - 12.01.04 - 22:18
pit, а ты что здесь делаешь? Здесь форум не шибко активный, так что....


Список тем форума
Рекламное место пустует  
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует