Вход | Регистрация

1С:Предприятие ::

Метки:Запросы и построители

Ворос по запросу ...

Я
   Danila
 
25.08.04 - 15:29
Вот код

КонечнаяДата = ТекущаяДата();
НачальнаяДата = НачНедели(КонечнаяДата);
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = 
"//{{ЗАПРОС(Запрос)

|Период с НачальнаяДата по КонечнаяДата;
|ОбрабатыватьДокументы все;
|Наим =  Документ.ЗаявкаПокупателя.Номенклатура;
|Колво = Документ.ЗаявкаПокупателя.Количество; 
|Автор = Документ.ЗаявкаПокупателя.Автор;
|НомерД = Документ.ЗаявкаПокупателя.НомерДок;
|Оплата = Документ.ЗаявкаПокупателя.СчетОплачен;  
|Группировка НомерД;
|Группировка Наим;
|//}}ЗАПРОС

;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
    
Пока (Запрос.Группировка("НомерД") = 1) Цикл 
 Сообщить("========");
 Сообщить("Номер"+Запрос.НомерД);         
 Сообщить("Автор"+Запрос.Автор);
 Пока (Запрос.Группировка("Наим") = 1) Цикл 
  Сообщить("Наименование"+Запрос.Наим);
  КонецЦикла
КонецЦикла
   
Результат отработки программы такой:
========
НомерА00426-С  
АвторKonstantin
НаименованиеЗадвижки
НаименованиеЗадвижки разные
НаименованиеЗадвижка 30с915нжБ ДУ200 (г-ф)
НаименованиеЗадвижка 30с964нжБ ДУ200 (н-ф)
========
НомерА00427-С  
АвторKonstantin
НаименованиеЗадвижки
НаименованиеЗадвижки разные
НаименованиеЗадвижка 30с41нж  ХЛ ДУ50 РУ16
НаименованиеЗадвижка 30с64нж ДУ100 (н-ф)
НаименованиеЗадвижка 30с915нжБ ДУ300 (н-ф)
НаименованиеЗадвижка 30с964нжБ ДУ200 (н-ф)

Вопрос. Как видно из примера происходит вывод групп справочника,
а они не нужны, нужно например (см. последний счет) выводить "Задвижка 30с964нжБ ДУ200 (н-ф)", а "Задвижки" и "Задвижки разные" не надо. Подскажите как это исправить. Спасибо!
 
  Рекламное место пустует
   Guk
 
1 - 25.08.04 - 15:30
(0)|Группировка НомерД без групп;
   Guk
 
2 - 25.08.04 - 15:30
(0)|Группировка Наим без групп;
   Guk
 
3 - 25.08.04 - 15:31
В (1) опечатка...
   Danila
 
4 - 25.08.04 - 15:32
Спасибо!


Список тем форума
Рекламное место пустует   Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит Тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует