Вход | Регистрация

1С:Предприятие ::

Метки:

Бухгалтерские итоги

Я
   AvAlex
25.08.04 - 13:22
Доброго всем дня. Есть вопросик по объекту \"БухгалтерскиеИтоги\": возможно ли получить остатки (кол-во/сумма) по счету в разрезе субконто и докумнетов прихода.

С уважением, Алексей.
 
 
   Diter
 
1 - 25.08.04 - 13:23
Конечно можно
   Рарог
 
2 - 25.08.04 - 13:23
Возможно.
Надо в Запросе указать Период "Операция"
А потом...
БИ.ВыбратьПериоды()...
   AvAlex
3 - 25.08.04 - 13:25
(1) Если не затруднит, можно по подробней (код или алгоритм).
   Рарог
 
4 - 25.08.04 - 13:25
БИ.ВыполнитьЗапрос(Дата,Дата,Счет,,,,"Операция",)
   Diter
 
4 - 25.08.04 - 13:25
БИ.Операция.Документ
   Diter
 
6 - 25.08.04 - 13:28
БИ.ВыполнитьЗапрос(ДатаНачала,ДатаКонца,Счет,,,,2);
   // только отгрузка и получение товаров и услуг

    БИ.ВыбратьСчета();
    Пока БИ.ПолучитьСчет()<>0 Цикл
        БИ.ВыбратьПериоды();
        Пока БИ.ПолучитьПериод()<>0 Цикл
            БИ.ВыбратьСубконто();
            Пока БИ.ПолучитьСубконто()<>0 Цикл      
                БИ.ВыбратьСубконто(2);
                Пока БИ.ПолучитьСубконто(2)<>0 Цикл
                    Если БИ.ДО(1)<>0 Тогда
                        Если (БИ.Операция.Дебет.Счет=СчетПоКоду("6811")) и (БИ.Операция.Кредит.Счет=СчетПоКоду("361")) Тогда
                        ИначеЕсли (БИ.Операция.Дебет.Счет=СчетПоКоду("631")) и (БИ.Операция.Кредит.Счет=СчетПоКоду("3711")) Тогда
                        Иначе 
                            Если (БИ.Операция.Дебет.Счет=СчетПоКоду("3711")) и (БИ.Операция.Кредит.Счет=СчетПоКоду("631")) Тогда// возвраты

                                ТабЗначР.НоваяСтрока();
                                ТабЗначР.Счет=БИ.Счет; 
                                ТабЗначР.Клиент=БИ.Субконто(1);
                                ТабЗначР.Основание=БИ.Субконто(2); 
                                ТабЗначР.Документ=БИ.Операция.Документ;
                                ТабЗначР.ДатаДОп=БИ.Операция.Документ.ДатаДок;
                                ТабЗначР.ДатаДОс=БИ.Субконто(2).ДатаДок;
                                ТабЗначР.СуммаД=(-1)*БИ.КО(1);
                                ТабЗначР.СуммаК=(-1)*БИ.ДО(1);
                            Иначе
                                ТабЗначПр.НоваяСтрока();
                                ТабЗначПр.Счет=БИ.Счет; 
                                ТабЗначПр.Клиент=БИ.Субконто(1);
                                ТабЗначПр.Основание=БИ.Субконто(2); 
                                ТабЗначПр.Документ=БИ.Операция.Документ;
                                ТабЗначПр.ДатаДОп=БИ.Операция.Документ.ДатаДок;
                                ТабЗначПр.ДатаДОс=БИ.Субконто(2).ДатаДок;
                                ТабЗначПр.СуммаД=БИ.ДО(1);
                                ТабЗначПр.СуммаК=БИ.КО(1); 
                            КонецЕсли;
                        КонецЕсли;
                    КонецЕсли;
                КонецЦикла;          
            КонецЦикла;    
        КонецЦикла;
    КонецЦикла;
   AvAlex
7 - 25.08.04 - 14:06
При выполнении команды БИ.ВыполнитьЗапрос(Дата,Дата,Счет,,,,"Операция",) в выборку попадают все движения. Возможно я не совсем корректно поставил вопрос, постараюсь еще раз. Счет 10.1, субконто1 материалы, субконто2 места хранения. По счету проходят приход и расход материалов. Требуется получить !остатки! по счету 10.1 на дату в разрезе материалов, мест хранения и приходных документов.
   Diter
 
8 - 25.08.04 - 14:11
Ну так и отбирай по приходным документам
Если БИ.Операция.Документ.Вид()="ПриходнаяНакладная" Тогда
...
КонецЕсли;


Список тем форума
Рекламное место пустует   Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует