Вход | Регистрация

1С:Предприятие ::

Метки:

Проблема

↓ [Волшебник, 24.08.04 - 08:12]
Я
   Korchagin
 
24.08.04 - 02:32
Как в расходную накладную добавлять не по одному єкземпляру номенклатуры а сразу всех из выбранной группы
Реальный ответ ожидает приз!!
 
  Рекламное место пустует
   тип топ1
1 - 24.08.04 - 05:15
повесь на форму реквизит выбора группы
Процедура Внеси()
    Тов=СоздатьОбъект(\"Справочник.Товары\");
    Если ВыбТовар.ЭтоГруппа()=1 Тогда
        Тов.ВключатьПодчиненные(1);
        Тов.ИспользоватьРодителя(ВыбТовар);
        Тов.ВыбратьЭлементы();
        Пока Тов.ПолучитьЭлемент()>0 Цикл
            Если Тов.ПометкаУдаления()=1 Тогда
                Продолжить;
            КонецЕсли;
            Если Тов.ЭтоГруппа()=1 Тогда
                Продолжить;
            Иначе
                НоваяСтрока();
                Товар=Тов.ТекущийЭлемент();
                Розн_Цена=Товар.Розн_Цена.Получить(ДатаДок);
               //и т.д.

            КонецЕсли;
        КонецЦикла;
    КонецЕсли; 
КонецПроцедуры
   Волшебник
 
2 - 24.08.04 - 08:12
(0) Тема должна отражать суть сообщения.
   Korchagin
 
3 - 24.08.04 - 17:11
(1) Выдает ошибку Если ВыбТовар.ЭтоГруппа()=1 Тогда
{Документ.Т_РасходнаяНакладная.Форма.Модуль(396)}: Значение не представляет агрегатный объект (ЭтоГруппа)
В чем проблема?
   тип топ
 
4 - 25.08.04 - 05:56
1 Реквизит на форме ВыбТовар=Справочник.Номеклатура ?
2 проверь типЗначенияСтр(ВыбТовар)
3 7.7 или 8.0?
   Korchagin
 
5 - 27.08.04 - 02:17
(4)
3.7.7Комплексная конфа
1.ВыбТовар=ТекущейЭлемент();
выдает ошибку
Функция не обнаружена (ТекущийЭлемент);


Список тем форума
Рекламное место пустует  
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует