Вход | Регистрация

1С:Предприятие ::

Метки:

Не печатается сумма и цена

Я
   Юрий_В
23.08.04 - 14:03
1С бухгалтерия 7.7  Релиз 458
В документе \"Перемещение материалов\" при \"Складском перемещении\" в \"проведенных\" документах не выводится на печать \"Сумма\" и\"Цена\".
В модуле формы явного обращения к этим реквизитам нет.
Это так задумано или я чего-то не знаю?
Подскажите кто знает.
Заранее благодарю.
 
  Рекламное место пустует
   Yaret
 
1 - 23.08.04 - 14:09
Да, именно так сделана накладная по форме М-11. В типовой бухгалтерии при перемещении со склада на склад ведется только количественный учет. Если необходимо видеть цену, можно вначале делать списание на счет 00, провести докумет, посмотреть и распечатать с ценами, а затем исправлять на складское перемещение и перепровести. Для того что бы увидеть сумму придется добавлять строку с итоговой суммой и несколько строк добавить в модуле для подсчета суммы.
   Юрий_В
2 - 23.08.04 - 15:07
Добавил в модуль формы в Функцию ПредставлениеВидаМПЗ() две строки:

Цена1=Материал.Цена;
Сумма=Цена1*КоличествоОтпущено;

Правильно ли я сделал?
   GrayT
 
3 - 23.08.04 - 15:17
Нет. Цена в справочнике дана ориентировочно. Фактический приход может отличаться. Как результат - суммы без количества, краснота.
   Yaret
 
4 - 23.08.04 - 15:34
Ниже кусок модуля, где для подсчета суммы добавляется переменная МС:

Процедура Печать() 
    МС=0;
...........
    Иначе
        НомерПовторяемойСтроки = 15;
        Таб.ВывестиСекцию("Шапка");

        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            Если Материал.Выбран() = 1 Тогда
                Субсчет = ?(Материал.Вид() = "Материалы",Материал.СубСчет10,"43");
                МатЦенность = Материал;
                Код = Материал.Код;
                ЕдиницаИзмерения = Материал.ЕдиницаИзмерения;
                ЕдиницаИзмеренияКод = Материал.ЕдиницаИзмерения.Код;
                МатериалСумма = Сумма;
                МС=МС+МатериалСумма; // подсчет суммы


                МатериалЦенаБезНДС = Сумма / КоличествоОтпущено;
            КонецЕсли;
            Таб.ВывестиСекцию("Строка");
            Состояние("Выведено строк: " + НомерСтроки);
        КонецЦикла;
.....................
КонецПроцедуры// Печать



Дальше в общей таблице М-11 добавляется еще одна строка в секции Подвал, в которой в ячейке столбца Сумма прописывается - МС #Ч015.2., - тип Выражение, больше ничего не надо.
Как получать сумму я говорил в (1).
   GrayT
 
5 - 23.08.04 - 15:44
Ерунда. Особенно 1
   Akv
6 - 23.08.04 - 16:11
GrayT почему ерунда?
Справочно так можно мосмотреть цену.
Правда она особого смысла в конфе бухг не имеет, т. к.
по местам хранения суммовой учет НЕ ВЕДЕТСЯ ВООБЩЕ, только количественный
   Yaret
 
7 - 23.08.04 - 16:14
(5)Обоснуй.
Твои предложения?
   Юрий_В
8 - 24.08.04 - 06:48
(4) Спасибо. Пока ничего не сделал, но возможно - придётся.
   GrayT
 
9 - 24.08.04 - 11:28
Ерунда, потому что в такой справке грошь цена. Причины в Akv сам назвал.
А особенно 1 - тогда уж проще выцепить процедуру расчета средней себестоимости материалов и подставлять эту цену. Про списание на 00, просто молчу


Список тем форума
  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует