Вход | Регистрация

1С:Предприятие ::

Метки:

Открыть документ из ТЗ

Я
   Генс
21.08.04 - 17:11
Здравствуйте. У меня к вам такой вопрос. Я сделал таблицу значений в ней находяться накладные для определеных операций.Вопрос, как мне написать, чтобы при клике на стороку в ТЗ открывалась имено та накладая на которой клик?
 
  Рекламное место пустует
   SnarkHunter
 
1 - 21.08.04 - 17:17
См. ОткрытьФорму()
   romix
 
2 - 22.08.04 - 13:52
В свойствах формы есть поле, куда надо вписать вызов процедуры. Из этой процедуры можно вызвать ОткрытьФорму(тз.ИмяКолонки);
   427
 
3 - 22.08.04 - 14:31
я et.//// Где находится это поле?
   SnarkHunter
 
4 - 22.08.04 - 15:19
Поле... Русское поле... romix твой тонкий колосок...
   Guk
 
5 - 22.08.04 - 15:24
(2) В свойствах формы ни#ера нет. Зачем глумиться над новичками?...
   SnarkHunter
 
6 - 22.08.04 - 15:33
(5) :-))
   Asmody
 
7 - 22.08.04 - 17:24
(0) ну так:
Процедура ПриКликеНаТЗ()
   Если ТЗ.ТекущаяСтрока()>0 Тогда
       ТЗ.ПолучиьСтрокуПоНомеру(ТЗ.ТекущаяСтрока());
       Если ПустоеЗначение(ТЗ.<ИмяКолонкиСДокументами>)=0 Тогда
          //на всякий случай

           Если ТипЗначения(ТЗ.<ИмяКолонкиСДокументами>)=12 Тогда 
               ОткрытьФорму(ТЗ.<ИмяКолонкиСДокументами>);
           КонецЕсли;
       КонецЕсли;
   КонецЕсли;
КонецПроцедуры

в свойствах таблицы на закладке "Дополнительно" в поле "Формула" написать: ПриКликеНаТЗ()
   Asmody
 
8 - 22.08.04 - 17:26
(7)+ только конечно ТЗ.ПолучиТьСтрокуПоНомеру()
   Warlock
 
9 - 22.08.04 - 17:42
(7,8)Нда...
А зачем ТЗ.ПолучиьСтрокуПоНомеру(ТЗ.ТекущаяСтрока()); или ТЗ.ПолучиТьСтрокуПоНомеру() ?!
И зачем проверять тип? Это антиоптимизация?
Если правильно объявить тип колонки, то он не поменяется...
   Asmody
 
10 - 22.08.04 - 17:45
(9) а где написано, как у (0) определяются колонки? я же написал "на всякий случай"
 
  Рекламное место пустует
   Warlock
 
11 - 22.08.04 - 17:47
(10)Давай предложим ему "Попытка..."? Как ты смотришь?
   Asmody
 
12 - 22.08.04 - 17:52
(11) а Попытка быстрее будет? а потом, может там справочник какой-нибудь затесался?
   Guk
 
13 - 22.08.04 - 17:56
(10,11) По-моему (0) вас испугался...
   Warlock
 
14 - 22.08.04 - 17:57
(12)Ессно, что медленнее будет :)) ...но раз не важна оптимизация... зато ошибка уж точно не появится!!! ;)))
   Warlock
 
15 - 22.08.04 - 17:58
(13)Думаешь, не скажет спасибо?
   Guk
 
16 - 22.08.04 - 18:06
(15) адназначна...
   romix
 
17 - 23.08.04 - 17:49
(5) ты прав - не формы, а тз


Список тем форума
Рекламное место пустует  
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует