Вход | Регистрация

1С:Предприятие ::

Метки:справочники

Как програмно перенести существующий элемент справочника в другую группу?

Я
   koshechka
 
20.08.04 - 13:08
Имеется справочник ТМЦ, в нем жуть как много позиций, многие уже не используются. Сворачиваю в ТЗ то, что мне не нужно. Все получается. Потом хочу перенести и оп-ля переносится только одна позиция, или не переносится вааще. Помогите, плиз.
Процедура Перенести()
    СПР1=СоздатьОбъект("Справочник.ТМЦ");
    СПР1.ИспользоватьДату(Дата1);
    СПР1.НайтиПоКоду("999999");
    Род=СПР1.ТекущийЭлемент();
ТЗ.ВыбратьСтроки();
С=СоздатьОбъект("Справочник.ТМЦ"); 
С.ИспользоватьДату(Дата1);
С.ВыбратьЭлементы();
Пока С.ПолучитьЭлемент()=1 Цикл
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Если   С.ТекущийЭлемент()=ТЗ.ТМЦ Тогда
    С.УстановитьАтрибут("Родитель",Род); 
    С.Удалить(0);    
       КонецЕсли;  КонецЦикла;
         
С.Записать();  
КонецЦикла;
КонецПроцедуры
 
 
   Эмблема форума
 
4 - 20.08.04 - 13:15
Вы чё? Не сможет она присвоить родителя ч/з УстановитьАтрибут() ...
   Michael99
 
8 - 20.08.04 - 13:40
(0) Чтото наворочено всего
Если для элементов из ТЗ надо присвоить нового родителя
То После того как с родителем определлилась:
СПР=СоздатьОбъект("Справочник.ТМЦ");
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()>0 Цикл
     Если СПР.НайтиЭлемент(ТЗ.ТМЦ)>0 Тогда
           СПР.Родитель=Род;
           СПР.Записать();
     КонецЕсли;
КонецЦикла;
И с удалением не очень понятно.
   SnarkHunter
 
9 - 20.08.04 - 13:50
(8)Это не удаление, а пометка на удаление... Переносит ненужные в определенную группу и помечает на удаление...
   Michael99
 
10 - 20.08.04 - 13:54
(9) Это я понял , а смысл переноса в группу ?
чтоб помучались :-) Тогда после СПР.Записать() - СПР.Удалить(0);
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует