Вход | Регистрация

1С:Предприятие ::

Метки:запросы, Запросы и построители

Запрос к журналу расчётов

Я
   m_arhangel
 
16.08.04 - 21:11
Привет ВСЕМ!!!
Помагите пожалуйста:
Надо создать отчёт о ЗП сотрудников по месецам в таком виде:
--------------------------------------------------------------------------
|                      |         Месяц                              |
|Сотрудник      |-------------------------------------------------|
|                      |     1     |     2     |    ...    |    12     |
--------------------------------------------------------------------------
|                      |            |           |            |            |
--------------------------------------------------------------------------


Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб, ДатаКон;
    ДатаКон = КонГода(ДатаАктуал);
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)

    |Период с ДатаАктуал по ДатаКон;
    |Объект = ЖурналРасчетов.ЗарплатаАгентов.Объект;
    |ПериодДействия = ЖурналРасчетов.ЗарплатаАгентов.ПериодДействия;
    |Результат = ЖурналРасчетов.ЗарплатаАгентов.Результат;
    |Функция РезультатСумма = Сумма(Результат);
    |Группировка Объект упорядочить по Объект.Наименование все;
    |Группировка ПериодДействия все;
    |";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;  
    Таб=СоздатьОБъект("Таблица"); 
    Таб.ИсходнаяТаблица("Таб");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Таб.ВывестиСекцию("Шапка");                                                    
    Пока Запрос.Группировка("Объект")=1 Цикл
        Таб.ВывестиСекцию("Сотр|Лево"); 
        Пока Запрос.Группировка("ПериодДействия")=1 Цикл    
             Таб.ПрисоединитьСекцию("Сотр|Месяц"); 
        КонецЦикла;    
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры    

Допустим до августа у сотрудника не была зарплаты вообще.
Почему у этого сотрудника августовская зарплата выводится в первом (Январь) столбце?
 
 
   GrayT
 
1 - 16.08.04 - 22:26
Собственно говоря ты сам ответил на свой вопрос. Если с 1-7 месяцы зарплаты нет, то нужно вывести (присоеденить) пустые колонки.
   m_arhangel
 
2 - 16.08.04 - 23:50
(1) Да нужно, причём обезательно. А иначе как заголовок вывести? Там же в ячейке сотрудни обьеденены две строки...
   NS
 
3 - 17.08.04 - 00:40
И кто-же их объел?
   m_arhangel
 
4 - 17.08.04 - 14:21
(3) Непонял?


Список тем форума
Рекламное место пустует  
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует